aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2003-03-25 21:09:07 +0800
committernobutaka <nobutaka@FreeBSD.org>2003-03-25 21:09:07 +0800
commit46477961c91b4e96ae7f8910492aae01f9f3ae59 (patch)
tree5ad52edffe950ceaae2d86d423df10bf25cc3f3f /multimedia
parent4a2bbc6ee638bd2f004b058b9d423693b2278d68 (diff)
downloadfreebsd-ports-gnome-46477961c91b4e96ae7f8910492aae01f9f3ae59.tar.gz
freebsd-ports-gnome-46477961c91b4e96ae7f8910492aae01f9f3ae59.tar.zst
freebsd-ports-gnome-46477961c91b4e96ae7f8910492aae01f9f3ae59.zip
Update to 0.9.19.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/xine/Makefile5
-rw-r--r--multimedia/xine/distinfo2
-rw-r--r--multimedia/xine/files/patch-ltmain.sh34
-rw-r--r--multimedia/xine/files/patch-src:xitk:network.c22
-rw-r--r--multimedia/xine/files/patch-src:xitk:session.c4
5 files changed, 19 insertions, 48 deletions
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 7e57960b28f8..df0ec45407b8 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xine
-PORTVERSION= 0.9.18
-PORTREVISION= 1
+PORTVERSION= 0.9.19
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +15,7 @@ DISTNAME= ${PORTNAME}-ui-${PORTVERSION}
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= An X11 multimedia player
-LIB_DEPENDS= xine.4:${PORTSDIR}/multimedia/libxine \
+LIB_DEPENDS= xine.5:${PORTSDIR}/multimedia/libxine \
aa.1:${PORTSDIR}/graphics/aalib \
png.5:${PORTSDIR}/graphics/png \
intl.4:${PORTSDIR}/devel/gettext
diff --git a/multimedia/xine/distinfo b/multimedia/xine/distinfo
index fff8c4e48552..ae54c54b7340 100644
--- a/multimedia/xine/distinfo
+++ b/multimedia/xine/distinfo
@@ -1 +1 @@
-MD5 (xine-ui-0.9.18.tar.gz) = 7aaabeb4cac95f66000741f970a17eca
+MD5 (xine-ui-0.9.19.tar.gz) = 6d502c8743659097ad0cf04cd21b70b1
diff --git a/multimedia/xine/files/patch-ltmain.sh b/multimedia/xine/files/patch-ltmain.sh
index c65b12a2d188..4eddb3f75fb4 100644
--- a/multimedia/xine/files/patch-ltmain.sh
+++ b/multimedia/xine/files/patch-ltmain.sh
@@ -1,6 +1,6 @@
---- ltmain.sh.orig Wed Jan 16 09:00:24 2002
-+++ ltmain.sh Tue Jan 29 10:33:29 2002
-@@ -958,6 +958,7 @@
+--- ltmain.sh.orig Sun Mar 9 08:51:33 2003
++++ ltmain.sh Sun Mar 9 23:40:14 2003
+@@ -956,6 +956,7 @@
;;
-avoid-version)
@@ -8,33 +8,7 @@
avoid_version=yes
continue
;;
-@@ -1045,14 +1046,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2459,7 +2460,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4247,10 +4248,12 @@
+@@ -4210,10 +4211,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/multimedia/xine/files/patch-src:xitk:network.c b/multimedia/xine/files/patch-src:xitk:network.c
index 866486e61c4e..0a15ecf9ef57 100644
--- a/multimedia/xine/files/patch-src:xitk:network.c
+++ b/multimedia/xine/files/patch-src:xitk:network.c
@@ -1,12 +1,10 @@
---- src/xitk/network.c.orig Fri Jun 28 23:03:50 2002
-+++ src/xitk/network.c Sat Jun 29 00:55:00 2002
-@@ -24,9 +24,6 @@
- */
- /* required for getsubopt(); the __sun test avoids compilation problems on */
- /* solaris */
--#ifndef __sun
--#define _XOPEN_SOURCE 500
--#endif
- /* required for strncasecmp() */
- #define _BSD_SOURCE 1
- /* required to enable POSIX variant of getpwuid_r on solaris */
+--- src/xitk/network.c.orig Mon Mar 3 23:43:41 2003
++++ src/xitk/network.c Tue Mar 25 00:10:12 2003
+@@ -48,6 +48,7 @@
+ #include <time.h>
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
++#include <sys/select.h>
+ #include <sys/stat.h>
+ #include <sys/signal.h>
+ #include <sys/time.h>
diff --git a/multimedia/xine/files/patch-src:xitk:session.c b/multimedia/xine/files/patch-src:xitk:session.c
index fa54d950ba07..56958fd87681 100644
--- a/multimedia/xine/files/patch-src:xitk:session.c
+++ b/multimedia/xine/files/patch-src:xitk:session.c
@@ -1,5 +1,5 @@
---- src/xitk/session.c.orig Sat Feb 1 21:23:01 2003
-+++ src/xitk/session.c Sat Feb 1 21:25:03 2003
+--- src/xitk/session.c.orig Mon Mar 3 23:43:45 2003
++++ src/xitk/session.c Tue Mar 25 00:11:39 2003
@@ -41,6 +41,7 @@
#include <sys/stat.h>
#include <sys/socket.h>
/td>-208/+175 * Fix build on 4.x.naddy2006-03-191-8/+19 * Fix a buffer overflow, caused by improper bounds checking of thenaddy2006-03-042-1/+125 * SHA256ifyedwin2006-01-221-0/+1 * Fix command line parsing.naddy2005-01-302-0/+18 * Update to 1.15.1. Notable changes:naddy2005-01-10