aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-12-17 00:49:17 +0800
committerrene <rene@FreeBSD.org>2018-12-17 00:49:17 +0800
commit4909b0f811cf5ad505666da55a2655041c78e236 (patch)
tree892baa84cc0c67b08795b6576e985d83e5a8f6d1 /multimedia
parent0a0c9722087f1a9b6e1d4506eed21bd6d9b3bcb5 (diff)
downloadfreebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.tar.gz
freebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.tar.zst
freebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.zip
Use regular DEPRECATED and EXPIRATION_DATE variables in an "if FLAVOR" block
instead of flavoring the variables themselves. This caused too much hassle for Tools/scripts/rmport. Discussed with: tcberner
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer1-qt/Makefile5
-rw-r--r--multimedia/phonon-designerplugin/Makefile5
-rw-r--r--multimedia/phonon-gstreamer/Makefile5
-rw-r--r--multimedia/phonon-vlc/Makefile5
-rw-r--r--multimedia/phonon/Makefile5
5 files changed, 10 insertions, 15 deletions
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
index bced1289990a..71f266e48435 100644
--- a/multimedia/gstreamer1-qt/Makefile
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -17,9 +17,6 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
CONFLICTS_INSTALL= gstreamer${PKGNAMESUFFIX}-*
USES= bison cmake:outsource gl gnome pathfix pkgconfig tar:xz
@@ -33,6 +30,8 @@ CMAKE_OFF= USE_GST_PLUGIN_DIR USE_QT_PLUGIN_DIR
CMAKE_ARGS= -DQT_VERSION=${FLAVOR:C/qt//}
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= corelib gui opengl declarative script \
qmake_build moc_build rcc_build uic_build qtestlib_build
diff --git a/multimedia/phonon-designerplugin/Makefile b/multimedia/phonon-designerplugin/Makefile
index b6a72ad957b5..669de2e013bd 100644
--- a/multimedia/phonon-designerplugin/Makefile
+++ b/multimedia/phonon-designerplugin/Makefile
@@ -18,12 +18,11 @@ FLAVOR?= ${FLAVORS:[1]}
qt4_PKGNAMESUFFIX= -designerplugin-qt4
qt5_PKGNAMESUFFIX= -designerplugin-qt5
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= cmake tar:xz
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= kde:4 qt:4
USE_QT= corelib designer gui phonon \
qmake_build moc_build rcc_build uic_build
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index c7ee439305c0..cc786a3fbfa5 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -22,9 +22,6 @@ qt5_PKGNAMESUFFIX= -${PHONON_PLUGIN}-qt5
qt4_PLIST= ${.CURDIR}/pkg-plist.qt4
qt5_PLIST= ${.CURDIR}/pkg-plist.qt5
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= cmake pkgconfig tar:xz
USE_GL= gl
USE_GNOME= glib20 libxml2
@@ -32,6 +29,8 @@ USE_GSTREAMER1= yes
USE_XORG= x11
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= kde:4 qt:4
USE_KDE= automoc4
USE_QT= corelib gui opengl phonon \
diff --git a/multimedia/phonon-vlc/Makefile b/multimedia/phonon-vlc/Makefile
index f11c2a2d41d6..c75a2f7a2fc1 100644
--- a/multimedia/phonon-vlc/Makefile
+++ b/multimedia/phonon-vlc/Makefile
@@ -21,12 +21,11 @@ FLAVOR?= ${FLAVORS:[1]}
qt4_LIB_DEPENDS= libvlc.so:multimedia/vlc-qt4
qt5_LIB_DEPENDS= libvlc.so:multimedia/vlc3
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= cmake:outsource pkgconfig tar:xz
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= kde:4 qt:4
USE_KDE= automoc4
USE_QT= corelib gui phonon \
diff --git a/multimedia/phonon/Makefile b/multimedia/phonon/Makefile
index 3159812f0663..3e3f3cdeb388 100644
--- a/multimedia/phonon/Makefile
+++ b/multimedia/phonon/Makefile
@@ -23,9 +23,6 @@ qt5_PKGNAMESUFFIX= -qt5
qt4_PLIST= ${.CURDIR}/pkg-plist.qt4
qt5_PLIST= ${.CURDIR}/pkg-plist.qt5
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= cmake compiler:c++11-lang pathfix tar:xz
CMAKE_ON= PHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT \
PHONON_NO_PLATFORMPLUGIN
@@ -33,6 +30,8 @@ CMAKE_OFF= PHONON_BUILD_DESIGNER_PLUGIN:BOOL=OFF
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= kde:4 qt:4
USE_KDE= automoc4
USE_QT= corelib dbus declarative gui testlib \