aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2010-10-08 21:10:42 +0800
committerbeat <beat@FreeBSD.org>2010-10-08 21:10:42 +0800
commit4d8bcad1d1bb56092f5b26fb9ad70231c74747b7 (patch)
tree9be59e7b1ad17dd44ad94291af83109d6ed821f7 /multimedia
parent052c6c544a83d44857d0efd2ff043320f1822192 (diff)
downloadfreebsd-ports-gnome-4d8bcad1d1bb56092f5b26fb9ad70231c74747b7.tar.gz
freebsd-ports-gnome-4d8bcad1d1bb56092f5b26fb9ad70231c74747b7.tar.zst
freebsd-ports-gnome-4d8bcad1d1bb56092f5b26fb9ad70231c74747b7.zip
- Fix build on PowerPC
PR: ports/149913 Submitted by: andreast Approved by: maintainer timeout
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/files/patch-configure9
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-Makefile11
2 files changed, 20 insertions, 0 deletions
diff --git a/multimedia/mplayer/files/patch-configure b/multimedia/mplayer/files/patch-configure
index ff5a23391cc1..105de46649ec 100644
--- a/multimedia/mplayer/files/patch-configure
+++ b/multimedia/mplayer/files/patch-configure
@@ -101,3 +101,12 @@
# TODO add some check
def_joystick='#define CONFIG_JOYSTICK 1'
else
+@@ -8560,7 +8555,7 @@
+ EXESUF = $_exesuf
+ EXESUFS_ALL = .exe
+
+-ARCH = $arch
++MPLAYER_ARCH = $arch
+ $(mak_enable "$arch_all" "$arch" ARCH)
+ $(mak_enable "$subarch_all" "$subarch" ARCH)
+ $(mak_enable "$cpuexts_all" "$cpuexts" HAVE)
diff --git a/multimedia/mplayer/files/patch-libavcodec-Makefile b/multimedia/mplayer/files/patch-libavcodec-Makefile
new file mode 100644
index 000000000000..dc3335363e3b
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavcodec-Makefile
@@ -0,0 +1,11 @@
+--- libavcodec/Makefile.orig 2010-09-26 20:31:26.000000000 +0200
++++ libavcodec/Makefile 2010-09-26 20:31:52.000000000 +0200
+@@ -608,7 +608,7 @@
+
+ OBJS-$(CONFIG_MLIB) += mlib/dsputil_mlib.o \
+
+--include $(SUBDIR)$(ARCH)/Makefile
++-include $(SUBDIR)$(MPLAYER_ARCH)/Makefile
+
+ SKIPHEADERS = %_tablegen.h
+ SKIPHEADERS-$(CONFIG_DXVA2) += dxva2.h dxva2_internal.h