aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-08-19 00:52:59 +0800
committerfeld <feld@FreeBSD.org>2016-08-19 00:52:59 +0800
commit5ab3faa1c84c63e12f152f930c31e29b3c2f2a08 (patch)
treeba83ec90a00bc954e90050e877a1999d3f64d52d /multimedia
parent97b005a87d75e892cb75515104cadd5dcd550a1a (diff)
downloadfreebsd-ports-gnome-5ab3faa1c84c63e12f152f930c31e29b3c2f2a08.tar.gz
freebsd-ports-gnome-5ab3faa1c84c63e12f152f930c31e29b3c2f2a08.tar.zst
freebsd-ports-gnome-5ab3faa1c84c63e12f152f930c31e29b3c2f2a08.zip
multimedia/plexmediaserver: Change the way binaries are stripped
This is a master port with the PlexPass port as the slave. Calling strip directly on files is problematic when they change or are moved in updates to the slave port. This is a no-op for this port but prevents errors in the slave port from trying to call strip on files that no longer exist or have moved.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/plexmediaserver/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/multimedia/plexmediaserver/Makefile b/multimedia/plexmediaserver/Makefile
index 1fc9b39fb705..a4ac29e77478 100644
--- a/multimedia/plexmediaserver/Makefile
+++ b/multimedia/plexmediaserver/Makefile
@@ -42,7 +42,8 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:misc/compat9x
post-patch:
# binaries don't come pre-stripped
${FIND} ${WRKSRC}/Resources -name '*.so' -exec ${STRIP_CMD} {} \+
- ${STRIP_CMD} ${WRKSRC}/lib* ${WRKSRC}/Resources/Plex*
+ ${FIND} ${WRKSRC} ${WRKSRC}/Resources -name 'Plex*' -depth 1 -exec ${STRIP_CMD} {} \+
+ ${FIND} ${WRKSRC} -depth 1 -name 'lib*' -exec ${STRIP_CMD} {} \+
${RM} ${WRKSRC}/start.sh
# Older verisons of Plex we have to create a symlink
# Newer versions of Plex ship a duplicate file; we'll just symlink