aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-22 02:00:38 +0800
committerwg <wg@FreeBSD.org>2013-10-22 02:00:38 +0800
commit6b7dcc5f4980cf369e69900697c08ef42042648a (patch)
tree9dc4df1bf0e3daf103bc869f8401475d3a414603 /multimedia
parent19df2b97bc3621a8d5097dd0c0d326c0d9851853 (diff)
downloadfreebsd-ports-gnome-6b7dcc5f4980cf369e69900697c08ef42042648a.tar.gz
freebsd-ports-gnome-6b7dcc5f4980cf369e69900697c08ef42042648a.tar.zst
freebsd-ports-gnome-6b7dcc5f4980cf369e69900697c08ef42042648a.zip
multimedia/mpv: use ffmpeg instead of ffmpeg1
- Use ffmpeg instead of ffmpeg1 Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpv/Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index dd26d0eacffd..0c1e6d90c6ae 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mpv
PORTVERSION= 20130711
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= LOCAL/gblach/
@@ -13,9 +14,9 @@ LICENSE= GPLv3
LIB_DEPENDS= ass:${PORTSDIR}/multimedia/libass \
dvdread:${PORTSDIR}/multimedia/libdvdread
-BUILD_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1 \
+BUILD_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
rst2man:${PORTSDIR}/textproc/py-docutils
-RUN_DEPENDS= ffmpeg1:${PORTSDIR}/multimedia/ffmpeg1
+RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
USE_XZ= yes
USES= gmake iconv pkgconfig
@@ -25,10 +26,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--mandir=${PREFIX}/man \
--cc=${CC} \
--extra-cflags=' \
- -I${LOCALBASE}/include/ffmpeg1 \
-I${LOCALBASE}/include' \
--extra-ldflags=' \
- -L${LOCALBASE}/lib/ffmpeg1 \
-L${LOCALBASE}/lib' \
--disable-mng \
--disable-mpg123 \
@@ -154,16 +153,6 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
@${REINPLACE_CMD} \
- -e 's/libavutil/libavutil1/' \
- -e 's/libavcodec/libavcodec1/' \
- -e 's/libavdevice/libavdevice1/' \
- -e 's/libavformat/libavformat1/' \
- -e 's/libavresample/libavresample1/' \
- -e 's/libpostproc/libpostproc1/' \
- -e 's/libswscale/libswscale1/' \
- -e 's/libswresample/libswresample1/' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} \
-e 's|/dev/acd0|/dev/cd0|' \
-e 's|-lncurses|/usr/lib/libncurses.so|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}