aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-01-12 16:51:04 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2018-01-12 16:51:04 +0800
commit6e7aeedc03045e5a49a2deffb636a92baa29f743 (patch)
tree9b6714b13a0c92bc210c3b9322b53465a5432f02 /multimedia
parent86431e1c3cac229c824bf377cb399d192dc468bc (diff)
downloadfreebsd-ports-gnome-6e7aeedc03045e5a49a2deffb636a92baa29f743.tar.gz
freebsd-ports-gnome-6e7aeedc03045e5a49a2deffb636a92baa29f743.tar.zst
freebsd-ports-gnome-6e7aeedc03045e5a49a2deffb636a92baa29f743.zip
multimedia/handbrake: Make Python 2.7 build dependency explicit
Handbrake has a hard build dependency on Python 2.7 and calls python2 during the build. However lang/python2 might not be installed in the build environment (e.g. with OPTIONS_UNSET=CUPS). python2 /wrkdirs/usr/ports/multimedia/handbrake/work/HandBrake-1.0.7/build/../gtk/src/makedeps.py gmake[4]: python2: Command not found gmake[4]: *** [Makefile:866: widget.deps] Error 127 gmake[4]: Leaving directory '/wrkdirs/usr/ports/multimedia/handbrake/work/HandBrake-1.0.7/build/gtk/src'
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/handbrake/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 369c2eca8883..46cb3e7dfb74 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -64,7 +64,7 @@ LIB_DEPENDS+= libdvdcss.so:multimedia/libdvdcss
GNU_CONFIGURE= yes
USE_GCC= yes
USES= autoreconf:build compiler:features gmake iconv \
- libtool:build localbase:ldflags pkgconfig python:build
+ libtool:build localbase:ldflags pkgconfig python:2.7,build
MAKE_ENV= V=1 ACLOCAL=${LOCALBASE}/bin/aclocal
CONFIGURE_ARGS= --force --enable-x265
@@ -124,6 +124,10 @@ post-extract: .SILENT
${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSRC}/download
.endfor
+post-patch:
+ @${REINPLACE_CMD} 's@python2 @${PYTHON_CMD} @' \
+ ${WRKSRC}/gtk/src/Makefile.am
+
post-install-X11-on:
${LN} -sf ghb ${STAGEDIR}${PREFIX}/bin/HandBrake