aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2014-03-25 18:06:55 +0800
committerdecke <decke@FreeBSD.org>2014-03-25 18:06:55 +0800
commit76ea309fc064fe3c961ad4e1f62695c40cf016d2 (patch)
tree0e8b3062bbea13d851e92aff8728ebd57562adb6 /multimedia
parent2b4f16b731f80f386d6e44db52962275b18671be (diff)
downloadfreebsd-ports-gnome-76ea309fc064fe3c961ad4e1f62695c40cf016d2.tar.gz
freebsd-ports-gnome-76ea309fc064fe3c961ad4e1f62695c40cf016d2.tar.zst
freebsd-ports-gnome-76ea309fc064fe3c961ad4e1f62695c40cf016d2.zip
- Make sure libavcodec builds MD code
- Bump PORTREVISION PR: ports/187836 Submitted by: Jan Beich <jbeich@tormail.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mythtv-frontend/Makefile2
-rw-r--r--multimedia/mythtv-frontend/files/patch-external__FFmpeg__configure9
-rw-r--r--multimedia/mythtv/Makefile2
-rw-r--r--multimedia/mythtv/files/patch-external__FFmpeg__configure9
4 files changed, 4 insertions, 18 deletions
diff --git a/multimedia/mythtv-frontend/Makefile b/multimedia/mythtv-frontend/Makefile
index 131c67341051..2d46a0b68a79 100644
--- a/multimedia/mythtv-frontend/Makefile
+++ b/multimedia/mythtv-frontend/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mythtv-frontend
PORTVERSION= 0.27.0.20140121
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://people.freebsd.org/~decke/distfiles/
DISTNAME= mythtv-${PORTVERSION}
@@ -28,6 +29,7 @@ GH_COMMIT= 5a5e1cd
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/${GH_PROJECT}
ONLY_FOR_ARCHS= i386 amd64
+NOPRECIOUSMAKEVARS= # don't override $(ARCH) in ffmpeg makefiles
USES= gmake pkgconfig
USE_QT4= gui sql network script linguist_build l10n sql-mysql_run \
moc_build qmake_build rcc_build uic_build
diff --git a/multimedia/mythtv-frontend/files/patch-external__FFmpeg__configure b/multimedia/mythtv-frontend/files/patch-external__FFmpeg__configure
index 8fe0073fafd3..cc641f1e2028 100644
--- a/multimedia/mythtv-frontend/files/patch-external__FFmpeg__configure
+++ b/multimedia/mythtv-frontend/files/patch-external__FFmpeg__configure
@@ -20,12 +20,3 @@
;;
# targets that do support conditional mov but on which it's slow
pentium4|pentium4m|prescott|nocona)
-@@ -3063,7 +3063,7 @@
- SRC_PATH_BARE=$source_path
- BUILD_ROOT="$PWD"
- CC_IDENT=$cc_ident
--ARCH=$arch
-+FFMPEG_ARCH=$arch
- CC=$cc
- AS=$as
- LD=$ld
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 0d4c419c23a3..a83986ed1de7 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mythtv
PORTVERSION= 0.27.0.20140121
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://people.freebsd.org/~decke/distfiles/
@@ -28,6 +29,7 @@ GH_COMMIT= 5a5e1cd
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}/${GH_PROJECT}
ONLY_FOR_ARCHS= i386 amd64
+NOPRECIOUSMAKEVARS= # don't override $(ARCH) in ffmpeg makefiles
USES= gmake pkgconfig perl5
USE_QT4= gui sql network script linguist_build l10n sql-mysql_run \
moc_build qmake_build rcc_build uic_build imageformats
diff --git a/multimedia/mythtv/files/patch-external__FFmpeg__configure b/multimedia/mythtv/files/patch-external__FFmpeg__configure
index 8fe0073fafd3..cc641f1e2028 100644
--- a/multimedia/mythtv/files/patch-external__FFmpeg__configure
+++ b/multimedia/mythtv/files/patch-external__FFmpeg__configure
@@ -20,12 +20,3 @@
;;
# targets that do support conditional mov but on which it's slow
pentium4|pentium4m|prescott|nocona)
-@@ -3063,7 +3063,7 @@
- SRC_PATH_BARE=$source_path
- BUILD_ROOT="$PWD"
- CC_IDENT=$cc_ident
--ARCH=$arch
-+FFMPEG_ARCH=$arch
- CC=$cc
- AS=$as
- LD=$ld