aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-31 22:17:52 +0800
committerpav <pav@FreeBSD.org>2004-03-31 22:17:52 +0800
commit77ead8e7f0f1e9f02410c3652b4d2cc5d0a07663 (patch)
tree808f6fb7357fcd030aa0523f3fc72a1b63dad827 /multimedia
parenta03c49f0a300a5afbf3267c224eca33f87dc21fa (diff)
downloadfreebsd-ports-gnome-77ead8e7f0f1e9f02410c3652b4d2cc5d0a07663.tar.gz
freebsd-ports-gnome-77ead8e7f0f1e9f02410c3652b4d2cc5d0a07663.tar.zst
freebsd-ports-gnome-77ead8e7f0f1e9f02410c3652b4d2cc5d0a07663.zip
Add lsdvd, a small utility to list content of DVD in human readable form.
PR: ports/64962 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/lsdvd/Makefile49
-rw-r--r--multimedia/lsdvd/distinfo2
-rw-r--r--multimedia/lsdvd/pkg-descr3
4 files changed, 55 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 17eda078f804..084fec3514a1 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -55,6 +55,7 @@
SUBDIR += linux-divxplayer
SUBDIR += linux-realplayer
SUBDIR += linux-xmovie
+ SUBDIR += lsdvd
SUBDIR += mjpegtools
SUBDIR += mkvtoolnix
SUBDIR += mkxvcd
diff --git a/multimedia/lsdvd/Makefile b/multimedia/lsdvd/Makefile
new file mode 100644
index 000000000000..591a3dab192d
--- /dev/null
+++ b/multimedia/lsdvd/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: lsdvd
+# Date created: 2004-03-30
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lsdvd
+PORTVERSION= 0.10
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= acidrip
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Print information about the contents and structure of a DVD
+
+LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+PLIST_FILES= bin/lsdvd
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DVD_DEVICE)
+DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
+.else
+.if ${OSVERSION} < 500000
+DEFAULT_DVD_DEVICE=/dev/acd0c
+.else
+DEFAULT_DVD_DEVICE=/dev/acd0
+.endif
+.endif
+
+pre-everything::
+.if !defined(WITH_DVD_DEVICE)
+ @${ECHO_MSG} "===> The default DVD device is ${DEFAULT_DVD_DEVICE}"
+ @${ECHO_MSG} "===> Define WITH_DVD_DEVICE if you want to change the default"
+ @${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
+ ${WRKSRC}/lsdvd.c
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/lsdvd/distinfo b/multimedia/lsdvd/distinfo
new file mode 100644
index 000000000000..8bd86e025c58
--- /dev/null
+++ b/multimedia/lsdvd/distinfo
@@ -0,0 +1,2 @@
+MD5 (lsdvd-0.10.tar.gz) = 7fd659f8e26fd790ecc4903d7961985a
+SIZE (lsdvd-0.10.tar.gz) = 36206
diff --git a/multimedia/lsdvd/pkg-descr b/multimedia/lsdvd/pkg-descr
new file mode 100644
index 000000000000..8176167d35ae
--- /dev/null
+++ b/multimedia/lsdvd/pkg-descr
@@ -0,0 +1,3 @@
+Print information about the contents and structure of a DVD.
+
+WWW: http://acidrip.thirtythreeandathird.net/