aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-09-25 03:08:49 +0800
committermakc <makc@FreeBSD.org>2010-09-25 03:08:49 +0800
commit79100d4385e295a3d86e0bec07a055734344c5cf (patch)
tree252f64cd9e4adc8e36a29cbb2b92e6e82a6e8833 /multimedia
parentb895d5ec27908b19c0559b8d45d6b461fbc952a5 (diff)
downloadfreebsd-ports-gnome-79100d4385e295a3d86e0bec07a055734344c5cf.tar.gz
freebsd-ports-gnome-79100d4385e295a3d86e0bec07a055734344c5cf.tar.zst
freebsd-ports-gnome-79100d4385e295a3d86e0bec07a055734344c5cf.zip
Switch libvdpau dependency from x11/nvidia-driver to multimedia/libvdpau
PR: ports/150383 Submitted by: Anonymous <swell.k at gmail.com> Approved by: maintainer
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mythtv-frontend/Makefile5
-rw-r--r--multimedia/mythtv/Makefile5
3 files changed, 5 insertions, 7 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 677c5ab83e0b..96bf4f94a9fc 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -145,7 +145,7 @@ CONFIGURE_ARGS+=--disable-x11 \
.endif
.if defined(WITH_VDPAU)
-LIB_DEPENDS+= vdpau.1:${PORTSDIR}/x11/nvidia-driver
+LIB_DEPENDS+= vdpau.1:${PORTSDIR}/multimedia/libvdpau
.else
CONFIGURE_ARGS+= --disable-vdpau
.endif
diff --git a/multimedia/mythtv-frontend/Makefile b/multimedia/mythtv-frontend/Makefile
index b1e7756bd68f..262075c2c9f9 100644
--- a/multimedia/mythtv-frontend/Makefile
+++ b/multimedia/mythtv-frontend/Makefile
@@ -17,14 +17,13 @@ COMMENT= MythTV is a homebrew PVR project
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
freetype.9:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${QT_PREFIX}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin
CONFLICTS= mythtv-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_QT_VER= 4
-QT_COMPONENTS= gui sql network script linguist_build l10n \
+QT_COMPONENTS= gui sql network script linguist_build l10n sql-mysql_run \
moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
USE_GMAKE= yes
@@ -80,7 +79,7 @@ CONFIGURE_ARGS+= --disable-audio-pulseoutput
.endif
.if defined(WITH_VDPAU)
-LIB_DEPENDS+= vdpau.1:${PORTSDIR}/x11/nvidia-driver
+LIB_DEPENDS+= vdpau.1:${PORTSDIR}/multimedia/libvdpau
CONFIGURE_ARGS+= --enable-vdpau
.else
CONFIGURE_ARGS+= --disable-vdpau
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 920f69656195..17a2ef0c5d7e 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
BUILD_DEPENDS= v4l_compat>=1.0.20100321:${PORTSDIR}/multimedia/v4l_compat \
${SITE_PERL}/${PERL_ARCH}/XML/Parser/Expat.pm:${PORTSDIR}/textproc/p5-XML-SAX-Expat
RUN_DEPENDS= tv_check:${PORTSDIR}/textproc/p5-xmltv \
- ${QT_PREFIX}/lib/qt4/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt4-mysql-plugin \
wget:${PORTSDIR}/ftp/wget
CONFLICTS= mythtv-frontend-[0-9]*
@@ -28,7 +27,7 @@ CONFLICTS= mythtv-frontend-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_QT_VER= 4
-QT_COMPONENTS= gui sql network script linguist_build l10n \
+QT_COMPONENTS= gui sql network script linguist_build l10n sql-mysql_run \
moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
USE_MYSQL= 51
@@ -84,7 +83,7 @@ CONFIGURE_ARGS+= --disable-opengl-video --disable-opengl-vsync
.endif
.if defined(WITH_VDPAU)
-LIB_DEPENDS+= vdpau.1:${PORTSDIR}/x11/nvidia-driver
+LIB_DEPENDS+= vdpau.1:${PORTSDIR}/multimedia/libvdpau
CONFIGURE_ARGS+= --enable-vdpau
.else
CONFIGURE_ARGS+= --disable-vdpau