aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-04-18 23:07:38 +0800
committerriggs <riggs@FreeBSD.org>2014-04-18 23:07:38 +0800
commit798483cecdb9602e1cbdd83beab738b512e2c635 (patch)
tree9f0635b6d6eab58235f187bc92e71829663dcafc /multimedia
parentc49d94d08a85e2f3c0166ed46ba20b8c3a1795a8 (diff)
downloadfreebsd-ports-gnome-798483cecdb9602e1cbdd83beab738b512e2c635.tar.gz
freebsd-ports-gnome-798483cecdb9602e1cbdd83beab738b512e2c635.tar.zst
freebsd-ports-gnome-798483cecdb9602e1cbdd83beab738b512e2c635.zip
- Bring back VPX option, thus fixing potential (de-)install dependencies
- Handle UTF-8 charset properly in libvo - Bump PORTREVISION PR: ports/188657, ports/188697 Submitted by: anonymous <anonymous@gmail.com> Approved by: jadawin (co-mentor) MFH: 2014Q2
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile2
-rw-r--r--multimedia/mplayer/Makefile4
-rw-r--r--multimedia/mplayer/files/patch-libvo-x11_common.c10
3 files changed, 13 insertions, 3 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index 60334d74781d..fdd331e8d99f 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Convenient video file and movie encoder
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 0e67dddde693..28ad7691bd9a 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= High performance media player supporting many formats
@@ -14,7 +14,7 @@ OPTIONS_DEFINE= AALIB AMR_NB AMR_WB BLURAY CACA DEBUG DV \
LADSPA LIBMNG LIRC LZO NAS OCFLAGS \
OPENAL OPENGL OPENJPEG OPUS OTCHAIN \
PULSEAUDIO REAL RTC RTCPU RTMP SCHROEDINGER SDL \
- SKINS SMB SVGALIB V4L VDPAU WIN32 \
+ SKINS SMB SVGALIB V4L VDPAU VPX WIN32 \
X11 X11DGA X11VM XINERAMA XVIDEO XVMC
OPTIONS_RADIO= RGCD
diff --git a/multimedia/mplayer/files/patch-libvo-x11_common.c b/multimedia/mplayer/files/patch-libvo-x11_common.c
new file mode 100644
index 000000000000..24e8e08c986f
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libvo-x11_common.c
@@ -0,0 +1,10 @@
+--- libvo/x11_common.c 2013-10-16 17:07:12.000000000 -0700
++++ libvo/x11_common.c 2014-04-16 09:15:27.888658589 -0700
+@@ -430,7 +430,7 @@
+ }
+
+ // Required so that XLookupString returns UTF-8
+- if (!setlocale(LC_CTYPE, "C.UTF-8") && !setlocale(LC_CTYPE, "en_US.utf8"))
++ if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
+ mp_msg(MSGT_VO, MSGL_WARN, "Could not find a UTF-8 locale, some keys will not be handled.\n");
+ XSetErrorHandler(x11_errorhandler);