aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-01-31 02:08:56 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2021-01-31 02:08:56 +0800
commit7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f (patch)
tree713fa1b8e4fb42290a607fc6c42e2fb1e1f72ed5 /multimedia
parent33809b22ade1a5f4c057fc465145e9a1ca12d82c (diff)
downloadfreebsd-ports-gnome-7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f.tar.gz
freebsd-ports-gnome-7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f.tar.zst
freebsd-ports-gnome-7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f.zip
graphics/opencv: update to 4.5.1 -- and make port more easily maintainable
This is a major upgrade from 3.x to 4.x. Changelog from versions 3.4.1--4.5.1 can be found here: https://github.com/opencv/opencv/wiki/ChangeLog Note: this has explicitely not been added as a new graphics/opencv4 port, but replaces the previous graphics/opencv[3] port. Again, to improve maintainability by not giving ports the option to pick the "wrong one" - this leads however to some abandoned ports being broken. The port has been greatly simplified: * graphics/opencv-core which existed to enable ffmpeg to depend on opencv, and vice versa has been removed. ffmpeg no longer can depend on opencv. * graphics/py-opencv has been integrated into graphics/opencv, the default versions python bindings will be built unless the PYTHON option is explicitely turned off. * graphics/opencv-java has been integrated into graphics/opencv -- it is off by default, but can be enabled by toggling the JAVA option -- there are no consumers in the tree, so that option might go away in the future. * All the previous options have been removed and replaced by a (hopefully) sane set of dependencies that make the port and package most usable for the majority of consumers. - Please let me know if you think there are better defaults (i.e. anything that is missing, or something that should not be dependet on). - If you think something should be added or removed, please open a bug report. - If you think something should be added as an optional dependency, please open a bug report (with a good reason [tm]). The depending ports have been updated to work against opencv4, or marked broken. * Ports broken: - graphics/rubygem-objectdetect: OpenCV4 no longer ships opencv-1.0 API - graphics/p5-Image-ObjectDetect: OpenCV4 no longer ships opencv-1.0 API - graphics/gimp-gmic-plugin: OpenCV4 no longer ships opencv-1.0 API * Backports: - misc/visp: https://github.com/lagadic/visp/commit/dfa7e4bd47c24cd2e631477e6afb18806733ff8a - multimedia/zart: https://github.com/c-koi/zart/commit/6ca1964690afbbc78627d7c868a692401043a584, https://github.com/c-koi/zart/commit/d3a2931b1a07ec0322211f253468000363c4b6cb * Others: - misc/actiona: switch to pkgconfig 'opencv4' - multimedia/libav: drop opencv support - misc/darknet: already failed to build prior to the upgrade - math/saga: remove patching added to work against opencv3
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ccextractor/Makefile4
-rw-r--r--multimedia/chilitags/Makefile5
-rw-r--r--multimedia/ffmpeg/Makefile14
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common3
-rw-r--r--multimedia/libav/Makefile10
-rw-r--r--multimedia/lives/Makefile4
-rw-r--r--multimedia/zart/Makefile7
-rw-r--r--multimedia/zart/distinfo4
-rw-r--r--multimedia/zart/files/patch-zart.pro11
9 files changed, 31 insertions, 31 deletions
diff --git a/multimedia/ccextractor/Makefile b/multimedia/ccextractor/Makefile
index fc937324c57d..4a3f6915cb96 100644
--- a/multimedia/ccextractor/Makefile
+++ b/multimedia/ccextractor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ccextractor
DISTVERSIONPREFIX= v
DISTVERSION= 0.85
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= multimedia
MAINTAINER= oz@nixil.net
@@ -16,7 +16,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libgmp.so:math/gmp \
libgnutls.so:security/gnutls \
libogg.so:audio/libogg \
- libopencv_core.so:graphics/opencv-core \
+ libopencv_core.so:graphics/opencv \
libpng.so:graphics/png \
libschroedinger-1.0.so:multimedia/schroedinger \
libtheoraenc.so:multimedia/libtheora \
diff --git a/multimedia/chilitags/Makefile b/multimedia/chilitags/Makefile
index 3f704d28d834..9615c13790d4 100644
--- a/multimedia/chilitags/Makefile
+++ b/multimedia/chilitags/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chilitags
DISTVERSION= 2.0.0-169
DISTVERSIONSUFFIX= -g0d9854f
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
@@ -12,8 +12,7 @@ COMMENT= Robust fiducial markers for augmented reality and robotics
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/gpl.txt
-LIB_DEPENDS= libopencv_imgproc.so:graphics/opencv-core \
- libopencv_video.so:graphics/opencv
+LIB_DEPENDS= libopencv_video.so:graphics/opencv
USES= cmake compiler:c++11-lang
USE_GITHUB= yes
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index dc824526ab82..069dd0451b3d 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -39,7 +39,7 @@ OPTIONS_DEFINE= ALSA AMR_NB AMR_WB AOM ARIBB24 ASM ASS BS2B CACA CDIO CELT \
CODEC2 DAV1D DAVS2 DC1394 DEBUG DOCS DRM FDK_AAC FLITE \
FONTCONFIG FREETYPE FREI0R FRIBIDI GLSLANG GME GSM ICONV ILBC JACK \
KLVANC KVAZAAR LADSPA LAME LENSFUN LIBBLURAY LIBRSVG2 LIBXML2 \
- LTO LV2 MFX MODPLUG MYSOFA OPENAL OPENCL OPENCV OPENGL OPENH264 \
+ LTO LV2 MFX MODPLUG MYSOFA OPENAL OPENCL OPENGL OPENH264 \
OPENJPEG OPENMPT OPTIMIZED_CFLAGS OPUS POCKETSPHINX PULSEAUDIO \
RAV1E RABBITMQ RTCPU RUBBERBAND SDL SMB SNAPPY SNDIO SOXR SPEEX SRT SSH \
SVTAV1 SVTHEVC SVTVP9 TENSORFLOW TESSERACT THEORA TWOLAME V4L \
@@ -47,7 +47,7 @@ OPTIONS_DEFINE= ALSA AMR_NB AMR_WB AOM ARIBB24 ASM ASS BS2B CACA CDIO CELT \
WAVPACK WEBP X264 X265 XAVS2 XCB XVID XVIDEO ZIMG ZMQ ZVBI
OPTIONS_DEFAULT= AOM ASM ASS DAV1D DRM FONTCONFIG FREETYPE FREI0R GMP GNUTLS ICONV \
- LAME LIBXML2 OPENCV OPTIMIZED_CFLAGS OPUS RTCPU THEORA V4L VAAPI \
+ LAME LIBXML2 OPTIMIZED_CFLAGS OPUS RTCPU THEORA V4L VAAPI \
VDPAU VORBIS VPX X264 X265 XCB XVID
.if !exists(${.CURDIR:H:H}/multimedia/aribb24)
@@ -356,10 +356,6 @@ OPENCL_BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
OPENCL_LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
OPENCL_CONFIGURE_ENABLE= opencl
-# opencv
-OPENCV_LIB_DEPENDS= libopencv_imgproc.so:graphics/opencv-core
-OPENCV_CONFIGURE_ENABLE= libopencv
-
# opengl
OPENGL_USES= gl
OPENGL_USE= GL=gl
@@ -636,12 +632,6 @@ PORTDOCS= *
USE_GCC= yes
.endif
-post-patch:
-# {C,LD}FLAGS safeness
- @${REINPLACE_CMD} -E \
- -e 's|require_pkg_config opencv|require_pkg_config opencv-core|g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
post-install:
(cd ${WRKSRC} && ${COPYTREE_SHARE} \
"${DOC_FILES}" ${STAGEDIR}${DOCSDIR})
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index a96507b898f0..26cd314c3b90 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -380,8 +380,7 @@ gst_neon_PLIST_FILES= ${GST_LIB_DIR}/libgstneonhttpsrc.so
gst_ogg_LIB_DEPENDS= libogg.so:audio/libogg
# opencv
-gst_opencv_LIB_DEPENDS= libopencv_core.so:graphics/opencv-core \
- libopencv_highgui.so:graphics/opencv
+gst_opencv_LIB_DEPENDS= libopencv_highgui.so:graphics/opencv
gst_opencv_GST_PLUGIN_DIR= gst-libs/gst/opencv ext/opencv
gst_opencv_PLIST_FILES= #
gst_opencv_USES= compiler:c++11-lib
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index 39e616990454..e7bb5e75cd8f 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -15,8 +15,7 @@ BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ABS64
BROKEN_armv6= fails to compile: cc: warning: joined argument expects additional value: -mcpu=
BUILD_DEPENDS= yasm:devel/yasm
-LIB_DEPENDS= libopencv_core.so:graphics/opencv-core \
- libgmp.so:math/gmp \
+LIB_DEPENDS= libgmp.so:math/gmp \
libvdpau.so:multimedia/libvdpau \
libhogweed.so:security/nettle
@@ -43,11 +42,11 @@ CONFIGURE_ARGS= --prefix="${PREFIX}" \
--cc="${CC}"
OPTIONS_DEFINE= ALSA AMR_NB AMR_WB BZIP2 CDIO FAAC FDK_AAC DC1394 DOCS FREETYPE \
- FREI0R GNUTLS GSM ILBC JACK LAME OPENCV OPENJPEG OPENSSL \
+ FREI0R GNUTLS GSM ILBC JACK LAME OPENJPEG OPENSSL \
OPUS PULSEAUDIO RTMP SCHROEDINGER SDL SPEEX THEORA V4L VAAPI \
VDPAU VO_AACENC VO_AMRWBENC VORBIS VPX WAVPACK WEBP X11GRAB \
X264 XVID ZLIB
-OPTIONS_DEFAULT=BZIP2 FREETYPE FREI0R GNUTLS OPENCV SCHROEDINGER \
+OPTIONS_DEFAULT=BZIP2 FREETYPE FREI0R GNUTLS SCHROEDINGER \
THEORA VAAPI VDPAU VO_AACENC VORBIS VPX X264 XVID ZLIB
FDK_AAC_DESC= AAC audio encoding via Fraunhofer FDK
@@ -106,9 +105,6 @@ JACK_CONFIGURE_OFF= --disable-indev=jack
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
LAME_CONFIGURE_ENABLE= libmp3lame
-OPENCV_LIB_DEPENDS= libopencv_video.so:graphics/opencv
-OPENCV_CONFIGURE_ENABLE= libopencv
-
OPENJPEG_LIB_DEPENDS= libopenjpeg.so:graphics/openjpeg15
OPENJPEG_CONFIGURE_ENABLE= libopenjpeg
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index 15848f69dd67..07df5f5d1d2b 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lives
DISTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://lives-video.com/releases/
DISTNAME= LiVES-${PORTVERSION}
@@ -123,7 +123,7 @@ OGM_DESC= Use ogmtools for manipulating with OGM files
OGM_RUN_DEPENDS= ogmmerge:multimedia/ogmtools
OPENCV_CONFIGURE_OFF= --disable-opencv
OPENCV_LIB_DEPENDS= libopencv_calib3d.so:graphics/opencv \
- libopencv_core.so:graphics/opencv-core
+ libopencv_core.so:graphics/opencv
SCHROEDINGER_CONFIGURE_OFF= --disable-dirac
SCHROEDINGER_LIB_DEPENDS= libschroedinger-1.0.so:multimedia/schroedinger
SSWF_DESC= Use sswf for manipulating with Flash movies
diff --git a/multimedia/zart/Makefile b/multimedia/zart/Makefile
index f71bd30d5a34..8608afe2acce 100644
--- a/multimedia/zart/Makefile
+++ b/multimedia/zart/Makefile
@@ -2,10 +2,14 @@
PORTNAME= zart
PORTVERSION= g20191124
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= https://gmic.eu/files/source/:gmic
DISTFILES= gmic_${GMIC_VERSION}.tar.gz:gmic
+PATCH_SITES= https://github.com/c-koi/zart/commit/
+PATCHFILES= 6ca1964690afbbc78627d7c868a692401043a584.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= GMIC GUI for video streams
@@ -15,8 +19,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libgmic.so:graphics/gmic \
- libopencv_core.so:graphics/opencv-core \
- libopencv_video.so:graphics/opencv \
+ libopencv_core.so:graphics/opencv \
libfftw3.so:math/fftw3
USES= compiler:c++11-lang pkgconfig qmake qt:5
diff --git a/multimedia/zart/distinfo b/multimedia/zart/distinfo
index 8777cd82ca23..ca97bde3e4a9 100644
--- a/multimedia/zart/distinfo
+++ b/multimedia/zart/distinfo
@@ -1,5 +1,7 @@
-TIMESTAMP = 1577251091
+TIMESTAMP = 1612027931
SHA256 (gmic_2.8.1.tar.gz) = 1a2b4c75c428201e52e920bd07e6c04118ae294cb89fce3c1c4ef386421b2a7a
SIZE (gmic_2.8.1.tar.gz) = 5995556
SHA256 (c-koi-zart-g20191124-099554f_GH0.tar.gz) = 667bb0730cc462f31659b33b66cbc521e94a321e4eea96d79ded2f6ee31b002e
SIZE (c-koi-zart-g20191124-099554f_GH0.tar.gz) = 293482
+SHA256 (6ca1964690afbbc78627d7c868a692401043a584.patch) = 00c749fd75b460e57f6ad99c44c6c9f81c66d88468dd79cf2698cf7f6282bb6a
+SIZE (6ca1964690afbbc78627d7c868a692401043a584.patch) = 1154
diff --git a/multimedia/zart/files/patch-zart.pro b/multimedia/zart/files/patch-zart.pro
new file mode 100644
index 000000000000..db8f6d7fe19f
--- /dev/null
+++ b/multimedia/zart/files/patch-zart.pro
@@ -0,0 +1,11 @@
+--- zart.pro.orig 2021-01-30 17:27:07 UTC
++++ zart.pro
+@@ -29,7 +29,7 @@ greaterThan(QT_MAJOR_VERSION, 4): CONFIG += c++11
+ CONFIG += warn_on
+ QT_CONFIG -= no-pkg-config
+ CONFIG += link_pkgconfig
+-PKGCONFIG += opencv fftw3 zlib
++PKGCONFIG += opencv4 fftw3 zlib
+ DEFINES += cimg_use_fftw3 cimg_use_zlib
+
+ DEFINES += QT_DEPRECATED_WARNINGS