aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-11-08 03:51:26 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-11-08 03:51:26 +0800
commit7ecb26d6c8781e290d74faebcf4ae31352c736f8 (patch)
tree336bd3a60df6fb376dad457b87c228a5c0b7bba3 /multimedia
parentf566a3d020d63f66bdd1301f5a227244f2c15da0 (diff)
downloadfreebsd-ports-gnome-7ecb26d6c8781e290d74faebcf4ae31352c736f8.tar.gz
freebsd-ports-gnome-7ecb26d6c8781e290d74faebcf4ae31352c736f8.tar.zst
freebsd-ports-gnome-7ecb26d6c8781e290d74faebcf4ae31352c736f8.zip
Gmerlin_avdecoder is a general purpose media decoding library. It
was written as a support library for gmerlin, but it can also be used by other applications. You don't even need gmerlin installed, only gavl. Most of it was written completely from scratch, but the sourcetrees of some other great software packages were used as reference documentation. Credits go to the authors of Xine, MPlayer, quicktime4linux and ffmpeg. Gmerlin_avdecoder is one of the most complete general purpose media decoding libraries. The supported formats and codecs span a wide range of applications from consumer level (mp3, divx etc.) to high end production formats like 32 bit PCM and some professional uncompressed video codecs. Using gmerlin_avdecoder in your playback for transcoding application means rock solid media format support with an ever growing list of supported codecs and formats. WWW: http://gmerlin.sourceforge.net/
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/gmerlin-avdecoder/Makefile181
-rw-r--r--multimedia/gmerlin-avdecoder/distinfo3
-rw-r--r--multimedia/gmerlin-avdecoder/files/patch-lib-libw32dll-wine-win32.c30
-rw-r--r--multimedia/gmerlin-avdecoder/pkg-descr18
-rw-r--r--multimedia/gmerlin-avdecoder/pkg-plist9
6 files changed, 242 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 50ed9e864e05..e8c64747cb7b 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -53,6 +53,7 @@
SUBDIR += gdvrecv
SUBDIR += ggrab
SUBDIR += gmencoder
+ SUBDIR += gmerlin-avdecoder
SUBDIR += gmimms
SUBDIR += gnome-subtitles
SUBDIR += gnustep-mplayer
diff --git a/multimedia/gmerlin-avdecoder/Makefile b/multimedia/gmerlin-avdecoder/Makefile
new file mode 100644
index 000000000000..ff6d2fad58b1
--- /dev/null
+++ b/multimedia/gmerlin-avdecoder/Makefile
@@ -0,0 +1,181 @@
+# New ports collection makefile for: gmerlin-avdecoder
+# Date created: 07 Nov 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmerlin-avdecoder
+PORTVERSION= 0.1.8
+CATEGORIES= multimedia
+MASTER_SITES= SF/gmerlin
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= General purpose media decoding library
+
+LIB_DEPENDS= gavl.0:${PORTSDIR}/multimedia/gavl
+
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --without-cpuflags --without-doxygen --disable-gmerlin
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PORTDOCS= README
+
+OPTIONS= FFMPEG "Enable ffmpeg support" on \
+ THEORA "Enable theora support" on \
+ SPEEX "Enable speex support" on \
+ MJPEGTOOLS "Enable mjpegtools support" on \
+ VORBIS "Enable vorbis support" on \
+ MPEG2 "Enable MPEG2 support" on \
+ TIFF "Enable TIFF support" on \
+ SAMBA "Enable samba support" on \
+ PNG "Enable libpng support" on \
+ FAAD "Enabled FAAD2 support" on \
+ DVDREAD "Enable libdvdread support" on \
+ FLAC "Enable FLAC support" on \
+ MUSEPACK "Enable musepack (mpc) support" on \
+ MAD "Enable mp3 support" on \
+ A52 "Enable A52 support" on \
+ DCA "Enable DTS Coherent Acoustics decoder" on \
+ LIBCDIO "Enable libcdio support" on \
+ OPTIMIZED_CFLAGS "Additional optimizations" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.else
+CONFIGURE_ARGS+=--disable-libavcodec --disable-libpostproc --disable-libswscale --disable-libavformat
+.endif
+
+.if !defined(WITHOUT_THEORA)
+LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
+.else
+CONFIGURE_ARGS+=--disable-theora
+.endif
+
+.if !defined(WITHOUT_SPEEX)
+LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+.else
+CONFIGURE_ARGS+=--disable-speex
+.endif
+
+.if !defined(WITHOUT_MJPEGTOOLS)
+LIB_DEPENDS+= lavjpeg-1.9.1:${PORTSDIR}/multimedia/mjpegtools
+.else
+CONFIGURE_ARGS+=--disable-mjpegtools
+.endif
+
+.if !defined(WITHOUT_VORBIS)
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+CONFIGURE_ARGS+=--with-vorbis=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-vorbis
+.endif
+
+.if !defined(WITHOUT_VORBIS)
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+=--disable-vorbis
+.endif
+
+.if !defined(WITHOUT_MPEG2)
+LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
+.else
+CONFIGURE_ARGS+=--disable-libmpeg2
+.endif
+
+.if !defined(WITHOUT_TIFF)
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+.else
+CONFIGURE_ARGS+=--disable-libtiff
+.endif
+
+.if !defined(WITHOUT_SAMBA)
+LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+.else
+CONFIGURE_ARGS+=--disable-samba
+.endif
+
+.if !defined(WITHOUT_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+=--disable-libpng
+.endif
+
+.if !defined(WITHOUT_FAAD)
+LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
+.else
+CONFIGURE_ARGS+=--disable-faad2
+.endif
+
+.if !defined(WITHOUT_DVDREAD)
+LIB_DEPENDS+= dvdread.5:${PORTSDIR}/multimedia/libdvdread
+.else
+CONFIGURE_ARGS+=--disable-dvdread
+.endif
+
+.if !defined(WITHOUT_FLAC)
+LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+.else
+CONFIGURE_ARGS+=--disable-flac
+.endif
+
+.if !defined(WITHOUT_MUSEPACK)
+LIB_DEPENDS+= mpcdec.5:${PORTSDIR}/audio/libmpcdec
+.else
+CONFIGURE_ARGS+=--disable-musepack
+.endif
+
+.if !defined(WITHOUT_MAD)
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+.else
+CONFIGURE_ARGS+=--disable-mad
+.endif
+
+.if !defined(WITHOUT_A52)
+LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
+.else
+CONFIGURE_ARGS+=--disable-liba52
+.endif
+
+.if !defined(WITHOUT_DCA)
+LIB_DEPENDS+= dca.0:${PORTSDIR}/multimedia/libdca
+.else
+# error in configure
+CONFIGURE_ARGS+=--disable-libcda --disable-libdca
+.endif
+
+.if !defined(WITHOUT_LIBCDIO)
+LIB_DEPENDS+= cdio.8:${PORTSDIR}/sysutils/libcdio
+.else
+CONFIGURE_ARGS+=--disable-libcdio
+.endif
+
+# vendor ocflags from configure
+.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -funroll-all-loops -ffast-math
+CXXFLAGS+= -O3 -funroll-all-loops -ffast-math
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3 -funroll-all-loops -ffast-math||g; \
+ /LIBS/ s|-ldl||g; s|^LDFLAGS="|&$${LDFLAGS} |' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^LIBS = / s|$$|@LIBINTL@ -lz|' \
+ ${WRKSRC}/tests/Makefile.in
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/lib/in_smb.c
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/gmerlin-avdecoder/distinfo b/multimedia/gmerlin-avdecoder/distinfo
new file mode 100644
index 000000000000..fe6c841cd241
--- /dev/null
+++ b/multimedia/gmerlin-avdecoder/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmerlin-avdecoder-0.1.8.tar.gz) = cefa2b135dbc9ada61b480351300f722
+SHA256 (gmerlin-avdecoder-0.1.8.tar.gz) = 2f561f792d26d9829e7a0fec54c5d05f6e733e864e7354c14232a6e93b0e024f
+SIZE (gmerlin-avdecoder-0.1.8.tar.gz) = 1345582
diff --git a/multimedia/gmerlin-avdecoder/files/patch-lib-libw32dll-wine-win32.c b/multimedia/gmerlin-avdecoder/files/patch-lib-libw32dll-wine-win32.c
new file mode 100644
index 000000000000..aa3a74db95c6
--- /dev/null
+++ b/multimedia/gmerlin-avdecoder/files/patch-lib-libw32dll-wine-win32.c
@@ -0,0 +1,30 @@
+--- lib/libw32dll/wine/win32.c.orig 2008-01-11 22:27:11.000000000 +0300
++++ lib/libw32dll/wine/win32.c 2008-11-07 17:15:48.000000000 +0300
+@@ -61,27 +61,6 @@
+ #include <kstat.h>
+ #endif
+
+-#if HAVE_VSSCANF
+-# ifndef __sun
+-/*
+- * On solaris, remove the prototype for now; it's incompatible with the one
+- * from solaris9 stdio.h
+- */
+-int vsscanf( const char *str, const char *format, va_list ap);
+-# endif
+-#else
+-/* system has no vsscanf. try to provide one */
+-static int vsscanf( const char *str, const char *format, va_list ap)
+-{
+- long p1 = va_arg(ap, long);
+- long p2 = va_arg(ap, long);
+- long p3 = va_arg(ap, long);
+- long p4 = va_arg(ap, long);
+- long p5 = va_arg(ap, long);
+- return sscanf(str, format, p1, p2, p3, p4, p5);
+-}
+-#endif
+-
+ char* win32_def_path = WIN32_PATH;
+
+ static void do_cpuid(unsigned int ax, unsigned int *regs)
diff --git a/multimedia/gmerlin-avdecoder/pkg-descr b/multimedia/gmerlin-avdecoder/pkg-descr
new file mode 100644
index 000000000000..fabc098196b0
--- /dev/null
+++ b/multimedia/gmerlin-avdecoder/pkg-descr
@@ -0,0 +1,18 @@
+Gmerlin_avdecoder is a general purpose media decoding library. It
+was written as a support library for gmerlin, but it can also be
+used by other applications. You don't even need gmerlin installed,
+only gavl. Most of it was written completely from scratch, but the
+sourcetrees of some other great software packages were used as
+reference documentation. Credits go to the authors of Xine, MPlayer,
+quicktime4linux and ffmpeg.
+
+Gmerlin_avdecoder is one of the most complete general purpose media
+decoding libraries. The supported formats and codecs span a wide
+range of applications from consumer level (mp3, divx etc.) to high
+end production formats like 32 bit PCM and some professional
+uncompressed video codecs.
+Using gmerlin_avdecoder in your playback for transcoding application
+means rock solid media format support with an ever growing list of
+supported codecs and formats.
+
+WWW: http://gmerlin.sourceforge.net/
diff --git a/multimedia/gmerlin-avdecoder/pkg-plist b/multimedia/gmerlin-avdecoder/pkg-plist
new file mode 100644
index 000000000000..ce84d030ca1a
--- /dev/null
+++ b/multimedia/gmerlin-avdecoder/pkg-plist
@@ -0,0 +1,9 @@
+bin/bgavdump
+include/gmerlin/avdec.h
+include/gmerlin/bgav_version.h
+lib/libgmerlin_avdec.la
+lib/libgmerlin_avdec.so
+lib/libgmerlin_avdec.so.0
+libdata/pkgconfig/gmerlin_avdec.pc
+share/locale/de/LC_MESSAGES/gmerlin-avdecoder.mo
+@dirrmtry include/gmerlin