aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-24 04:19:53 +0800
committermiwi <miwi@FreeBSD.org>2009-02-24 04:19:53 +0800
commit81869f614bcbfd22a763ddaac8220a466cc72b9e (patch)
treebdcf5ac3ce0bc0e18b9b813e0dfcdc9d6c9536e5 /multimedia
parentd5ddc03909374401abd0faf52e958738bd28bfdc (diff)
downloadfreebsd-ports-gnome-81869f614bcbfd22a763ddaac8220a466cc72b9e.tar.gz
freebsd-ports-gnome-81869f614bcbfd22a763ddaac8220a466cc72b9e.tar.zst
freebsd-ports-gnome-81869f614bcbfd22a763ddaac8220a466cc72b9e.zip
- Update to 2.1.6
PR: 131890 Submitted by: Toni Gundogdu <legatvs@gmail.com> (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/clive/Makefile34
-rw-r--r--multimedia/clive/distinfo6
-rw-r--r--multimedia/clive/files/patch-Makefile34
3 files changed, 52 insertions, 22 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index 632a95db0e5e..bed8ae866442 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= clive
-PORTVERSION= 2.1.5
-PORTREVISION= 0
+PORTVERSION= 2.1.6
CATEGORIES= multimedia
-MASTER_SITES= GOOGLE_CODE \
- SF
+MASTER_SITES= GOOGLE_CODE
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= legatvs@gmail.com
@@ -26,36 +24,34 @@ RUN_DEPENDS= p5-BerkeleyDB>=0.36:${PORTSDIR}/databases/p5-BerkeleyDB \
# deskutils/ljclive, multimedia/clive1 (same executable/manpage/distfile name)
CONFLICTS= *clive-[0-1]*
-NO_BUILD= yes
+OPTIONS= PASTE "Enable pasting from X clipboard" off \
+ PAGER "Enable pager for viewing cache entries" off \
+ EXPECT "Enable clivepass interface" off \
+ MANPAGE "Install manual page" on
-OPTIONS= PASTE "Paste URLs from clipboard" off \
- CLIVEPASS "Enable login passwords" off \
- SHOW "Show cache entries" off
+PLIST_FILES= bin/clive
USE_BZIP2= yes
+USE_GMAKE= yes
USE_PERL5= 5.8.2+
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
-
-.if !defined(NO_INSTALL_MANPAGES)
-MAN1= ${PORTNAME}.1
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/
-.endif
-
.include <bsd.port.pre.mk>
.if defined(WITH_PASTE)
RUN_DEPENDS+= p5-Clipboard>=0.09:${PORTSDIR}/x11/p5-Clipboard
.endif
-.if defined(WITH_SHOW)
+.if defined(WITH_PAGER)
RUN_DEPENDS+= p5-IO-Pager-0.06:${PORTSDIR}/devel/p5-IO-Pager
.endif
-.if defined(WITH_CLIVEPASS)
+.if defined(WITH_EXPECT)
RUN_DEPENDS+= p5-Expect>=1.21:${PORTSDIR}/lang/p5-Expect
.endif
+.if defined(WITH_MANPAGE)
+MAKE_ENV= WITH_MAN=yes
+MAN1= clive.1
+.endif
+
.include <bsd.port.post.mk>
diff --git a/multimedia/clive/distinfo b/multimedia/clive/distinfo
index d46e412e3e69..64c121db64dd 100644
--- a/multimedia/clive/distinfo
+++ b/multimedia/clive/distinfo
@@ -1,3 +1,3 @@
-MD5 (clive/clive-2.1.5.tar.bz2) = 66ff6adc1664c75d58ce25e4c322c2cb
-SHA256 (clive/clive-2.1.5.tar.bz2) = 388bc32bf505ca29f994da71282eebedf7043e7c293809e2fd9394d641c48b89
-SIZE (clive/clive-2.1.5.tar.bz2) = 27739
+MD5 (clive/clive-2.1.6.tar.bz2) = 3cab75a76c0c44cdffeca93b75acc800
+SHA256 (clive/clive-2.1.6.tar.bz2) = 4aec66d614339fdaed5437fc5868854252719731c60b471f9e26a8d4355c29fd
+SIZE (clive/clive-2.1.6.tar.bz2) = 27329
diff --git a/multimedia/clive/files/patch-Makefile b/multimedia/clive/files/patch-Makefile
new file mode 100644
index 000000000000..69428d19678a
--- /dev/null
+++ b/multimedia/clive/files/patch-Makefile
@@ -0,0 +1,34 @@
+--- Makefile.orig 2009-02-19 15:27:58.000000000 +0200
++++ Makefile 2009-02-19 15:31:01.000000000 +0200
+@@ -1,26 +1,21 @@
+ # GNU Makefile
+
+-SHELL = /bin/sh
+-
+-prefix = $(HOME)
++prefix = $(PREFIX)
+ bindir = $(prefix)/bin
+ datarootdir = $(prefix)/share
+ datadir = $(datarootdir)
+-mandir = $(datarootdir)/man
++mandir = $(MANPREFIX)/man
+ man1dir = $(mandir)/man1
+
+-INSTALL = install -c
+-INSTALL_D = install -d
+-INSTALL_M = install -c -m 444
++INSTALL = $(BSD_INSTALL_SCRIPT)
++INSTALL_D = mkdir -p
++INSTALL_M = $(BSD_INSTALL_MAN)
+ RM = rm -f
+ PERL = perl
+ POD2MAN = pod2man
+ AWK = awk
+ TR = tr
+
+-WITH_MAN = yes
+-WITH_CHECK = yes
+-
+ ifndef V
+ QUIET_POD2MAN = @echo POD2MAN clive.1;
+ endif