aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-04-19 17:20:57 +0800
committermmokhi <mmokhi@FreeBSD.org>2017-04-19 17:20:57 +0800
commit81a4545715fe24eb8187de88bc198a6e336a05b2 (patch)
treee0399ce9eaebc598c24513e706a7a65c265b4188 /multimedia
parent5f37772fd7990f8cd2670e4792a3cca355b2dff9 (diff)
downloadfreebsd-ports-gnome-81a4545715fe24eb8187de88bc198a6e336a05b2.tar.gz
freebsd-ports-gnome-81a4545715fe24eb8187de88bc198a6e336a05b2.tar.zst
freebsd-ports-gnome-81a4545715fe24eb8187de88bc198a6e336a05b2.zip
multimedia/librespot: Add port to the tree.
LibreSpot is an Open Source Spotify client (and library). It enables applications to use Spotify's service, without using the official but closed-source libspotify. Reviewed by: feld, mat (mentors) Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D10402
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/librespot/Makefile42
-rw-r--r--multimedia/librespot/distinfo3
-rw-r--r--multimedia/librespot/pkg-descr8
-rw-r--r--multimedia/librespot/pkg-message10
5 files changed, 64 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 78ba476373b1..ac0a801b4817 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -203,6 +203,7 @@
SUBDIR += libquvi-scripts
SUBDIR += libquvi-scripts09
SUBDIR += libquvi09
+ SUBDIR += librespot
SUBDIR += librtmp
SUBDIR += libsmacker
SUBDIR += libtheora
diff --git a/multimedia/librespot/Makefile b/multimedia/librespot/Makefile
new file mode 100644
index 000000000000..decbb63f87d0
--- /dev/null
+++ b/multimedia/librespot/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= librespot
+PORTVERSION= 0.1.0
+CATEGORIES= multimedia net devel
+
+MAINTAINER= mmokhi@FreeBSD.org
+COMMENT= Open Source Spotify client library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cargo>0:devel/cargo \
+ portaudio>0:audio/portaudio
+
+USES= localbase pathfix pkgconfig shebangfix
+USE_LDCONFIG= yes
+
+# Rust's target arch string is different from *BSD arch strings
+RUST_ARCH_x86_64= x86_64 # dragonfly
+RUST_ARCH_amd64= x86_64
+RUST_ARCH_i386= i686
+RUST_TARGET= ${RUST_ARCH_${ARCH}}-unknown-${OPSYS:tl}
+
+USE_GITHUB= yes
+GH_ACCOUNT= plietar
+GH_TAGNAME= 85dbc3b
+
+MAKE_ENV= CARGO_HOME=${BUILD_WRKSRC}
+
+PLIST_FILES= bin/${PORTNAME} \
+ lib/rustlib/${RUST_TARGET}/lib/lib${PORTNAME}.rlib
+
+do-build:
+ cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} cargo build --release --verbose
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/rustlib/${RUST_TARGET}/lib
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/target/release/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/target/release/${PORTNAME} ${STAGEDIR}${PREFIX}/lib/rustlib/${RUST_TARGET}/lib/lib${PORTNAME}.rlib
+
+.include <bsd.port.mk>
diff --git a/multimedia/librespot/distinfo b/multimedia/librespot/distinfo
new file mode 100644
index 000000000000..bd1c877b15e1
--- /dev/null
+++ b/multimedia/librespot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492239429
+SHA256 (plietar-librespot-0.1.0-85dbc3b_GH0.tar.gz) = 48e878a8863fb1905facf9c33f2aaee64d01e695a549af4dc51403daf5f34223
+SIZE (plietar-librespot-0.1.0-85dbc3b_GH0.tar.gz) = 165946
diff --git a/multimedia/librespot/pkg-descr b/multimedia/librespot/pkg-descr
new file mode 100644
index 000000000000..b280ba9f1a87
--- /dev/null
+++ b/multimedia/librespot/pkg-descr
@@ -0,0 +1,8 @@
+librespot is an open source client library for Spotify.
+It enables applications to use Spotify's service,
+without using the official but closed-source libspotify.
+
+Additionally, it will provide extra features which are not
+available in the official library.
+
+WWW: https://github.com/plietar/librespot
diff --git a/multimedia/librespot/pkg-message b/multimedia/librespot/pkg-message
new file mode 100644
index 000000000000..92d219bd9ce5
--- /dev/null
+++ b/multimedia/librespot/pkg-message
@@ -0,0 +1,10 @@
+******************************************************************************
+A sample program implementing a headless Spotify Connect receiver is provided.
+Once you've built librespot, run it using :
+
+librespot --username USERNAME --cache CACHEDIR --name DEVICENAME
+
+librespot can be run in discovery mode,
+in which case no password is required at startup.
+For that, simply omit the --username argument.
+******************************************************************************