aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-10-05 06:20:03 +0800
committerlinimon <linimon@FreeBSD.org>2019-10-05 06:20:03 +0800
commit8902876908ff10e9753f78f3208635d62b938389 (patch)
tree29da83bd17df34c6755b9201ded4ebbf843cbd95 /multimedia
parent896274f1e08fb5502ab671ec15c8124157f0b606 (diff)
downloadfreebsd-ports-gnome-8902876908ff10e9753f78f3208635d62b938389.tar.gz
freebsd-ports-gnome-8902876908ff10e9753f78f3208635d62b938389.tar.zst
freebsd-ports-gnome-8902876908ff10e9753f78f3208635d62b938389.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". For people already testing powerpc on clang, it is possible that they already have both compilers in base. Thus, the assumption that "gcc is in base" (e.g. libstdc++.so exists) always means "force use of GCC" is already broken. It will be for everyone on -CURRENT once the switch is made. Tested on both amd64 and powerpc64. PR: 239152 Approved by: gnome (maintainer-timeout > 1 month)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/totem/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 634e8b4f40ca..449b13ec928e 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -37,7 +37,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gl gnome localbase meson \
+USES= compiler desktop-file-utils gettext gl gnome localbase meson \
pkgconfig python:3.4+ tar:xz
USE_GNOME= cairo gtk30 intlhack introspection libxml2 nautilus3 \
pygobject3
@@ -76,10 +76,12 @@ pre-everything::
@${ECHO_MSG} "===> Define WITH_DVD_DEVICE if you want to change the default"
@${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
-.if exists(/usr/lib/libstdc++.so)
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
post-patch:
${REINPLACE_CMD} -e '/-Wno-unused-but-set-variable/d' \
${WRKSRC}/src/plugins/meson.build
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>