aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /multimedia
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/aegisub/Makefile2
-rw-r--r--multimedia/gmerlin-avdecoder/Makefile4
-rw-r--r--multimedia/handbrake/Makefile4
-rw-r--r--multimedia/libkate/Makefile3
-rw-r--r--multimedia/sabbu/Makefile2
5 files changed, 7 insertions, 8 deletions
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index 8b44bff69eeb..15220773c3aa 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -24,7 +24,6 @@ COMMENT= A cross-platform subtitle editor
LICENSE= BSD
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
OPTIONS_DEFINE= DEBUG PROFILE GCOV EFENCE ASS ALSA OPENAL PORTAUDIO PULSEAUDIO \
@@ -37,6 +36,7 @@ HUNSPELL_DESC= Hunspell support
USE_GNOME= intltool
USE_WX= 2.8
+USE_PKGCONFIG= yes
WX_COMPS= wx contrib
WX_UNICODE= yes
WX_CONF_ARGS= absolute
diff --git a/multimedia/gmerlin-avdecoder/Makefile b/multimedia/gmerlin-avdecoder/Makefile
index b0ef06bb0eb6..4e606df3d3f3 100644
--- a/multimedia/gmerlin-avdecoder/Makefile
+++ b/multimedia/gmerlin-avdecoder/Makefile
@@ -16,8 +16,7 @@ COMMENT= General purpose media decoding library
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/linux/dvb/frontend.h:${PORTSDIR}/multimedia/v4l_compat \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/dvb/frontend.h:${PORTSDIR}/multimedia/v4l_compat
LIB_DEPENDS= gavl.1:${PORTSDIR}/multimedia/gavl
OPTIONS_DEFINE= A52 CDIO DCA DVDREAD FAAD FFMPEG FLAC GMERLIN MAD \
@@ -35,6 +34,7 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cpuflags=none --without-doxygen
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 5a6c9e968d6a..36e213dd5b4b 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -33,11 +33,11 @@ DIST_SUBDIR= handbrake
MAINTAINER= ports@FreeBSD.org
COMMENT= A DVD to MPEG-4 ripper and encoder
-BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam \
- pkg-config:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
+USE_PKGCONFIG= yes
USE_AUTOTOOLS= libtool aclocal
diff --git a/multimedia/libkate/Makefile b/multimedia/libkate/Makefile
index 35b141490f04..5eb3afb129e1 100644
--- a/multimedia/libkate/Makefile
+++ b/multimedia/libkate/Makefile
@@ -16,14 +16,13 @@ COMMENT= Codec for karaoke and text encapsulation for Ogg
LICENSE= BSD
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
png15:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= pkgconfig
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
CFLAGS+= "-I${LOCALBASE}/include"
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index b65b14154d4b..8cd0a332b6ad 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Sabbu%20${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Program used to time subtitles
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
sndfile:${PORTSDIR}/audio/libsndfile
@@ -22,6 +21,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
+USE_PKGCONFIG= yes
USE_GNOME= gtk20
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include