aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2002-10-16 23:55:26 +0800
committernork <nork@FreeBSD.org>2002-10-16 23:55:26 +0800
commit8c5d22752e43264c585054ef9286b5bb2b7d469d (patch)
tree37e248690dba8a00588ca4602f2702e2de907e48 /multimedia
parent790a25f2ea0642efc9b60b12e3c8bc9ca324292c (diff)
downloadfreebsd-ports-gnome-8c5d22752e43264c585054ef9286b5bb2b7d469d.tar.gz
freebsd-ports-gnome-8c5d22752e43264c585054ef9286b5bb2b7d469d.tar.zst
freebsd-ports-gnome-8c5d22752e43264c585054ef9286b5bb2b7d469d.zip
Add support RTP/RTSP protocol with liveMedia,
Reviewed by: Thomas E. Zander <riggs@rrr.de> (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile13
-rw-r--r--multimedia/mplayerxp/Makefile13
2 files changed, 24 insertions, 2 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 4a8daeac4d3c..1d41d0ef1bed 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= 0.90.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -79,6 +79,10 @@ WITH_XANIM= yes
WITH_REALPLAYER= yes
.endif
+.if exists(${LOCALBASE}/live/liveMedia/libliveMedia.a)
+WITH_LIVEMEDIA= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
@@ -123,6 +127,13 @@ RUN_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
BUILD_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
.endif
+.if defined(WITH_LIVEMEDIA)
+CONFIGURE_ARGS+= --enable-live \
+ --with-livelibdir=${LOCALBASE}/live
+RUN_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+ .endif
+
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 4a8daeac4d3c..1d41d0ef1bed 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= 0.90.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -79,6 +79,10 @@ WITH_XANIM= yes
WITH_REALPLAYER= yes
.endif
+.if exists(${LOCALBASE}/live/liveMedia/libliveMedia.a)
+WITH_LIVEMEDIA= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
@@ -123,6 +127,13 @@ RUN_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
BUILD_DEPENDS+= realplay:${PORTSDIR}/audio/linux-realplayer
.endif
+.if defined(WITH_LIVEMEDIA)
+CONFIGURE_ARGS+= --enable-live \
+ --with-livelibdir=${LOCALBASE}/live
+RUN_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+ .endif
+
.if defined(WITH_XANIM)
BUILD_DEPENDS+= xanim:${PORTSDIR}/graphics/xanim