aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-06-19 21:12:21 +0800
committerkwm <kwm@FreeBSD.org>2015-06-19 21:12:21 +0800
commit8deeb25a675bed353aa4bc6ba7b5c7a888802077 (patch)
treec42378893ef57a7492d710c0280dc96e1300b40c /multimedia
parentd747ccdcff2bf633bc8c2637efcebaf7ed1fdb36 (diff)
downloadfreebsd-ports-gnome-8deeb25a675bed353aa4bc6ba7b5c7a888802077.tar.gz
freebsd-ports-gnome-8deeb25a675bed353aa4bc6ba7b5c7a888802077.tar.zst
freebsd-ports-gnome-8deeb25a675bed353aa4bc6ba7b5c7a888802077.zip
Our stdint.h is a symlink to sys/stdint.h so we need to teach x264 the
header guard of the sys/stdint.h file. Otherwise compiling software with the x264.h header will generate a warning about the mismatch header guard. Approved by: maintainer (koobs@) Differential Revision: https://reviews.freebsd.org/D2863
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libx264/Makefile2
-rw-r--r--multimedia/libx264/files/patch-x264.h15
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/libx264/Makefile b/multimedia/libx264/Makefile
index 60832b68011e..ff71c2da0121 100644
--- a/multimedia/libx264/Makefile
+++ b/multimedia/libx264/Makefile
@@ -5,7 +5,7 @@
PORTNAME= libx264
PORTVERSION= 0.${X264_BUILD}.${X264_REV}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.videolan.org/pub/videolan/x264/snapshots/ \
http://samples.mplayerhq.hu/yuv4mpeg2/:pgo
diff --git a/multimedia/libx264/files/patch-x264.h b/multimedia/libx264/files/patch-x264.h
new file mode 100644
index 000000000000..a6d1ea730ba8
--- /dev/null
+++ b/multimedia/libx264/files/patch-x264.h
@@ -0,0 +1,15 @@
+Our stdint.h is a symlink to sys/stdint.h so we need to teach x264
+the header guard of the sys/stdint.h file.
+
+Accepted upstream, see https://reviews.freebsd.org/D2863 for details.
+--- x264.h.orig 2015-06-19 08:05:22.728325000 +0200
++++ x264.h 2015-06-19 08:05:39.433879000 +0200
+@@ -29,7 +29,7 @@
+ #define X264_X264_H
+
+ #if !defined(_STDINT_H) && !defined(_STDINT_H_) && !defined(_STDINT_H_INCLUDED) && !defined(_STDINT) &&\
+- !defined(_INTTYPES_H) && !defined(_INTTYPES_H_) && !defined(_INTTYPES)
++ !defined(_SYS_STDINT_H_) && !defined(_INTTYPES_H) && !defined(_INTTYPES_H_) && !defined(_INTTYPES)
+ # ifdef _MSC_VER
+ # pragma message("You must include stdint.h or inttypes.h before x264.h")
+ # else