aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorHans Petter Selasky <hselasky@FreeBSD.org>2020-04-17 16:35:59 +0800
committerHans Petter Selasky <hselasky@FreeBSD.org>2020-04-17 16:35:59 +0800
commit9aa37199261bf213752c9868b3d48ca5fac666d9 (patch)
tree3152159c66fac5ed2d91c4b4344d2e294e8ccc52 /multimedia
parent6dd2426803c57693b1c944d66a30266929466167 (diff)
downloadfreebsd-ports-gnome-9aa37199261bf213752c9868b3d48ca5fac666d9.tar.gz
freebsd-ports-gnome-9aa37199261bf213752c9868b3d48ca5fac666d9.tar.zst
freebsd-ports-gnome-9aa37199261bf213752c9868b3d48ca5fac666d9.zip
Fix build after LibV4L upgrade to v1.18.0.
PR: 245501 Approved by: pi (implicit)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kaffeine/Makefile7
-rw-r--r--multimedia/mythtv/Makefile4
-rw-r--r--multimedia/mythtv/files/patch-libs_libmythtv_videodev2.h62
-rw-r--r--multimedia/w_scan/Makefile5
-rw-r--r--multimedia/w_scan/files/patch-si__types.h10
-rw-r--r--multimedia/w_scan/files/types.sed6
6 files changed, 48 insertions, 46 deletions
diff --git a/multimedia/kaffeine/Makefile b/multimedia/kaffeine/Makefile
index f666a797d222..f5a850c65fc3 100644
--- a/multimedia/kaffeine/Makefile
+++ b/multimedia/kaffeine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kaffeine
DISTVERSION= 2.0.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}
@@ -13,7 +13,7 @@ COMMENT= Multimedia player based on KDE and VLC
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
+BUILD_DEPENDS= v4l_compat>=1.18.0:multimedia/v4l_compat
LIB_DEPENDS= libvlc.so:multimedia/vlc \
libdvbv5.so:multimedia/libv4l
@@ -29,6 +29,9 @@ USE_XORG= xscrnsaver
CPE_VENDOR= kaffeine
CPE_PRODUCT= kaffeine_player
+post-patch:
+ @${RM} -r ${WRKSRC}/include
+
post-build:
# Cleanup translated manpages, we don't want them
${RM} ${STAGEDIR}/man/{ca,id,it,nl,pt,pt_BR,sv,uk}/man1/kaffeine.1.gz
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 477e0cb29b55..6b1cf5591817 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -4,7 +4,7 @@
PORTNAME= mythtv
DISTVERSIONPREFIX= v
DISTVERSION= 30.0
-PORTREVISION?= 4
+PORTREVISION?= 5
PORTEPOCH= 1
CATEGORIES= multimedia
@@ -83,7 +83,7 @@ OPTIONS_EXCLUDE+= BINDINGS LIRC MYSQL
.else
CONFLICTS_INSTALL= mythtv-frontend
-BUILD_DEPENDS+= v4l_compat>=1.0.20100321:multimedia/v4l_compat
+BUILD_DEPENDS+= v4l_compat>=1.18.0:multimedia/v4l_compat
RUN_DEPENDS+= tv_check:textproc/p5-xmltv \
wget:ftp/wget
USES+= perl5 python:2.7 shebangfix
diff --git a/multimedia/mythtv/files/patch-libs_libmythtv_videodev2.h b/multimedia/mythtv/files/patch-libs_libmythtv_videodev2.h
index f628c661acac..7c2015492073 100644
--- a/multimedia/mythtv/files/patch-libs_libmythtv_videodev2.h
+++ b/multimedia/mythtv/files/patch-libs_libmythtv_videodev2.h
@@ -1,34 +1,32 @@
---- libs/libmythtv/videodev2.h.orig 2018-01-11 12:39:22 UTC
+--- libs/libmythtv/videodev2.h.orig 2019-01-14 11:53:51 UTC
+++ libs/libmythtv/videodev2.h
-@@ -60,6 +60,32 @@
- #ifdef __FreeBSD__
- #include <linux/input.h> // For __[us][0-9]+ types
-+#ifndef __u64
-+typedef uint64_t __u64;
-+#endif
-+#ifndef __u32
-+typedef uint32_t __u32;
-+#endif
-+#ifndef __u16
-+typedef uint16_t __u16;
-+#endif
-+#ifndef __u8
-+typedef uint8_t __u8;
-+#endif
+@@ -53,25 +53,14 @@
+ * Hans Verkuil <hverkuil@xs4all.nl>
+ * et al.
+ */
+-#ifndef __LINUX_VIDEODEV2_H
+
-+#ifndef __s64
-+typedef int64_t __s64;
-+#endif
-+#ifndef __s32
-+typedef int32_t __s32;
-+#endif
-+#ifndef __s16
-+typedef int16_t __s16;
-+#endif
-+#ifndef __s8
-+typedef int8_t __s8;
-+#endif
-+
- #define __le64 __u64
- #define __le32 __u32
- #define __le16 __u16
++#ifdef __FreeBSD__
++#include <linux/videodev2.h>
++#elif !defined(__LINUX_VIDEODEV2_H)
+ #define __LINUX_VIDEODEV2_H
+
+ #include <sys/time.h>
+
+-#ifdef __FreeBSD__
+-#include <linux/input.h> // For __[us][0-9]+ types
+-#define __le64 __u64
+-#define __le32 __u32
+-#define __le16 __u16
+-#define __le8 __u8
+-#define __be64 __u64
+-#define __be32 __u32
+-#define __be16 __u16
+-#define __be8 __u8
+-#else
+-#include <linux/ioctl.h>
+-#include <linux/types.h>
+-#endif
+ #include <linux/v4l2-common.h>
+ #include <linux/v4l2-controls.h>
+
diff --git a/multimedia/w_scan/Makefile b/multimedia/w_scan/Makefile
index 0e8037b0bb4b..16fbb4bcd579 100644
--- a/multimedia/w_scan/Makefile
+++ b/multimedia/w_scan/Makefile
@@ -3,7 +3,7 @@
PORTNAME= w_scan
PORTVERSION= 20170107
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://wirbel.htpc-forum.de/w_scan/
@@ -26,9 +26,6 @@ PLIST_FILES= bin/${PORTNAME} \
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -f ${FILESDIR}/types.sed ${WRKSRC}/configure ${WRKSRC}/*.c ${WRKSRC}/*.h
-
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
diff --git a/multimedia/w_scan/files/patch-si__types.h b/multimedia/w_scan/files/patch-si__types.h
new file mode 100644
index 000000000000..c3ce360950ac
--- /dev/null
+++ b/multimedia/w_scan/files/patch-si__types.h
@@ -0,0 +1,10 @@
+--- si_types.h.orig 2020-04-14 20:31:04 UTC
++++ si_types.h
+@@ -27,6 +27,7 @@
+ #define __SI_TYPES_H
+
+ #include <stdint.h>
++#include <sys/types.h>
+ #include "descriptors.h"
+ #include "tools.h"
+
diff --git a/multimedia/w_scan/files/types.sed b/multimedia/w_scan/files/types.sed
deleted file mode 100644
index 45d6f25cfddc..000000000000
--- a/multimedia/w_scan/files/types.sed
+++ /dev/null
@@ -1,6 +0,0 @@
-/^#include <linux\/dvb\/frontend.h>/i\
-#include <stdint.h>
-s/^#include <linux\/types.h>/#include <stdint.h>/
-s/__u8/uint8_t/
-s/__u16/uint16_t/
-s/__u32/uint32_t/