aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2011-11-15 09:33:38 +0800
committerrakuco <rakuco@FreeBSD.org>2011-11-15 09:33:38 +0800
commit9d8911cada190bb60e393fde559c479b9db8b7f5 (patch)
tree33fa02f572f80c7d7040d013b8e074217498b3eb /multimedia
parenteebbad06e0449fc98659c64b89fa2faffe24de43 (diff)
downloadfreebsd-ports-gnome-9d8911cada190bb60e393fde559c479b9db8b7f5.tar.gz
freebsd-ports-gnome-9d8911cada190bb60e393fde559c479b9db8b7f5.tar.zst
freebsd-ports-gnome-9d8911cada190bb60e393fde559c479b9db8b7f5.zip
Add my upstream commit 353bf15.
This should fix a warning (and, in bsam's case, an error) about a wrong variable expansion in an if clause in CMake. Approved by: avilla (mentor) Feature safe: yes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/phonon/files/patch-CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/multimedia/phonon/files/patch-CMakeLists.txt b/multimedia/phonon/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9d6f2b74f048
--- /dev/null
+++ b/multimedia/phonon/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+commit 353bf15657c9a93138bce7431c5180b25efaede7
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon Nov 14 19:14:02 2011 -0200
+
+ Fix if() clause the same way 13ec1718 does.
+
+ QT_QTDESIGNER_FOUND should not be expanded, as if it is not found the if
+ clause will effectively become `if(AND PHONON_BUILD_DESIGNER_PLUGIN)`.
+
+ This was fixed in master by commit 13ec1718, which for some reason has
+ never made its way to the 4.5 branch.
+
+ CCMAIL: kde-multimedia@kde.org
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7fbb816..71cb14a 100644
+--- ./CMakeLists.txt
++++ ./CMakeLists.txt
+@@ -55,9 +55,9 @@ endif(QT_QTDBUS_FOUND)
+ set(BUILDSYSTEM_INSTALL_DIR ${SHARE_INSTALL_PREFIX}/phonon-buildsystem/)
+
+ add_subdirectory(cmake)
+-if(${QT_QTDESIGNER_FOUND} AND PHONON_BUILD_DESIGNER_PLUGIN)
++if(QT_QTDESIGNER_FOUND AND PHONON_BUILD_DESIGNER_PLUGIN)
+ add_subdirectory(designer)
+-endif(${QT_QTDESIGNER_FOUND} AND PHONON_BUILD_DESIGNER_PLUGIN)
++endif(QT_QTDESIGNER_FOUND AND PHONON_BUILD_DESIGNER_PLUGIN)
+ add_subdirectory(phonon)
+ add_subdirectory(includes)
+ if(PHONON_BUILD_DEMOS)