aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-10-09 16:31:05 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2016-10-09 16:31:05 +0800
commit9eb055cfb841a163dcda78c1e28beb339503eba6 (patch)
treefa9758eeb88d63886b9c121841c5433e40aa6724 /multimedia
parent59c61e434d3053b2de8db0408b53fc61fa48bf5c (diff)
downloadfreebsd-ports-gnome-9eb055cfb841a163dcda78c1e28beb339503eba6.tar.gz
freebsd-ports-gnome-9eb055cfb841a163dcda78c1e28beb339503eba6.tar.zst
freebsd-ports-gnome-9eb055cfb841a163dcda78c1e28beb339503eba6.zip
Remove the dependency on 'declarative' from multimedia/qt5-phonon4
USE_QT5=declarative aka Qt Quick1 has been put to rest upstream [1], and is no longer shipped with Qt5 [that's why it has been kept at 5.5.1 while the rest of Qt has been updated to 5.6.1]. Similar to arch [2] and debian [3] also get rid of it as a dependency for qt5-phonon4. [1] http://permalink.gmane.org/gmane.comp.lib.qt.releasing/1973 [2] https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/phonon&id=1e16901aa3991d10e94906316258759be8e6b3d7 [3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824957 Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D8163
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/qt5-phonon4/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/multimedia/qt5-phonon4/Makefile b/multimedia/qt5-phonon4/Makefile
index d6a655dad909..6bc7408e5371 100644
--- a/multimedia/qt5-phonon4/Makefile
+++ b/multimedia/qt5-phonon4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= phonon
PORTVERSION= 4.9.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= qt5-
@@ -16,11 +17,12 @@ LICENSE= LGPL21
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
USES= cmake:outsource pathfix tar:xz
-USE_QT5= core dbus declarative gui opengl widgets \
+USE_QT5= core dbus gui opengl widgets \
buildtools_build qmake_build
CMAKE_ARGS= -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=TRUE \
-DPHONON_NO_PLATFORMPLUGIN:BOOL=TRUE \
-DPHONON_BUILD_DESIGNER_PLUGIN:BOOL=OFF \
+ -DPHONON_BUILD_DECLARATIVE_PLUGIN:BOOL=OFF \
-DPHONON_BUILD_PHONON4QT5=ON
USE_LDCONFIG= yes