aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
committerantoine <antoine@FreeBSD.org>2015-06-23 02:33:20 +0800
commita271c81a691520343b54826252aba0c2600e31ab (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /multimedia
parent19ea8e358e68f9d94cca6a73917529e296948d19 (diff)
downloadfreebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.gz
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.tar.zst
freebsd-ports-gnome-a271c81a691520343b54826252aba0c2600e31ab.zip
Convert to USES=jpeg
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/camserv/Makefile5
-rw-r--r--multimedia/ffmpegthumbnailer/Makefile5
-rw-r--r--multimedia/gmerlin/Makefile2
-rw-r--r--multimedia/gpac-libgpac/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile5
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common4
-rw-r--r--multimedia/gstreamer1-plugins/Makefile5
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common4
-rw-r--r--multimedia/kissdx/Makefile3
-rw-r--r--multimedia/kodi/Makefile3
-rw-r--r--multimedia/libdv/Makefile5
-rw-r--r--multimedia/libmovtar/Makefile4
-rw-r--r--multimedia/libquicktime/Makefile2
-rw-r--r--multimedia/libv4l/Makefile5
-rw-r--r--multimedia/mjpegtools/Makefile3
-rw-r--r--multimedia/mjpg-streamer/Makefile2
-rw-r--r--multimedia/motion/Makefile4
-rw-r--r--multimedia/openquicktime/Makefile4
-rw-r--r--multimedia/plexhometheater/Makefile3
-rw-r--r--multimedia/pwcbsd/Makefile2
-rw-r--r--multimedia/pwcview/Makefile4
-rw-r--r--multimedia/spook/Makefile2
-rw-r--r--multimedia/transcode/Makefile2
-rw-r--r--multimedia/vdr/Makefile3
-rw-r--r--multimedia/xawtv/Makefile5
-rw-r--r--multimedia/xine/Makefile5
-rw-r--r--multimedia/zoneminder/Makefile5
27 files changed, 43 insertions, 55 deletions
diff --git a/multimedia/camserv/Makefile b/multimedia/camserv/Makefile
index e7c7f2319296..a020e8b11718 100644
--- a/multimedia/camserv/Makefile
+++ b/multimedia/camserv/Makefile
@@ -13,10 +13,9 @@ COMMENT= Free program to do streaming video via the web
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
-USES= libtool
+USES= jpeg libtool
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/multimedia/ffmpegthumbnailer/Makefile b/multimedia/ffmpegthumbnailer/Makefile
index 9202c5a50530..c38719855a56 100644
--- a/multimedia/ffmpegthumbnailer/Makefile
+++ b/multimedia/ffmpegthumbnailer/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
- libswscale.so:${PORTSDIR}/multimedia/ffmpeg \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ libswscale.so:${PORTSDIR}/multimedia/ffmpeg
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -23,7 +22,7 @@ CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig --enable-gio
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= compiler:c++11-lib libtool pathfix pkgconfig
+USES= compiler:c++11-lib jpeg libtool pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index 4f6fdba330ac..74ee3ac8a63c 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -51,7 +51,7 @@ ESOUND_USE= gnome=esound
ESOUND_CONFIGURE_OFF= --disable-esd
JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
JACK_CONFIGURE_OFF= --disable-jack
-JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_USES= jpeg
JPEG_CONFIGURE_OFF= --disable-libjpeg
LIBVISUAL_LIB_DEPENDS= libvisual-0.4.so:${PORTSDIR}/graphics/libvisual04
LIBVISUAL_CONFIGURE_OFF=--disable-libvisual
diff --git a/multimedia/gpac-libgpac/Makefile b/multimedia/gpac-libgpac/Makefile
index 64d2136e5da1..07993915d1a0 100644
--- a/multimedia/gpac-libgpac/Makefile
+++ b/multimedia/gpac-libgpac/Makefile
@@ -43,7 +43,7 @@ OPENGL_CONFIGURE_ENABLE=3d
XVIDEO_LIB_DEPENDS= libXv.so:${PORTSDIR}/x11/libXv
XVIDEO_CONFIGURE_OFF= --disable-x11-xv --disable-x11-shm
IPV6_CONFIGURE_ENABLE= ipv6
-JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_USES= jpeg
JPEG_CONFIGURE_ON= --use-jpeg=local
JPEG_CONFIGURE_OFF= --use-jpeg=no
PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index cd8675ced941..a2e4794d63b6 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -57,7 +57,8 @@ CFLAGS+= -I${LOCALBASE}/include
DEFAULT_AUDIOSINK?= osssink
DEFAULT_AUDIOSRC?= osssrc
-.include <bsd.port.pre.mk>
+# Include bsd.port.options.mk and not bsd.port.pre.mk to be able to use USES
+.include <bsd.port.options.mk>
.if ${ARCH}=="i386"
PLIST_SUB+= I386=""
@@ -166,4 +167,4 @@ USE_GCC= any
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index e78c4c48189a..078617f6733d 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -343,7 +343,7 @@ gst_jack_PLIST_FILES= ${GST_LIB_DIR}/libgstjack.la \
gst_jack_DIST= good
# jpeg
-gst_jpeg_LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+gst_jpeg_USES= jpeg
gst_jpeg_PLIST_FILES= ${GST_LIB_DIR}/libgstjpeg.la \
${GST_LIB_DIR}/libgstjpeg.so
@@ -613,6 +613,7 @@ DIST= ${gst_${GST_PLUGIN}_DIST}
gst_${GST_PLUGIN}_BUILD_DEPENDS?=
gst_${GST_PLUGIN}_LIB_DEPENDS?=
gst_${GST_PLUGIN}_RUN_DEPENDS?=
+gst_${GST_PLUGIN}_USES?=
gst_${GST_PLUGIN}_PLIST_FILES?=${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.a \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.la
@@ -631,6 +632,7 @@ gst_${GST_PLUGIN}_USE_GSTREAMER?=
BUILD_DEPENDS+= ${gst_${GST_PLUGIN}_BUILD_DEPENDS}
LIB_DEPENDS+= ${gst_${GST_PLUGIN}_LIB_DEPENDS}
RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
+USES+= ${gst_${GST_PLUGIN}_USES}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
PLIST_DIRS= ${gst_${GST_PLUGIN}_PLIST_DIRS}
PLIST_DIRSTRY= ${gst_${GST_PLUGIN}_PLIST_DIRSTRY}
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index cc546fa332d3..a73b927070a7 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -65,7 +65,8 @@ SOVERSION= 0.405.0
PLIST_SUB+= VERSION="${VERSION}" \
SOVERSION="${SOVERSION}"
-.include <bsd.port.pre.mk>
+# Include bsd.port.options.mk and not bsd.port.pre.mk to be able to use USES
+.include <bsd.port.options.mk>
.if ${GST_PLUGIN} == "base"
DIST= base
@@ -171,4 +172,4 @@ USE_GCC= any
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gstreamer-1.0
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index f997f60643ad..6ac0d280847c 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -271,7 +271,7 @@ gst_gsm_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
gst_jack_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
# jpeg
-gst_jpeg_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+gst_jpeg_USES= jpeg
# kate
gst_kate_LIB_DEPENDS= libkate.so:${PORTSDIR}/multimedia/libkate
@@ -428,6 +428,7 @@ gst_zbar_LIB_DEPENDS= libzbar.so:${PORTSDIR}/graphics/zbar
gst_${GST_PLUGIN}_BUILD_DEPENDS?=
gst_${GST_PLUGIN}_LIB_DEPENDS?=
gst_${GST_PLUGIN}_RUN_DEPENDS?=
+gst_${GST_PLUGIN}_USES?=
gst_${GST_PLUGIN}_USE_XORG?=
gst_${GST_PLUGIN}_PLIST_FILES?= \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so
@@ -445,6 +446,7 @@ gst_${GST_PLUGIN}_USE_GSTREAMER1?=
BUILD_DEPENDS+= ${gst_${GST_PLUGIN}_BUILD_DEPENDS}
LIB_DEPENDS+= ${gst_${GST_PLUGIN}_LIB_DEPENDS}
RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
+USES+= ${gst_${GST_PLUGIN}_USES}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
EXTRA_LIBS+= ${gst_${GST_PLUGIN}_EXTRA_LIBS}
USE_XORG+= ${gst_${GST_PLUGIN}_USE_XORG}
diff --git a/multimedia/kissdx/Makefile b/multimedia/kissdx/Makefile
index d24620386ca1..4d08b92d115f 100644
--- a/multimedia/kissdx/Makefile
+++ b/multimedia/kissdx/Makefile
@@ -13,10 +13,9 @@ COMMENT= Multimedia streaming server for KiSS/Linksys player
LICENSE= GPLv2
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libdvdread.so:${PORTSDIR}/multimedia/libdvdread
-USES= compiler:nestedfct dos2unix iconv
+USES= compiler:nestedfct dos2unix iconv jpeg
MAKE_ENV= FreeBSD=defined
USE_RC_SUBR= kissdx
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index 0ddc4f61726a..dcede8f2eb4c 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -39,7 +39,6 @@ LIB_DEPENDS= libass.so:${PORTSDIR}/multimedia/libass \
libgnutls.so:${PORTSDIR}/security/gnutls \
liblzo2.so:${PORTSDIR}/archivers/lzo2 \
libjasper.so:${PORTSDIR}/graphics/jasper \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libltdl.so:${PORTSDIR}/devel/libltdl \
libmodplug.so:${PORTSDIR}/audio/libmodplug \
libmpeg2.so:${PORTSDIR}/multimedia/libmpeg2 \
@@ -62,7 +61,7 @@ GH_ACCOUNT= xbmc
GH_PROJECT= ffmpeg
GH_TAGNAME= 2.4.6-Helix
-USES= autoreconf:build gettext gmake iconv:wchar_t libtool \
+USES= autoreconf:build gettext gmake iconv:wchar_t jpeg libtool \
pkgconfig python:2
GNU_CONFIGURE= yes
USE_XORG= xt xmu xtst xrandr
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index e0822ebb7230..fb4b190a9d16 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -12,15 +12,14 @@ COMMENT= Quasar DV codec (libdv): software codec for DV video encoding format
LICENSE= LGPL21
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpopt.so:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-USES= libtool pathfix pkgconfig
+USES= jpeg libtool pathfix pkgconfig
USE_LDCONFIG= yes
DOCS= AUTHORS COPYING COPYRIGHT ChangeLog NEWS README \
diff --git a/multimedia/libmovtar/Makefile b/multimedia/libmovtar/Makefile
index e87f27009e69..a88615f5e6c6 100644
--- a/multimedia/libmovtar/Makefile
+++ b/multimedia/libmovtar/Makefile
@@ -10,11 +10,9 @@ MASTER_SITES= SF/mjpeg/OldFiles
MAINTAINER= ports@FreeBSD.org
COMMENT= Supports reading/writing of MJPEG video in YUV 4:2:2 JPEG
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
-
USE_SDL= sdl
USE_GNOME= glib12
-USES= gmake
+USES= gmake jpeg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-m4data-prefix=${PREFIX}/share
diff --git a/multimedia/libquicktime/Makefile b/multimedia/libquicktime/Makefile
index 98d22388f559..68e6bc57795c 100644
--- a/multimedia/libquicktime/Makefile
+++ b/multimedia/libquicktime/Makefile
@@ -78,7 +78,7 @@ CONFIGURE_ARGS+= --without-libdv
.endif
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES+= jpeg
CONFIGURE_ARGS+= --with-libjpeg
.else
CONFIGURE_ARGS+= --without-libjpeg
diff --git a/multimedia/libv4l/Makefile b/multimedia/libv4l/Makefile
index 788cb0eb0369..27465bea8749 100644
--- a/multimedia/libv4l/Makefile
+++ b/multimedia/libv4l/Makefile
@@ -24,13 +24,12 @@ WRKSRC= ${WRKDIR}/v4l-utils-${PORTVERSION}
.if ${LIBV4L_SLAVE} != compat
BUILD_DEPENDS+= v4l_compat>=${PORTVERSION}:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libargp.so:${PORTSDIR}/devel/argp-standalone
+LIB_DEPENDS+= libargp.so:${PORTSDIR}/devel/argp-standalone
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES+= gmake iconv libtool pathfix pkgconfig
+USES+= gmake iconv jpeg libtool pathfix pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-libdvbv5 \
--disable-qv4l2 \
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index f3bd8bf38db0..e0b585d21391 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -13,11 +13,10 @@ COMMENT= Set of tools to record/playback/edit videos in MPEG format
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
CONFLICTS= mplex-[0-9]*
-USES= gmake libtool pathfix pkgconfig
+USES= gmake jpeg libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/multimedia/mjpg-streamer/Makefile b/multimedia/mjpg-streamer/Makefile
index a322145b833f..683d8fada70a 100644
--- a/multimedia/mjpg-streamer/Makefile
+++ b/multimedia/mjpg-streamer/Makefile
@@ -41,7 +41,7 @@ MJPEG_STREAMER_PLUGINS+= input_testpicture.so
.if ${PORT_OPTIONS:MUVC}
MJPEG_STREAMER_PLUGINS+= input_uvc.so
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES+= jpeg
.endif
.if ${PORT_OPTIONS:MHTTP}
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 40156e1a8d08..abbbc1520f56 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -13,8 +13,6 @@ COMMENT= Motion detection application
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
-
OPTIONS_DEFINE= FFMPEG MYSQL PGSQL DOCS EXAMPLES
OPTIONS_SINGLE= VIDEO
OPTIONS_SINGLE_VIDEO= BKTR PWCBSD
@@ -23,7 +21,7 @@ VIDEO_DESC= Video capture driver. Choose one of BKTR or PWCBSD
BKTR_DESC= BKTR based TV capture cards
PWCBSD_DESC= PWCBSD based Webcams
-USES= autoreconf gmake
+USES= autoreconf gmake jpeg
GNU_CONFIGURE= yes
USE_RC_SUBR= ${PORTNAME}
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
index 8e56dd43b2a4..47bc9b317f60 100644
--- a/multimedia/openquicktime/Makefile
+++ b/multimedia/openquicktime/Makefile
@@ -14,11 +14,9 @@ COMMENT= Portable library for handling Apple's QuickTime(TM) files
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
-
GNU_CONFIGURE= yes
USE_GNOME= gtk12
-USES= gmake tar:tgz
+USES= gmake jpeg tar:tgz
USE_LDCONFIG= yes
PKGDEINSTALL= ${PKGINSTALL}
diff --git a/multimedia/plexhometheater/Makefile b/multimedia/plexhometheater/Makefile
index 63248fa6ab1c..3973827c8904 100644
--- a/multimedia/plexhometheater/Makefile
+++ b/multimedia/plexhometheater/Makefile
@@ -37,7 +37,6 @@ LIB_DEPENDS= libass.so:${PORTSDIR}/multimedia/libass \
libGLEW.so:${PORTSDIR}/graphics/glew \
libhal.so:${PORTSDIR}/sysutils/hal \
libjasper.so:${PORTSDIR}/graphics/jasper \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
liblzo2.so:${PORTSDIR}/archivers/lzo2 \
libmad.so:${PORTSDIR}/audio/libmad \
libmicrohttpd.so:${PORTSDIR}/www/libmicrohttpd \
@@ -69,7 +68,7 @@ GH_ACCOUNT= plexinc
GH_PROJECT= plex-home-theater-public
BUNDLE_LIBS= yes
-USES= cmake:outsource execinfo gmake iconv:wchar_t pkgconfig python:2
+USES= cmake:outsource execinfo gmake iconv:wchar_t jpeg pkgconfig python:2
CMAKE_ARGS+= -DENABLE_AUTOUPDATE:BOOL=false
CMAKE_ARGS+= -DENABLE_DUMP_SYMBOLS:BOOL=false
CMAKE_ARGS+= -DENABLE_PYTHON:BOOL=false
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
index b2825171a8bd..c42da32be992 100644
--- a/multimedia/pwcbsd/Makefile
+++ b/multimedia/pwcbsd/Makefile
@@ -47,7 +47,7 @@ ALL_TARGET= all
.if ${PORT_OPTIONS:MPROGRAMS}
ALL_TARGET+= pwcview
PROGRAMS= pwcview
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES+= jpeg
USE_SDL= sdl
PLIST_SUB+= PROGRAMS=""
.else
diff --git a/multimedia/pwcview/Makefile b/multimedia/pwcview/Makefile
index c04ecc7ef95e..6a3d933a701a 100644
--- a/multimedia/pwcview/Makefile
+++ b/multimedia/pwcview/Makefile
@@ -13,11 +13,11 @@ MAINTAINER= hselasky@FreeBSD.org
COMMENT= The Video4Linux PWC webcam viewer
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libv4l1.so:${PORTSDIR}/multimedia/libv4l
+LIB_DEPENDS= libv4l1.so:${PORTSDIR}/multimedia/libv4l
CONFLICTS= pwcbsd-[0-9]*
+USES= jpeg
USE_SDL= sdl
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/multimedia/spook/Makefile b/multimedia/spook/Makefile
index 096af4b85f1b..b798d6544e68 100644
--- a/multimedia/spook/Makefile
+++ b/multimedia/spook/Makefile
@@ -34,7 +34,7 @@ PORTDOCS= *
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES+= jpeg
CONFIGURE_ARGS+= --enable-encoder-jpeg
.endif
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 9b699e149360..7673309de50f 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -104,7 +104,7 @@ IMAGEMAGICK_LIB_DEPENDS= libMagickWand-6.so:${PORTSDIR}/graphics/ImageMagick
IMAGEMAGICK_CONFIGURE_ENABLE= imagemagick
IMAGEMAGICK_CONFIGURE_ON= --with-imagemagick-prefix=${LOCALBASE}
-JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_USES= jpeg
JPEG_CONFIGURE_ENABLE= libjpeg
JPEG_CONFIGURE_ON= --with-libjpeg-prefix=${LOCALBASE}
diff --git a/multimedia/vdr/Makefile b/multimedia/vdr/Makefile
index 3edeb83eafd1..9239d2795b19 100644
--- a/multimedia/vdr/Makefile
+++ b/multimedia/vdr/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= v4l_compat>=1.0.20120501:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig \
xorg-fonts-truetype>=0:${PORTSDIR}/x11-fonts/xorg-fonts-truetype
@@ -26,7 +25,7 @@ DVBPATCH_DESC= DVB audio patch for some countries
STB0899_SIGNAL_DESC= STB0899 signal strength patch
OPTIONS_DEFAULT= IPTVPATCH TTXPATCH
-USES= cpe pkgconfig gettext iconv:wchar_t gmake shebangfix tar:bzip2
+USES= cpe gettext gmake iconv:wchar_t jpeg pkgconfig shebangfix tar:bzip2
CPE_VENDOR= tvdr
SHEBANG_FILES= svdrpsend
DIST_SUBDIR= vdr
diff --git a/multimedia/xawtv/Makefile b/multimedia/xawtv/Makefile
index 165845768f22..82e3957a9140 100644
--- a/multimedia/xawtv/Makefile
+++ b/multimedia/xawtv/Makefile
@@ -12,15 +12,14 @@ COMMENT= TV viewing application and a few TV utilities
BUILD_DEPENDS= ${LOCALBASE}/share/fonts/misc/led-iso8859-1.pcf.gz:${PORTSDIR}/x11-fonts/tv-fonts
RUN_DEPENDS= ${LOCALBASE}/share/fonts/misc/led-iso8859-1.pcf.gz:${PORTSDIR}/x11-fonts/tv-fonts
-LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= AALIB DV QUICKTIME ZVBI
OPTIONS_DEFINE_i386= MMX
OPTIONS_DEFAULT= AALIB
ZVBI_DESC= Enable libzvbi support
-USES= gmake iconv motif perl5 tar:bzip2
+USES= gmake iconv jpeg motif perl5 tar:bzip2
GNU_CONFIGURE= yes
USE_XORG= x11 xaw
CPPFLAGS+= -I${WRKSRC}/common
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 696a301dbd36..6eec9df53942 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -12,11 +12,10 @@ COMMENT= X11 multimedia player
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libxine.so:${PORTSDIR}/multimedia/libxine
-USES= desktop-file-utils execinfo gmake iconv pkgconfig readline \
+USES= desktop-file-utils execinfo gmake iconv jpeg pkgconfig readline \
shared-mime-info tar:xz
USE_XORG= x11 xext xinerama xscrnsaver xtst xv xxf86vm
GNU_CONFIGURE= yes
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index 2916f3e6c8ce..808dca148c6f 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -15,8 +15,7 @@ COMMENT= Complete security camera solution, fully web based with image analysis
LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/sudo:${PORTSDIR}/security/sudo
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libnetpbm.so:${PORTSDIR}/graphics/netpbm \
+LIB_DEPENDS= libnetpbm.so:${PORTSDIR}/graphics/netpbm \
libpcre.so:${PORTSDIR}/devel/pcre \
libavutil0.so:${PORTSDIR}/multimedia/ffmpeg0
BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
@@ -29,7 +28,7 @@ BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
-USES= perl5 shebangfix
+USES= jpeg perl5 shebangfix
GNU_CONFIGURE= yes
USE_PHP= json mysql session
USE_MYSQL= yes