aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-28 06:20:43 +0800
committerwg <wg@FreeBSD.org>2013-10-28 06:20:43 +0800
commitaa3da1c84cdb0e5dfb190c16f74ea3d9def166a7 (patch)
tree716aaac131781964e20f9ff8e01e743528be5e1e /multimedia
parent98ca7a01bd429112f54d9a4cb2d1cb69b9363410 (diff)
downloadfreebsd-ports-gnome-aa3da1c84cdb0e5dfb190c16f74ea3d9def166a7.tar.gz
freebsd-ports-gnome-aa3da1c84cdb0e5dfb190c16f74ea3d9def166a7.tar.zst
freebsd-ports-gnome-aa3da1c84cdb0e5dfb190c16f74ea3d9def166a7.zip
multimedia/vlc: fix package without pkgng
- Fix package without pkgng PR: ports/183356 Submitted by: mandree
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 01300ead5f4e..6f683ea060ba 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -720,10 +720,10 @@ post-install:
@${FIND} ${STAGEDIR} -type d | ${SED} -e "s,${STAGEDIR},,g" \
| while read line; do \
${GREP} -qw "^$${line}$$" ${WRKDIR}/.mtree || { \
- [ -n "$${line}" ] && ${ECHO_CMD} "@dirrmtry $${line}"; \
+ [ -n "$${line}" ] && ${ECHO_CMD} "@unexec rmdir "%D/$${line}" >/dev/null 2>&1 || :"; \
}; \
done | ${SORT} -r | ${SED} \
- -e "s,${PREFIX}/,,g" | ${GREP} -v "^@dirrmtry share/licenses" >> ${TMPPLIST} || ${TRUE}
+ -e "s,${PREFIX}/,,g" | ${GREP} -v "^@unexec rmdir %D/share/licenses" >> ${TMPPLIST} || ${TRUE}
.include <bsd.port.post.mk>