aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-01-19 05:12:42 +0800
committerKoop Mast <kwm@FreeBSD.org>2015-01-19 05:12:42 +0800
commitbb89f80c35b37a67d67d5353a5d6cb7c77070b98 (patch)
tree9382515fd441e0336df236e464a9bd7532cccaac /multimedia
parent743a2d9f8d26f0bf7aecb4931e8f02cb732f47b6 (diff)
downloadfreebsd-ports-gnome-bb89f80c35b37a67d67d5353a5d6cb7c77070b98.tar.gz
freebsd-ports-gnome-bb89f80c35b37a67d67d5353a5d6cb7c77070b98.tar.zst
freebsd-ports-gnome-bb89f80c35b37a67d67d5353a5d6cb7c77070b98.zip
Update ImageMagick to 6.9.0.4.
- Normalize the ImageMagick library name so it stays the same regardless of what the 16-bit and HDRI option are set to [1]. Teach cmake to look for the new name. Bump ports that link to the libraries due to this. - As a result do away with the "HALFSUPPORTED" option block, and list 16-bit and HDRI with the other options. - ImageMagick ships a basic SVG plugin when not using librsvg2 for SVG support. This basic SVG plugin needs libxml2 to work [2]. Make libxml2 a mandatory dependency (instead of only when the SVG option was selected). - Don't touch .keep files in the modules directory, there files there so it useless. PR: 194949 [1] PR: 195227 [2] Requested by: many [1] Submitted by: software-freebsd@interfasys.ch [2]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/dvdauthor/Makefile4
-rw-r--r--multimedia/libxine/Makefile4
-rw-r--r--multimedia/transcode/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 7fcc73f09f55..c9c3e30e08a9 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dvdauthor
PORTVERSION= 0.7.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -45,7 +45,7 @@ PAL_DESC= Default video format PAL
SUB_FILES= README.FreeBSD
-IMAGEMAGICK_LIB_DEPENDS= libMagick++-6.Q16.so:${PORTSDIR}/graphics/ImageMagick
+IMAGEMAGICK_LIB_DEPENDS= libMagick++-6.so:${PORTSDIR}/graphics/ImageMagick
.include <bsd.port.options.mk>
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 24a84d1ea835..4c8b15c4d27c 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xine
PORTVERSION= 1.2.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-lib/${PORTVERSION}
PKGNAMEPREFIX= lib
@@ -157,7 +157,7 @@ CONFIGURE_ARGS+= --disable-aalib --disable-aalibtest
.endif
.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= libMagickWand-6.Q16.so:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= libMagickWand-6.so:${PORTSDIR}/graphics/ImageMagick
PLIST_SUB+= WITH_IMAGEMAGICK=""
.else
PLIST_SUB+= WITH_IMAGEMAGICK="@comment "
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 316d32f077ab..b07c072806a5 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -3,7 +3,7 @@
PORTNAME= transcode
PORTVERSION= 1.1.7
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= multimedia
MASTER_SITES= http://cdn.bitbucket.org/france/transcode-tcforge/downloads/
@@ -100,7 +100,7 @@ SDL_USE= SDL=sdl
SDL_CONFIGURE_ENABLE= sdl
SDL_CONFIGURE_ENV_ON= SDL_CONFIG="${SDL_CONFIG}"
-IMAGEMAGICK_LIB_DEPENDS= libMagickWand-6.Q16.so:${PORTSDIR}/graphics/ImageMagick
+IMAGEMAGICK_LIB_DEPENDS= libMagickWand-6.so:${PORTSDIR}/graphics/ImageMagick
IMAGEMAGICK_CONFIGURE_ENABLE= imagemagick
IMAGEMAGICK_CONFIGURE_ON= --with-imagemagick-prefix=${LOCALBASE}