aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2016-02-08 03:43:56 +0800
committerkwm <kwm@FreeBSD.org>2016-02-08 03:43:56 +0800
commitbd0d08974c0ee8a31b090ec738e138401f2368ec (patch)
tree9e818b5d09f2e948238e96c1a5ae1e8212983272 /multimedia
parent3423370b10a03a2b6f1f05678e1e18ec354e04ec (diff)
downloadfreebsd-ports-gnome-bd0d08974c0ee8a31b090ec738e138401f2368ec.tar.gz
freebsd-ports-gnome-bd0d08974c0ee8a31b090ec738e138401f2368ec.tar.zst
freebsd-ports-gnome-bd0d08974c0ee8a31b090ec738e138401f2368ec.zip
Move Mk/bsd.gnome.mk and Mk/bsd.mate.mk to Mk/Uses/.
To use the GNOME or MATE components activate it by adding gnome or mate to USES. The usage of USE_GNOME/INSTALL_ICONS and for example GLIB_SCHEMAS has stayed the same. Like with USES, the use of USE_GNOME and so after bsd.port.pre.mk is now forbidden. And adapt ports that where still doing that. Exp-runs done by: antoine@ PR: 205432 Reviewed by: antoine@, mat@ Approved by: portmgr (antoine@) Differential Revision: https://reviews.freebsd.org/D3653
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avidemux/Makefile.common22
-rw-r--r--multimedia/mpeg4ip/Makefile4
-rw-r--r--multimedia/mplayer/Makefile7
-rw-r--r--multimedia/winff/Makefile4
4 files changed, 19 insertions, 18 deletions
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index d25f2449fdf1..db4f17d3feec 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -57,17 +57,6 @@ CMAKE_ARGS+= -DNO_NLS:BOOL=ON
PLIST_SUB+= NLS="@comment " QT_NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-# is this kosher? the result seems to run tho... (see ports/185997)
-.if $(COMPILER_FEATURES:Mlibc++)
-LDFLAGS+= -lc++
-.endif
-
-#.if ${COMPILER_TYPE} == clang
-USE_GCC= yes
-#.endif
-
# for libexecinfo: (so that __builtin_frame_address() finds the top
# of the stack)
.if ${ARCH} == "amd64"
@@ -265,6 +254,17 @@ CMAKE_ARGS+= -DOPENCORE_AMRWB:BOOL=OFF
PLIST_SUB+= AMRWB="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+# is this kosher? the result seems to run tho... (see ports/185997)
+.if $(COMPILER_FEATURES:Mlibc++)
+LDFLAGS+= -lc++
+.endif
+
+#.if ${COMPILER_TYPE} == clang
+USE_GCC= yes
+#.endif
+
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 06281f2fbf5c..ea240bafacdf 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -45,7 +45,7 @@ PORTDOCS= MAINREADME.html MP4LIVE_INTERNALS.html MPEG4IP_Guide.pdf \
ReadingList.txt encoding.htm m4rm.html \
mp4player.jpg mrm.html pi.html prm.html
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
###
## Auto detect possible extensions
@@ -170,4 +170,4 @@ CONFIGURE_ARGS+= --disable-mmx
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index d1b5b46b6862..e0a2b383de81 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -48,7 +48,7 @@ CONFFILES= example.conf input.conf menu.conf dvb-menu.conf
USES+= iconv pkgconfig
.include "${.CURDIR}/../../multimedia/mplayer/Makefile.optvars"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS+= --disable-arts \
--disable-directfb \
@@ -64,8 +64,6 @@ CONFIGURE_ARGS+= --disable-arts \
--disable-musepack \
--disable-theora
-.include "${.CURDIR}/../../multimedia/mplayer/Makefile.options"
-
.if ${PORT_OPTIONS:MGUI} && ${PORT_OPTIONS:MX11}
PLIST_SUB+= GMPLAYER=""
DESKTOP_ENTRIES= "MPlayer" "High performance media player" "mplayer" "gmplayer" "" false
@@ -115,6 +113,9 @@ CONFIGURE_ARGS+=--enable-xvmc --with-xvmclib=XvMCW
CONFIGURE_ARGS+=--disable-x11
.endif
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../multimedia/mplayer/Makefile.options"
+
pre-everything::
@${ECHO_MSG} "N - O - T - E"
@${ECHO_MSG} ""
diff --git a/multimedia/winff/Makefile b/multimedia/winff/Makefile
index a0974e8a03f0..b357142ebd80 100644
--- a/multimedia/winff/Makefile
+++ b/multimedia/winff/Makefile
@@ -45,7 +45,7 @@ QT4_DESC= Use qt4 interface
OPTIONS_DEFAULT= GTK2
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
USE_FPC+= gtk2
@@ -80,4 +80,4 @@ do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/*.pdf ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>