aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-05-01 01:16:04 +0800
committerolivierd <olivierd@FreeBSD.org>2013-05-01 01:16:04 +0800
commitbdbefe3abb6d2667a0a6a83523a67ffb205a5094 (patch)
treecf2347717538605001cce768bc31be39c85def5b /multimedia
parente4ec23046b134dff3b4ade98aa72aa31281a932b (diff)
downloadfreebsd-ports-gnome-bdbefe3abb6d2667a0a6a83523a67ffb205a5094.tar.gz
freebsd-ports-gnome-bdbefe3abb6d2667a0a6a83523a67ffb205a5094.tar.zst
freebsd-ports-gnome-bdbefe3abb6d2667a0a6a83523a67ffb205a5094.zip
- Adopt USES for desktop-file-utils, pathfix
- Add support for GStreamer 1.0 (GST10) and GStreamer 0.10 (GST01) - Add rtmp plugins (only available with GStreamer 1.0) - Apply 2 patches (obtained from upstream repository), to use gst-helper for setting the volume, and to reduce mousewheel volume-steps (10% -> 5%)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/xfce4-parole/Makefile46
-rw-r--r--multimedia/xfce4-parole/files/patch-src__gst__parole-gst.c31
-rw-r--r--multimedia/xfce4-parole/files/patch-src__parole-player.c28
-rw-r--r--multimedia/xfce4-parole/pkg-plist2
4 files changed, 91 insertions, 16 deletions
diff --git a/multimedia/xfce4-parole/Makefile b/multimedia/xfce4-parole/Makefile
index c7085ca1caee..30bef4e5ba20 100644
--- a/multimedia/xfce4-parole/Makefile
+++ b/multimedia/xfce4-parole/Makefile
@@ -3,6 +3,7 @@
PORTNAME= parole
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= multimedia xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}/
DIST_SUBDIR= xfce4
@@ -19,35 +20,61 @@ LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib \
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GSTREAMER= core faad flac wavpack
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-notify-plugin \
--enable-tray-plugin \
--enable-taglib \
- --with-gstreamer=0.10 \
--without-html-dir
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GNOME= gnomehack gtk20 glib20 intltool intlhack desktopfileutils
+USE_GNOME= gtk20 glib20 intltool intlhack
USE_XFCE= configenv libmenu libutil
USE_XORG= x11 sm
USE_LDCONFIG= yes
-USES= pkgconfig
+USES= desktop-file-utils pathfix pkgconfig
-OPTIONS_DEFINE= CDDA HTTP NLS
-OPTIONS_DEFAULT= CDDA HTTP NLS
-CDDA_DESC= CD audio support (cdparanoia)
-HTTP_DESC= HTTP streaming support (libsoup)
+OPTIONS_DEFINE= NLS
+OPTIONS_SINGLE= GSTREAMER
+# GST01 (GStreamer 0.10), GST10 (GStreamer 1.0)
+OPTIONS_SINGLE_GSTREAMER= GST01 GST10
+OPTIONS_GROUP= GST_PLUG
+OPTIONS_GROUP_GST_PLUG= CDDA HTTP
+OPTIONS_DEFAULT= GST01 NLS
+CDDA_DESC= CD audio (cdparanoia)
+HTTP_DESC= HTTP streaming (libsoup)
+GST01_DESC= GStreamer 0.10
+GST10_DESC= GStreamer 1.0
+GST_PLUG_DESC= Additional GStreamer plugins
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MGST01}
+USE_GSTREAMER= core faad flac wavpack
+CONFIGURE_ARGS+=--with-gstreamer=0.10
+.endif
+
+.if ${PORT_OPTIONS:MGST10}
+USE_GSTREAMER1= core faad flac wavpack rtmp x
+CONFIGURE_ARGS+=--with-gstreamer=1.0
+.endif
+
.if ${PORT_OPTIONS:MCDDA}
+.if ${PORT_OPTIONS:MGST01}
USE_GSTREAMER+= cdparanoia
.endif
+.if ${PORT_OPTIONS:MGST10}
+USE_GSTREAMER1+= cdparanoia
+.endif
+.endif
.if ${PORT_OPTIONS:MHTTP}
+.if ${PORT_OPTIONS:MGST01}
USE_GSTREAMER+= soup
.endif
+.if ${PORT_OPTIONS:MGST10}
+USE_GSTREAMER1+= soup
+.endif
+.endif
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
@@ -63,7 +90,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|xfce4/src/misc|${PORTNAME}|g' \
${WRKSRC}/src/common/parole-rc-utils.h
-post-install:
- @-update-desktop-database
-
.include <bsd.port.mk>
diff --git a/multimedia/xfce4-parole/files/patch-src__gst__parole-gst.c b/multimedia/xfce4-parole/files/patch-src__gst__parole-gst.c
index 77423e350673..f60202045aa7 100644
--- a/multimedia/xfce4-parole/files/patch-src__gst__parole-gst.c
+++ b/multimedia/xfce4-parole/files/patch-src__gst__parole-gst.c
@@ -1,6 +1,18 @@
--- ./src/gst/parole-gst.c.orig 2013-03-07 00:14:28.000000000 +0000
-+++ ./src/gst/parole-gst.c 2013-03-09 22:44:40.000000000 +0000
-@@ -1573,22 +1573,36 @@
++++ ./src/gst/parole-gst.c 2013-04-28 16:06:10.000000000 +0000
+@@ -33,9 +33,11 @@
+ #if GST_CHECK_VERSION(1, 0, 0)
+ #include <gst/video/videooverlay.h>
+ #include <gst/video/navigation.h>
++#include <gst/audio/streamvolume.h>
+ #else
+ #include <gst/interfaces/xoverlay.h>
+ #include <gst/interfaces/navigation.h>
++#include <gst/interfaces/streamvolume.h>
+ #endif
+
+ #include <gst/pbutils/missing-plugins.h>
+@@ -1573,22 +1575,36 @@
dialog = GTK_MESSAGE_DIALOG(gtk_message_dialog_new_with_markup(
NULL,
GTK_DIALOG_MODAL | GTK_DIALOG_DESTROY_WITH_PARENT,
@@ -37,7 +49,7 @@
desc);
return GTK_DIALOG(dialog);
-@@ -1712,7 +1726,7 @@
+@@ -1712,7 +1728,7 @@
#endif
gst_install_plugins_context_free(ctx);
}
@@ -46,3 +58,16 @@
gtk_widget_destroy(GTK_WIDGET(dialog));
}
break;
+@@ -2624,9 +2640,9 @@
+
+ void parole_gst_set_volume (ParoleGst *gst, gdouble value)
+ {
+- g_object_set (G_OBJECT (gst->priv->playbin),
+- "volume", value,
+- NULL);
++ gst_stream_volume_set_volume (GST_STREAM_VOLUME (gst->priv->playbin),
++ GST_STREAM_VOLUME_FORMAT_CUBIC,
++ value);
+ }
+
+ gdouble parole_gst_get_volume (ParoleGst *gst)
diff --git a/multimedia/xfce4-parole/files/patch-src__parole-player.c b/multimedia/xfce4-parole/files/patch-src__parole-player.c
new file mode 100644
index 000000000000..5632695ac677
--- /dev/null
+++ b/multimedia/xfce4-parole/files/patch-src__parole-player.c
@@ -0,0 +1,28 @@
+--- ./src/parole-player.c.orig 2013-03-07 00:14:28.000000000 +0000
++++ ./src/parole-player.c 2013-04-28 16:08:15.000000000 +0000
+@@ -1650,6 +1650,7 @@
+ seek = parole_gst_get_stream_position (PAROLE_GST (player->priv->gst) )
+ -
+ seek;
++ if ( seek < 0 ) { seek = 0; }
+ parole_gst_seek (PAROLE_GST (player->priv->gst), seek);
+ parole_player_change_range_value (player, seek);
+ }
+@@ -2241,7 +2242,7 @@
+ {
+ gdouble value;
+ value = gtk_scale_button_get_value (GTK_SCALE_BUTTON (player->priv->volume));
+- gtk_scale_button_set_value (GTK_SCALE_BUTTON (player->priv->volume), value + 0.1);
++ gtk_scale_button_set_value (GTK_SCALE_BUTTON (player->priv->volume), value + 0.05);
+ }
+
+ void
+@@ -2249,7 +2250,7 @@
+ {
+ gdouble value;
+ value = gtk_scale_button_get_value (GTK_SCALE_BUTTON (player->priv->volume));
+- gtk_scale_button_set_value (GTK_SCALE_BUTTON (player->priv->volume), value - 0.1);
++ gtk_scale_button_set_value (GTK_SCALE_BUTTON (player->priv->volume), value - 0.05);
+ }
+
+ void parole_player_volume_mute (GtkWidget *widget, ParolePlayer *player)
diff --git a/multimedia/xfce4-parole/pkg-plist b/multimedia/xfce4-parole/pkg-plist
index 6140e80fa55a..093807981ae6 100644
--- a/multimedia/xfce4-parole/pkg-plist
+++ b/multimedia/xfce4-parole/pkg-plist
@@ -76,5 +76,3 @@ share/pixmaps/parole.png
%%NLS%%@dirrmtry share/locale/ast
@dirrm lib/parole-0
@dirrm include/parole
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true