aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-08-05 02:19:49 +0800
committeritetcu <itetcu@FreeBSD.org>2006-08-05 02:19:49 +0800
commitbe177739a5cba5710a7e52a7c946e74969a6f932 (patch)
treed55e20575e7838c60cc5ef7ac8a44c9c207e39f3 /multimedia
parent27d398fd0b056243414eaabf03b355b2b1718103 (diff)
downloadfreebsd-ports-gnome-be177739a5cba5710a7e52a7c946e74969a6f932.tar.gz
freebsd-ports-gnome-be177739a5cba5710a7e52a7c946e74969a6f932.tar.zst
freebsd-ports-gnome-be177739a5cba5710a7e52a7c946e74969a6f932.zip
Apply some user-requested changes to the mplayer port:
o Have mga xvidix driver autodetect memory, reported by Andre Albsmeier o Remove PKGSUFFIX stuff, instead port name is always "mplayer" o Use win32 real player codecs if the user prohibits linux-realplayer interaction PR: ports/101224 Submitted by: Thomas E. Zander (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile21
-rw-r--r--multimedia/mplayer/files/patch-vidix-drivers-mga_vid.c13
2 files changed, 21 insertions, 13 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index aafbab5b9eff..b9097d7fbb5b 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -84,6 +84,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.8
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -173,6 +174,10 @@ TOOLFILES= calcbpp.pl countquant.pl dvd2divxscript.pl \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+IGNORE= does not build on 4.x. Patches are welcome
+.endif
+
#Building of vidix dependent shared libs is only possible
#on i386 at the moment.
.if ${ARCH} == "i386"
@@ -246,12 +251,6 @@ USE_GCC= 3.4
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --enable-gui
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gtk2
-.else
-PKGNAMESUFFIX= -gtk2
-.endif
-
.if defined(WITH_LANG)
WITH_LANG= ""
.endif
@@ -377,11 +376,6 @@ CONFIGURE_ARGS+= --disable-x264
.if !defined(WITHOUT_ESOUND)
USE_GNOME+= esound
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-esound
-.else
-PKGNAMESUFFIX= -esound
-.endif
.else
CONFIGURE_ARGS+= --disable-esd
.endif
@@ -397,8 +391,13 @@ CONFIGURE_ARGS+= --enable-real \
RUN_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
BUILD_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
.else
+.if !defined(WITHOUT_WIN32)
+CONFIGURE_ARGS+= --enable-real \
+ --with-reallibdir=${LOCALBASE}/lib/win32
+.else
CONFIGURE_ARGS+= --disable-real
.endif
+.endif
.if !defined(WITHOUT_LIVEMEDIA)
CONFIGURE_ARGS+= --enable-live \
diff --git a/multimedia/mplayer/files/patch-vidix-drivers-mga_vid.c b/multimedia/mplayer/files/patch-vidix-drivers-mga_vid.c
index 3fadae0b3807..c6edd3977fa2 100644
--- a/multimedia/mplayer/files/patch-vidix-drivers-mga_vid.c
+++ b/multimedia/mplayer/files/patch-vidix-drivers-mga_vid.c
@@ -1,5 +1,14 @@
---- vidix/drivers/mga_vid.c.orig Thu Sep 2 13:34:25 2004
-+++ vidix/drivers/mga_vid.c Tue Apr 12 17:51:55 2005
+--- vidix/drivers/mga_vid.c.orig Sun Jun 11 20:35:43 2006
++++ vidix/drivers/mga_vid.c Mon Jul 31 22:48:55 2006
+@@ -43,7 +43,7 @@
+
+ #define MGA_VSYNC_POS 2
+
+-#undef MGA_PCICONFIG_MEMDETECT
++#define MGA_PCICONFIG_MEMDETECT
+
+ #define MGA_DEFAULT_FRAMES 4
+
@@ -1218,8 +1218,7 @@
{
if ((lst[i].command & PCI_COMMAND_IO) == 0)