aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
committerxmj <xmj@FreeBSD.org>2014-09-22 18:40:00 +0800
commitd39787ca07e42b7a91488f45cc6c58333ae10780 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /multimedia
parent143e62b0f3ebf9f9c709e4c068013418325fc64c (diff)
downloadfreebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.gz
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.tar.zst
freebsd-ports-gnome-d39787ca07e42b7a91488f45cc6c58333ae10780.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile2
-rw-r--r--multimedia/linux-c6-libtheora/Makefile27
-rw-r--r--multimedia/linux-c6-libtheora/distinfo.i6864
-rw-r--r--multimedia/linux-c6-libv4l/Makefile19
-rw-r--r--multimedia/linux-c6-libv4l/distinfo.i6864
-rw-r--r--multimedia/linux-c6-libv4l/pkg-descr17
-rw-r--r--multimedia/linux-c6-libv4l/pkg-plist14
-rw-r--r--multimedia/linux-f10-libtheora/Makefile6
-rw-r--r--multimedia/linux-f10-libv4l/Makefile5
9 files changed, 92 insertions, 6 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index a38668f70d4f..307fbd4edf64 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -195,6 +195,8 @@
SUBDIR += libxine
SUBDIR += libxspf
SUBDIR += libzen
+ SUBDIR += linux-c6-libtheora
+ SUBDIR += linux-c6-libv4l
SUBDIR += linux-f10-libtheora
SUBDIR += linux-f10-libv4l
SUBDIR += linux-realplayer
diff --git a/multimedia/linux-c6-libtheora/Makefile b/multimedia/linux-c6-libtheora/Makefile
new file mode 100644
index 000000000000..bffe9abf26fb
--- /dev/null
+++ b/multimedia/linux-c6-libtheora/Makefile
@@ -0,0 +1,27 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= libtheora
+PORTVERSION= 1.1.0
+CATEGORIES= multimedia linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Theora Video Compression Codec (Linux Fedora 10)
+
+CONFLICTS= linux-libtheora-[0-9]* linux-f10-libtheora[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+
+RPMVERSION= 2.el6
+USE_LDCONFIG= yes
+
+PLIST_FILES= usr/lib/libtheora.so.0 usr/lib/libtheora.so.0.3.9 \
+ usr/lib/libtheoradec.so.1 usr/lib/libtheoradec.so.1.1.3 \
+ usr/lib/libtheoraenc.so.1 usr/lib/libtheoraenc.so.1.1.2
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= COPYING README
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/multimedia/linux-c6-libtheora/distinfo.i686 b/multimedia/linux-c6-libtheora/distinfo.i686
new file mode 100644
index 000000000000..50bfa310d490
--- /dev/null
+++ b/multimedia/linux-c6-libtheora/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/libtheora-1.1.0-2.el6.i686.rpm) = 0d7e7b9daa9d0d4d1dc52bb00e3022f11e1b3401ca7c646f5538c0042c3a29b7
+SIZE (rpm/i686/centos/6.5/libtheora-1.1.0-2.el6.i686.rpm) = 134564
+SHA256 (rpm/i686/centos/6.5/libtheora-1.1.0-2.el6.src.rpm) = 2f903b66160f5f5f19684a8cbe96c8c746c9fd77e8d93da15ac4fbbc67c2a16b
+SIZE (rpm/i686/centos/6.5/libtheora-1.1.0-2.el6.src.rpm) = 1381855
diff --git a/multimedia/linux-c6-libv4l/Makefile b/multimedia/linux-c6-libv4l/Makefile
new file mode 100644
index 000000000000..188fc658bb3f
--- /dev/null
+++ b/multimedia/linux-c6-libv4l/Makefile
@@ -0,0 +1,19 @@
+# Created by: bsam
+# $FreeBSD$
+
+PORTNAME= libv4l
+PORTVERSION= 0.6.3
+CATEGORIES= multimedia linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Collection of video4linux support libraries (CentOS 6)
+
+CONFLICTS= linux-f10-libv4l-[0-9]*
+
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+RPMVERSION= 2.el6
+USE_LDCONFIG= yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/multimedia/linux-c6-libv4l/distinfo.i686 b/multimedia/linux-c6-libv4l/distinfo.i686
new file mode 100644
index 000000000000..f3ea5598e6fa
--- /dev/null
+++ b/multimedia/linux-c6-libv4l/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/libv4l-0.6.3-2.el6.i686.rpm) = 44b8430a7f5dfb37dd57868f7f33e06194bb5ae4584592e9726417158e0cba5e
+SIZE (rpm/i686/centos/6.5/libv4l-0.6.3-2.el6.i686.rpm) = 103848
+SHA256 (rpm/i686/centos/6.5/libv4l-0.6.3-2.el6.src.rpm) = 4dffde0aeeb35b9ea30c2ebb04cb60fd73d3eb89cd2530b92fbe1c2d6907a24c
+SIZE (rpm/i686/centos/6.5/libv4l-0.6.3-2.el6.src.rpm) = 138961
diff --git a/multimedia/linux-c6-libv4l/pkg-descr b/multimedia/linux-c6-libv4l/pkg-descr
new file mode 100644
index 000000000000..2426783acae1
--- /dev/null
+++ b/multimedia/linux-c6-libv4l/pkg-descr
@@ -0,0 +1,17 @@
+libv4l is a collection of libraries which adds a thin abstraction layer on
+top of video4linux2 devices. The purpose of this (thin) layer is to make it
+easy for application writers to support a wide variety of devices without
+having to write separate code for different devices in the same class. libv4l
+consists of 3 different libraries: libv4lconvert, libv4l1 and libv4l2.
+
+libv4lconvert offers functions to convert from any (known) pixel-format
+to V4l2_PIX_FMT_BGR24 or V4l2_PIX_FMT_YUV420.
+
+libv4l1 offers the (deprecated) v4l1 API on top of v4l2 devices, independent
+of the drivers for those devices supporting v4l1 compatibility (which many
+v4l2 drivers do not).
+
+libv4l2 offers the v4l2 API on top of v4l2 devices, while adding for the
+application transparent libv4lconvert conversion where necessary.
+
+WWW: http://hansdegoede.livejournal.com/3636.html
diff --git a/multimedia/linux-c6-libv4l/pkg-plist b/multimedia/linux-c6-libv4l/pkg-plist
new file mode 100644
index 000000000000..96b7396af4cd
--- /dev/null
+++ b/multimedia/linux-c6-libv4l/pkg-plist
@@ -0,0 +1,14 @@
+@comment file listing
+usr/lib/libv4l/ov511-decomp
+usr/lib/libv4l/ov518-decomp
+usr/lib/libv4l/v4l1compat.so
+usr/lib/libv4l/v4l2convert.so
+usr/lib/libv4l1.so.0
+usr/lib/libv4l2.so.0
+usr/lib/libv4lconvert.so.0
+usr/share/doc/libv4l-%%PORTVERSION%%/COPYING.LIB
+usr/share/doc/libv4l-%%PORTVERSION%%/ChangeLog
+usr/share/doc/libv4l-%%PORTVERSION%%/README
+usr/share/doc/libv4l-%%PORTVERSION%%/TODO
+@dirrm usr/share/doc/libv4l-%%PORTVERSION%%
+@dirrm usr/lib/libv4l
diff --git a/multimedia/linux-f10-libtheora/Makefile b/multimedia/linux-f10-libtheora/Makefile
index d17a9d7aaf91..f20095c4ff21 100644
--- a/multimedia/linux-f10-libtheora/Makefile
+++ b/multimedia/linux-f10-libtheora/Makefile
@@ -3,10 +3,9 @@
PORTNAME= libtheora
PORTVERSION= 1.0rc1
+PORTREVISION= 1
CATEGORIES= multimedia linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Theora Video Compression Codec (Linux Fedora 10)
@@ -14,8 +13,9 @@ COMMENT= Theora Video Compression Codec (Linux Fedora 10)
CONFLICTS= linux-libtheora-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= f10
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 10
+
RPMVERSION= 2.fc10
USE_LDCONFIG= yes
diff --git a/multimedia/linux-f10-libv4l/Makefile b/multimedia/linux-f10-libv4l/Makefile
index 3cceba9a2967..3081391c8822 100644
--- a/multimedia/linux-f10-libv4l/Makefile
+++ b/multimedia/linux-f10-libv4l/Makefile
@@ -4,14 +4,13 @@
PORTNAME= libv4l
PORTVERSION= 0.6.2
CATEGORIES= multimedia linux
-PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Collection of video4linux support libraries (Fedora 10)
+USE_LINUX= f10
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 10
+
RPMVERSION= 1.fc10
USE_LDCONFIG= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}