aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2015-08-19 01:41:32 +0800
committerdelphij <delphij@FreeBSD.org>2015-08-19 01:41:32 +0800
commite5cb6561ee40a415db72b036d2d93ce1837e9726 (patch)
tree93545d183521c248cedd9aec81b29420ebd03ccd /multimedia
parentb4cef8e57acb3086788e73c591b2f88c3f37aa78 (diff)
downloadfreebsd-ports-gnome-e5cb6561ee40a415db72b036d2d93ce1837e9726.tar.gz
freebsd-ports-gnome-e5cb6561ee40a415db72b036d2d93ce1837e9726.tar.zst
freebsd-ports-gnome-e5cb6561ee40a415db72b036d2d93ce1837e9726.zip
Apply vendor changeset ce91452:
demux: mp4: correctly match release function Obtained from: VLC MFH: 2015Q3
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--multimedia/vlc/files/patch-vendor-00-ce9145229
2 files changed, 30 insertions, 1 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index ab1dc0224c42..61f6fd185312 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 2.2.1
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
diff --git a/multimedia/vlc/files/patch-vendor-00-ce91452 b/multimedia/vlc/files/patch-vendor-00-ce91452
new file mode 100644
index 000000000000..fa5a6a92a319
--- /dev/null
+++ b/multimedia/vlc/files/patch-vendor-00-ce91452
@@ -0,0 +1,29 @@
+From ce91452460a75d7424b165c4dc8db98114c3cbd9 Mon Sep 17 00:00:00 2001
+From: Francois Cartegnie <fcartegnie@free.fr>
+Date: Mon, 3 Aug 2015 15:17:32 +0200
+Subject: [PATCH] demux: mp4: correctly match release function
+
+Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
+---
+ modules/demux/mp4/libmp4.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git modules/demux/mp4/libmp4.c modules/demux/mp4/libmp4.c
+index 331262b..f220e51 100644
+--- modules/demux/mp4/libmp4.c
++++ modules/demux/mp4/libmp4.c
+@@ -3643,6 +3643,11 @@ void MP4_BoxFree( stream_t *s, MP4_Box_t *p_box )
+ {
+ for( i_index = 0; ; i_index++ )
+ {
++ if ( MP4_Box_Function[i_index].i_parent &&
++ p_box->p_father &&
++ p_box->p_father->i_type != MP4_Box_Function[i_index].i_parent )
++ continue;
++
+ if( ( MP4_Box_Function[i_index].i_type == p_box->i_type )||
+ ( MP4_Box_Function[i_index].i_type == 0 ) )
+ {
+--
+1.7.10.4
+