aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-02 20:43:46 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-02 20:43:46 +0800
commite60d3a8ef53744ce27a79f7aacaccaa4f82cf6f0 (patch)
tree476951412393d1a076d15e17d7caec1a6912637e /multimedia
parente974f17cd794b78db57aa779a2c908a0088d7538 (diff)
downloadfreebsd-ports-gnome-e60d3a8ef53744ce27a79f7aacaccaa4f82cf6f0.tar.gz
freebsd-ports-gnome-e60d3a8ef53744ce27a79f7aacaccaa4f82cf6f0.tar.zst
freebsd-ports-gnome-e60d3a8ef53744ce27a79f7aacaccaa4f82cf6f0.zip
Use c++ instead of cc for linking shared library from objects generated
from C++ code. This fixes the port on -current.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/smpeg/Makefile3
-rw-r--r--multimedia/smpeg/files/patch-configure13
2 files changed, 15 insertions, 1 deletions
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
index 75393ef17aac..931ff2345d89 100644
--- a/multimedia/smpeg/Makefile
+++ b/multimedia/smpeg/Makefile
@@ -26,7 +26,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
GLBASE="${X11BASE}" \
- CPPFLAGS="-I${X11BASE}/include"
+ CPPFLAGS="-I${X11BASE}/include" \
+ CC="${CXX}" REAL_CC="${CC}"
#If you want to try the opengl player (which doesn't seem to work)
#comment out the following line.
diff --git a/multimedia/smpeg/files/patch-configure b/multimedia/smpeg/files/patch-configure
new file mode 100644
index 000000000000..8eddcc730596
--- /dev/null
+++ b/multimedia/smpeg/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/07/02 12:33:37 1.1
++++ configure 2002/07/02 12:34:01
+@@ -2335,6 +2335,7 @@
+
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
++CC="$REAL_CC"
+
+ echo $ac_n "checking for sqrt in -lm""... $ac_c" 1>&6
+ echo "configure:2341: checking for sqrt in -lm" >&5