aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-02-28 19:48:08 +0800
committerriggs <riggs@FreeBSD.org>2016-02-28 19:48:08 +0800
commitea97db70c202156cd8dd256a3abc8ff670fc930e (patch)
tree1dc45c3fb6450189da30936f0d53744fe3a49dba /multimedia
parent69c0320ad83805cf160fab4b9a9e275a3f29bd0c (diff)
downloadfreebsd-ports-gnome-ea97db70c202156cd8dd256a3abc8ff670fc930e.tar.gz
freebsd-ports-gnome-ea97db70c202156cd8dd256a3abc8ff670fc930e.tar.zst
freebsd-ports-gnome-ea97db70c202156cd8dd256a3abc8ff670fc930e.zip
Respect timezone settings, remove unnecessary pkg-install script
Detailed maintainer log: - Remove the setting of the TZ, LC_ALL and LANG shell variables from rc script. This resolves an issue where the emby-server timezone was set to UTC, causing show air dates and TV guides to be off by a number of hours for some users [1]. Setting these variables was originally added when mono 3.12.1 was in the ports tree, to avoid mono throwing a number of System.TimeZoneNotFound exceptions when run in debugging mode [2]. Whilst these exceptions are still thrown, they are caught and the mono code now only sets the time to UTC if the correct timezone cannot be found from the TZ variable or /etc/localtime. - Remove pkg-install script as it is no longer necessary to download Mozilla's root certificates and import them into the Mono Trust store (this was actually never effective, as the certificates were saved into the root user's mono trust store instead of the emby user's store). - Bump PORTREVISION [1] http://emby.media/community/index.php?/topic/13083-freenas-plugin/?p=299783 [2] mono --debug --trace=N:nothing /usr/local/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/local/bin/ffmpeg -ffprobe /usr/local/bin/ffprobe -programdata /var/db/emby-server PR: 207436 Submitted by: woodsb02@gmail.com (maintainer) MFH: 2016Q1
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/emby-server/Makefile1
-rw-r--r--multimedia/emby-server/files/emby-server.in7
-rw-r--r--multimedia/emby-server/pkg-install15
3 files changed, 1 insertions, 22 deletions
diff --git a/multimedia/emby-server/Makefile b/multimedia/emby-server/Makefile
index 56f56234c2bd..72e8dc94ebda 100644
--- a/multimedia/emby-server/Makefile
+++ b/multimedia/emby-server/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emby-server
PORTVERSION= 3.0.5821
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= woodsb02@gmail.com
diff --git a/multimedia/emby-server/files/emby-server.in b/multimedia/emby-server/files/emby-server.in
index 3bb510367ce1..0a571f0b78fd 100644
--- a/multimedia/emby-server/files/emby-server.in
+++ b/multimedia/emby-server/files/emby-server.in
@@ -50,13 +50,6 @@ command_args="-f -p ${pidfile} ${procname} %%PREFIX%%/lib/emby-server/MediaBrows
start_precmd=%%RC_NAME%%_precmd
%%RC_NAME%%_precmd()
{
- : ${LC_ALL:="C"}
- : ${LANG:="C"}
- : ${TZ:="UTC"}
- export LC_ALL
- export LANG
- export TZ
-
if [ ! -e "${pidfile}" ]; then
install -g ${%%RC_NAME%%_group} -o ${%%RC_NAME%%_user} -- /dev/null "${pidfile}";
fi
diff --git a/multimedia/emby-server/pkg-install b/multimedia/emby-server/pkg-install
deleted file mode 100644
index dd55c74de183..000000000000
--- a/multimedia/emby-server/pkg-install
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-if [ $# -ne 2 ]; then
- echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
- exit 1
-fi
-
-case $2 in
- POST-INSTALL)
- echo "Downloading Mozilla's root certificates and importing into the Mono Trust store..."
- ${PKG_PREFIX}/bin/mozroots --import --sync
- ;;
-esac
-
-exit 0