aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2004-03-14 18:22:53 +0800
committerlioux <lioux@FreeBSD.org>2004-03-14 18:22:53 +0800
commited9c84d31963d21a9083c13cd12e260ee33a4c25 (patch)
tree72717eff76ff7276cebfca96d85c6d1ebb515f1d /multimedia
parent850aa471692c00cf0690be4a78ed9a85965dab39 (diff)
downloadfreebsd-ports-gnome-ed9c84d31963d21a9083c13cd12e260ee33a4c25.tar.gz
freebsd-ports-gnome-ed9c84d31963d21a9083c13cd12e260ee33a4c25.tar.zst
freebsd-ports-gnome-ed9c84d31963d21a9083c13cd12e260ee33a4c25.zip
o Play nice in FreeBSD series before 5.x, defaulting on all mkvtoolnix
dependencies (them and it at the same time) to USE_GCC=2.95 is enough o The requirement on gcc 3.x on one of the dependencies was removed and I forgot to check yet another variation PR: 63581 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libmatroska/Makefile11
-rw-r--r--multimedia/mkvtoolnix/Makefile11
2 files changed, 12 insertions, 10 deletions
diff --git a/multimedia/libmatroska/Makefile b/multimedia/libmatroska/Makefile
index ae4ce1c95086..59ee450fa4df 100644
--- a/multimedia/libmatroska/Makefile
+++ b/multimedia/libmatroska/Makefile
@@ -46,11 +46,6 @@ do-configure:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-# this is gcc 2.x
-CFLAGS+= -DNO_WSTRING
-.endif
-
# gcc 3.2 was available on 5.x before this OSVERSION
# do not build gcc 3.3 unless necessary
.if ${OSVERSION} < 501103
@@ -61,4 +56,10 @@ USE_GCC=3.2
USE_GCC=3.3
.endif
+.if ${OSVERSION} < 500000
+USE_GCC=2.95
+# this is gcc 2.x
+CFLAGS+= -DNO_WSTRING -I${LOCALBASE}/include
+.endif
+
.include <bsd.port.post.mk>
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 13e3be6c78ee..27921ad3eb57 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -37,11 +37,6 @@ post-patch:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-# this is gcc 2.x
-CFLAGS+= -DNO_WSTRING
-.endif
-
# gcc 3.2 was available on 5.x before this OSVERSION
# do not build gcc 3.3 unless necessary
.if ${OSVERSION} < 501103
@@ -52,4 +47,10 @@ USE_GCC=3.2
USE_GCC=3.3
.endif
+.if ${OSVERSION} < 500000
+USE_GCC=2.95
+# this is gcc 2.x
+CFLAGS+= -DNO_WSTRING
+.endif
+
.include <bsd.port.post.mk>