aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2009-03-01 12:36:56 +0800
committernobutaka <nobutaka@FreeBSD.org>2009-03-01 12:36:56 +0800
commitf045cffd1e322a08c55a1e3b3f771a3269d14b47 (patch)
treeac2db53e0696523edcd9e3c0847b1e704db987fc /multimedia
parent8c11047bd1df02c055faf3dc915ad8a9e7ca574c (diff)
downloadfreebsd-ports-gnome-f045cffd1e322a08c55a1e3b3f771a3269d14b47.tar.gz
freebsd-ports-gnome-f045cffd1e322a08c55a1e3b3f771a3269d14b47.tar.zst
freebsd-ports-gnome-f045cffd1e322a08c55a1e3b3f771a3269d14b47.zip
Fix DivX/XviD support breakage.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libxine/Makefile4
-rw-r--r--multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in11
2 files changed, 8 insertions, 7 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index ae5892f06d69..a6da4e6b1eb6 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.1.16.2
+PORTREVISION= 1
CATEGORIES= multimedia ipv6
MASTER_SITES= SF
PKGNAMEPREFIX= lib
@@ -50,7 +51,8 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -fno-force-addr -I${LOCALBASE}/include -I${LOCA
EXTRA_X_LIBS="-lGL -lGLU -lXext -lX11 -lm"
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32 --enable-ipv6 \
--with-external-libmad \
- --with-external-libdts --with-libflac --disable-v4l
+ --with-external-libdts --with-libflac --disable-v4l \
+ --with-external-ffmpeg=no
OPTIONS= ARTS "Enable aRts support" off \
CACA "Enable libcaca support" off \
diff --git a/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in b/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in
index 144b57e0c39f..5a11127433ae 100644
--- a/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in
+++ b/multimedia/libxine/files/patch-src_combined_ffmpeg_Makefile.in
@@ -1,12 +1,11 @@
---- src/combined/ffmpeg/Makefile.in.orig 2009-02-22 09:21:57.000000000 +0900
-+++ src/combined/ffmpeg/Makefile.in 2009-02-22 09:51:00.000000000 +0900
-@@ -889,8 +889,8 @@
-
+--- src/combined/ffmpeg/Makefile.in.orig 2009-03-01 12:02:37.000000000 +0900
++++ src/combined/ffmpeg/Makefile.in 2009-03-01 12:36:05.000000000 +0900
+@@ -890,7 +890,8 @@
avcodec_audio.list avcodec_video.list:
echo '#include "$(srcdir)/ffmpeg_decoder.h"' | $(AV_CPP) - |\
-- sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' |\
+ sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' |\
- head -n -1 >$@
-+ sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' >$@
++ $(PERL) -pe "s/^\s*//" > $@
+ sed -i.bak -e '$$d' $@
# Generate the mappings. These are #included where needed.