aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-07-05 05:54:55 +0800
committerahze <ahze@FreeBSD.org>2005-07-05 05:54:55 +0800
commitf6a187ae1d785aa2935431e5e542afc3108c4607 (patch)
tree72585f51f61c71ffb183e5b7b36f6212bf050360 /multimedia
parent73f676bd501351bb490f96f7d1e7c5f98253d4db (diff)
downloadfreebsd-ports-gnome-f6a187ae1d785aa2935431e5e542afc3108c4607.tar.gz
freebsd-ports-gnome-f6a187ae1d785aa2935431e5e542afc3108c4607.tar.zst
freebsd-ports-gnome-f6a187ae1d785aa2935431e5e542afc3108c4607.zip
- Add multimedia/istanbul
Istanbul is a desktop session recorder for the Free Desktop. It records your session into an Ogg Theora video file. To start the recording, you click on its icon in the notification area. To stop you click its icon again. It works on Gnome, KDE, XFCE and others. WWW: http://live.gnome.org/Istanbul PR: ports/82986 Submitted by: Dominique Goncalves <dominique.goncalves@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/istanbul/Makefile31
-rw-r--r--multimedia/istanbul/distinfo2
-rw-r--r--multimedia/istanbul/files/patch-main.py27
-rw-r--r--multimedia/istanbul/files/patch-prefs.py11
-rw-r--r--multimedia/istanbul/pkg-descr6
-rw-r--r--multimedia/istanbul/pkg-plist23
7 files changed, 101 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index a725b3282c09..e4b618b0a061 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -61,6 +61,7 @@
SUBDIR += gxmms
SUBDIR += handbrake
SUBDIR += hayes
+ SUBDIR += istanbul
SUBDIR += kaffeine
SUBDIR += kaffeine-mozilla
SUBDIR += kdemultimedia3
diff --git a/multimedia/istanbul/Makefile b/multimedia/istanbul/Makefile
new file mode 100644
index 000000000000..9142ab20dcda
--- /dev/null
+++ b/multimedia/istanbul/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: istanbul
+# Date created: 2005-07-03
+# Whom: Dominique Goncalves <dominique.goncalves@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= istanbul
+PORTVERSION= 0.1.1
+CATEGORIES= multimedia
+MASTER_SITES= http://live.hujjat.org/
+
+MAINTAINER= dominique.goncalves@gmail.com
+COMMENT= Istanbul is a desktop session recorder for the Free Desktop
+
+RUN_DEPENDS= icecast:${PORTSDIR}/audio/icecast2 \
+ ${PYTHON_SITELIBDIR}/gst/__init__.py:${PORTSDIR}/multimedia/py-gstreamer
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/gst/__init__.py:${PORTSDIR}/multimedia/py-gstreamer
+
+USE_GNOME= pygtk2
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+USE_PYTHON= 2.4+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GSTREAMER= shout2 theora ogg
+USE_REINPLACE= yes
+
+post-configure:
+ ${REINPLACE_CMD} -e "s|#!/usr/bin/python|#!/usr/bin/env python|" `${FIND} ${WRKDIR} -type f -name "istanbul"`
+
+.include <bsd.port.mk>
diff --git a/multimedia/istanbul/distinfo b/multimedia/istanbul/distinfo
new file mode 100644
index 000000000000..5086ece7d49b
--- /dev/null
+++ b/multimedia/istanbul/distinfo
@@ -0,0 +1,2 @@
+MD5 (istanbul-0.1.1.tar.bz2) = 360f0225c916e81eed459e9915caf317
+SIZE (istanbul-0.1.1.tar.bz2) = 238673
diff --git a/multimedia/istanbul/files/patch-main.py b/multimedia/istanbul/files/patch-main.py
new file mode 100644
index 000000000000..2c6f83ce76ee
--- /dev/null
+++ b/multimedia/istanbul/files/patch-main.py
@@ -0,0 +1,27 @@
+--- istanbul/main/main.py
++++ istanbul/main/main.py 2005-07-02 19:39:02.000000000 +0200
+@@ -114,7 +114,7 @@
+ mainpipeline = 'ximagesrc ! ffmpegcolorspace ! videoscale ! video/x-raw-yuv,width=%d,height=%d,framerate=%f' % (width, height, framerate)
+
+ save_pipeline = ''
+- encode_pipeline = ''
++ encode_pipeline = 'theoraenc ! oggmux'
+ icecast_pipeline = ''
+
+ if self.settingsdialog.xml.get_widget('save').get_active():
+@@ -122,7 +122,6 @@
+ encode_pipeline = 'smokeenc ! multipartmux'
+ filename = '%s.tmp' % self.settingsdialog.xml.get_widget('filenameEntry').get_text()
+ else:
+- encode_pipeline = 'theoraenc ! oggmux'
+ filename = self.settingsdialog.xml.get_widget('filenameEntry').get_text()
+
+ save_pipeline = 'filesink location=%s' % filename
+@@ -130,6 +129,7 @@
+ ip = self.settingsdialog.xml.get_widget('shout_ip').get_text()
+ port = self.settingsdialog.xml.get_widget('shout_port').get_value_as_int()
+ mountpoint = self.settingsdialog.xml.get_widget('shout_mount').get_text()
++ password = self.settingsdialog.xml.get_widget('shout_password').get_text()
+ icecast_pipeline = 'shout2send ip=%s port=%s mount=%s password=%s' % (ip, port, mountpoint, password)
+ if save_pipeline != '' and icecast_pipeline != '':
+ final_pipeline = '%s ! %s ! tee name=t ! %s t. ! { queue ! %s }' % (mainpipeline, encode_pipeline, save_pipeline, icecast_pipeline)
diff --git a/multimedia/istanbul/files/patch-prefs.py b/multimedia/istanbul/files/patch-prefs.py
new file mode 100644
index 000000000000..1eb595331a29
--- /dev/null
+++ b/multimedia/istanbul/files/patch-prefs.py
@@ -0,0 +1,11 @@
+--- istanbul/main/prefs.py
++++ istanbul/main/prefs.py 2005-07-02 19:37:21.000000000 +0200
+@@ -61,7 +61,7 @@
+ state = button.get_active()
+ self.xml.get_widget('filenameLabel').set_sensitive(state)
+ self.xml.get_widget('filenameEntry').set_sensitive(state)
+- self.xml.get_widget('encode_later').set_senisitive(state)
++ self.xml.get_widget('encode_later').set_sensitive(state)
+
+ def icecast_toggled_cb(self, button):
+ state = button.get_active()
diff --git a/multimedia/istanbul/pkg-descr b/multimedia/istanbul/pkg-descr
new file mode 100644
index 000000000000..306c7979ec30
--- /dev/null
+++ b/multimedia/istanbul/pkg-descr
@@ -0,0 +1,6 @@
+Istanbul is a desktop session recorder for the Free Desktop. It records your
+session into an Ogg Theora video file. To start the recording, you click on its
+icon in the notification area. To stop you click its icon again. It works on
+Gnome, KDE, XFCE and others.
+
+WWW: http://live.gnome.org/Istanbul
diff --git a/multimedia/istanbul/pkg-plist b/multimedia/istanbul/pkg-plist
new file mode 100644
index 000000000000..160dc8e26fa5
--- /dev/null
+++ b/multimedia/istanbul/pkg-plist
@@ -0,0 +1,23 @@
+bin/istanbul
+%%PYTHON_SITELIBDIR%%/istanbul/__init__.py
+%%PYTHON_SITELIBDIR%%/istanbul/configure/__init__.py
+%%PYTHON_SITELIBDIR%%/istanbul/configure/config.py
+%%PYTHON_SITELIBDIR%%/istanbul/extern/__init__.py
+%%PYTHON_SITELIBDIR%%/istanbul/extern/pytrayicon/__init__.py
+%%PYTHON_SITELIBDIR%%/istanbul/extern/pytrayicon/pytrayicon.so
+%%PYTHON_SITELIBDIR%%/istanbul/main/__init__.py
+%%PYTHON_SITELIBDIR%%/istanbul/main/main.py
+%%PYTHON_SITELIBDIR%%/istanbul/main/prefs.py
+share/applications/istanbul.desktop
+%%DATADIR%%/glade/prefs.glade
+share/pixmaps/istanbul.png
+@dirrm share/istanbul/glade
+@dirrm share/istanbul
+@dirrm %%PYTHON_SITELIBDIR%%/istanbul/main
+@dirrm %%PYTHON_SITELIBDIR%%/istanbul/extern/pytrayicon
+@dirrm %%PYTHON_SITELIBDIR%%/istanbul/extern
+@dirrm %%PYTHON_SITELIBDIR%%/istanbul/configure
+@dirrm %%PYTHON_SITELIBDIR%%/istanbul
+@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2>/dev/null || true
+@unexec rmdir %D/%%PYTHON_LIBDIR%% 2>/dev/null || true
+@unexec rmdir %D/share/applications 2>/dev/null || true