aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/climm
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2009-09-09 16:59:47 +0800
committerjohans <johans@FreeBSD.org>2009-09-09 16:59:47 +0800
commitc779e6023c42afcf690a9c4a8628e418163bcf4a (patch)
tree54e871533c3b19ab4aae049b0ccbdbd461d4dbe2 /net-im/climm
parentff85f564815cb72d082fd7651a26ffd61a368456 (diff)
downloadfreebsd-ports-gnome-c779e6023c42afcf690a9c4a8628e418163bcf4a.tar.gz
freebsd-ports-gnome-c779e6023c42afcf690a9c4a8628e418163bcf4a.tar.zst
freebsd-ports-gnome-c779e6023c42afcf690a9c4a8628e418163bcf4a.zip
- Make configure detect newer gnutls libraries as well (non-default option)
Reported by: Raphael Becker
Diffstat (limited to 'net-im/climm')
-rw-r--r--net-im/climm/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index 763788193022..09b510bef032 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -69,8 +69,9 @@ CONFIGURE_ARGS+= --disable-xmpp --enable-ssl=openssl
.else
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-xmpp --enable-ssl=gnutls \
- --with-libgnutls-prefix=${LOCALBASE} \
--with-libgcrypt-prefix=${LOCALBASE}
+CONFIGURE_ENV+= LIBGNUTLS_CONFIG="${LOCALBASE}/bin/pkg-config gnutls"
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel \
gnutls:${PORTSDIR}/security/gnutls \
gcrypt:${PORTSDIR}/security/libgcrypt \
@@ -79,7 +80,9 @@ LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel \
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/ doc//' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/ac_lib/s/tcl8\./tcl8/g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/ac_lib/s/tcl8\./tcl8/g' \
+ -e '/libgnutls_config_version=/s/--version/--modversion/' \
+ ${WRKSRC}/configure
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/climm.1 ${MANPREFIX}/man/man1