aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/cutegram
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-06-19 06:10:55 +0800
committerGuido Falsi <madpilot@FreeBSD.org>2016-06-19 06:10:55 +0800
commit51ed11820329e949c510a067ceb123f86b01d67b (patch)
tree07b74ae37fded95881236e1b29c9317701b93d4c /net-im/cutegram
parentc4030e6e55c985e93f4150ddf20088683b6e1d1a (diff)
downloadfreebsd-ports-gnome-51ed11820329e949c510a067ceb123f86b01d67b.tar.gz
freebsd-ports-gnome-51ed11820329e949c510a067ceb123f86b01d67b.tar.zst
freebsd-ports-gnome-51ed11820329e949c510a067ceb123f86b01d67b.zip
Fix build with libc++ 3.8.0.
PR: 209967 Submitted by: me Approved by: Henry Hu <henry.hu.sh at gmail.com> (maintainer)
Diffstat (limited to 'net-im/cutegram')
-rw-r--r--net-im/cutegram/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-im/cutegram/Makefile b/net-im/cutegram/Makefile
index d4769d2b698e..34c204602da2 100644
--- a/net-im/cutegram/Makefile
+++ b/net-im/cutegram/Makefile
@@ -24,10 +24,17 @@ GH_TAGNAME= 91bf14b:tools
USES= qmake:outsource desktop-file-utils
USE_QT5= qmake_build buildtools_build core qml quick sql xml multimedia \
widgets dbus webkit quickcontrols graphicaleffects sql-sqlite3
+USE_OPENSSL= yes
+QMAKE_ARGS= LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae" \
+ TELEGRAMQML_INCLUDE_PATH="${LOCALBASE}/include/telegramqml"
INSTALLS_ICONS= yes
post-extract:
@${RMDIR} ${WRKSRC}/Cutegram/asemantools && \
${MV} ${WRKSRC_tools} ${WRKSRC}/Cutegram/asemantools
+post-patch:
+ @${REINPLACE_CMD} -e "/isEmpty(OPENSSL_INCLUDE_PATH)/d" \
+ ${WRKSRC}/Cutegram/Cutegram.pro
+
.include <bsd.port.mk>