aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/decibel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
committerMartin Wilke <miwi@FreeBSD.org>2008-05-28 06:12:09 +0800
commit18dd6954f3060c12b7882f4cb2a1f68dbfc0f102 (patch)
tree51edb00936e1a3da263df313cad16c1fa2858d19 /net-im/decibel/Makefile
parenteb37a12fc9841da5f3a397814fbb99436d82a988 (diff)
downloadfreebsd-ports-gnome-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.tar.gz
freebsd-ports-gnome-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.tar.zst
freebsd-ports-gnome-18dd6954f3060c12b7882f4cb2a1f68dbfc0f102.zip
- Add common code to support for cmake based ports.
- Update devel/cmake to 2.6.0 (also fix ports/123092) - Use the new CMAKE build framework in all ports using cmake Approved by: portmgr (pav)
Diffstat (limited to 'net-im/decibel/Makefile')
-rw-r--r--net-im/decibel/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/net-im/decibel/Makefile b/net-im/decibel/Makefile
index 25a431819fd9..8ea6ad37062b 100644
--- a/net-im/decibel/Makefile
+++ b/net-im/decibel/Makefile
@@ -13,21 +13,15 @@ MASTER_SITES= http://decibel.kde.org/fileadmin/downloads/decibel/releases/
MAINTAINER= kde@FreeBSD.org
COMMENT= Realtime communications framework
-BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
LIB_DEPENDS= QtTapioca.0:${PORTSDIR}/net-im/tapioca-qt
USE_QT_VER= 4
QT_COMPONENTS= corelib xml dbus moc uic rcc qtestlib
USE_LDCONFIG= yes
+USE_CMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
-CMAKE?= ${LOCALBASE}/bin/cmake
-CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
- -DCMAKE_INSTALL_PREFIX=${PREFIX} \
- -DCMAKE_C_COMPILER:STRING='${CC}' \
- -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
- -DCMAKE_CXX_COMPILER:STRING=${CXX} \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+CMAKE_SOURCE_PATH= ..
.include <bsd.port.pre.mk>
@@ -43,7 +37,4 @@ post-patch:
"s,$${LIB_INSTALL_DIR}/pkgconfig,data/pkgconfig,g"\
${WRKSRC}/../src/client/Decibel/CMakeLists.txt
-do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
-
.include <bsd.port.post.mk>