aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/decibel
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-05-11 01:58:21 +0800
committermakc <makc@FreeBSD.org>2009-05-11 01:58:21 +0800
commit0806f9d2ab757db6ae9f631c503c02fd1c0370ea (patch)
treefce18598af35b5373aaa6b0122e026dc9c4d2513 /net-im/decibel
parent01bebd3499cae47f452b3f8dca00fad60d8e157f (diff)
downloadfreebsd-ports-gnome-0806f9d2ab757db6ae9f631c503c02fd1c0370ea.tar.gz
freebsd-ports-gnome-0806f9d2ab757db6ae9f631c503c02fd1c0370ea.tar.zst
freebsd-ports-gnome-0806f9d2ab757db6ae9f631c503c02fd1c0370ea.zip
Remove qt4 build tools from run dependencies,
clean up Makefile, bump PORTREVISION.
Diffstat (limited to 'net-im/decibel')
-rw-r--r--net-im/decibel/Makefile12
-rw-r--r--net-im/decibel/files/patch-CMakeLists.txt4
2 files changed, 5 insertions, 11 deletions
diff --git a/net-im/decibel/Makefile b/net-im/decibel/Makefile
index 23bab9528b52..dcb674617b25 100644
--- a/net-im/decibel/Makefile
+++ b/net-im/decibel/Makefile
@@ -6,7 +6,7 @@
PORTNAME= decibel
PORTVERSION= 0.5.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net-im
MASTER_SITES= http://decibel.kde.org/fileadmin/downloads/decibel/releases/
@@ -16,19 +16,13 @@ COMMENT= Realtime communications framework
LIB_DEPENDS= QtTapioca.0:${PORTSDIR}/net-im/tapioca-qt
USE_QT_VER= 4
-QT_COMPONENTS= corelib qmake xml dbus moc_build uic_build rcc_build qtestlib
+QT_COMPONENTS= xml dbus qtestlib qmake_build moc_build uic_build rcc_build
USE_LDCONFIG= yes
USE_CMAKE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
-CMAKE_SOURCE_PATH= ..
-
-post-extract:
- ${MKDIR} ${WRKSRC}
-
post-patch:
${REINPLACE_CMD} -e \
"s,$${LIB_INSTALL_DIR}/pkgconfig,data/pkgconfig,g"\
- ${WRKSRC}/../src/client/Decibel/CMakeLists.txt
+ ${WRKSRC}/src/client/Decibel/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/net-im/decibel/files/patch-CMakeLists.txt b/net-im/decibel/files/patch-CMakeLists.txt
index 34c02ebabdf3..29e7d0e25ec2 100644
--- a/net-im/decibel/files/patch-CMakeLists.txt
+++ b/net-im/decibel/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../CMakeLists.txt.orig 2007-07-19 19:42:20.000000000 +0400
-+++ ../CMakeLists.txt 2008-12-31 11:24:59.000000000 +0300
+--- CMakeLists.txt.orig 2007-07-19 19:42:20.000000000 +0400
++++ CMakeLists.txt 2008-12-31 11:24:59.000000000 +0300
@@ -4,7 +4,6 @@
SET(CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE ON)