aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/kmess/files
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2006-06-04 23:29:21 +0800
committermarkus <markus@FreeBSD.org>2006-06-04 23:29:21 +0800
commitfb97757e401a33a2c5b7e223901c03e4ccf015d1 (patch)
tree6cde3e51dcd802d7ed69f538c2261bbbf4d5faf1 /net-im/kmess/files
parentdb62e2098a01f1b212c4c2f0a6597291cba14b3c (diff)
downloadfreebsd-ports-gnome-fb97757e401a33a2c5b7e223901c03e4ccf015d1.tar.gz
freebsd-ports-gnome-fb97757e401a33a2c5b7e223901c03e4ccf015d1.tar.zst
freebsd-ports-gnome-fb97757e401a33a2c5b7e223901c03e4ccf015d1.zip
- Unbreak by updating to version 1.4.3
- Drop now unneeded dependency to deskutils/kdepim3
Diffstat (limited to 'net-im/kmess/files')
-rw-r--r--net-im/kmess/files/patch-kmess-Makefile.in11
-rw-r--r--net-im/kmess/files/patch-kmess-crypt-bithelp.h11
-rw-r--r--net-im/kmess/files/patch-kmess-crypt-globalstuff.h13
-rw-r--r--net-im/kmess/files/patch-kmess-kmessview.cpp11
-rw-r--r--net-im/kmess/files/patch-kmess-kmessview.h10
-rw-r--r--net-im/kmess/files/patch-kmess-network-applications-p2papplication.cpp11
6 files changed, 67 insertions, 0 deletions
diff --git a/net-im/kmess/files/patch-kmess-Makefile.in b/net-im/kmess/files/patch-kmess-Makefile.in
new file mode 100644
index 000000000000..17a9da05f3fd
--- /dev/null
+++ b/net-im/kmess/files/patch-kmess-Makefile.in
@@ -0,0 +1,11 @@
+--- kmess/Makefile.in.orig Sun Jun 4 16:44:43 2006
++++ kmess/Makefile.in Sun Jun 4 16:45:06 2006
+@@ -470,7 +470,7 @@
+
+ # the library search path.
+ # the -lpthread is required for Autopackage/BinReloc
+-kmess_LDFLAGS = $(KDE_RPATH) $(all_libraries) -lpthread
++kmess_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+ AM_CXXFLAGS = -ggdb
+ #>- all: all-recursive
+ #>+ 1
diff --git a/net-im/kmess/files/patch-kmess-crypt-bithelp.h b/net-im/kmess/files/patch-kmess-crypt-bithelp.h
new file mode 100644
index 000000000000..5a20fc68d008
--- /dev/null
+++ b/net-im/kmess/files/patch-kmess-crypt-bithelp.h
@@ -0,0 +1,11 @@
+--- kmess/crypt/bithelp.h.orig Sun Jun 4 13:38:04 2006
++++ kmess/crypt/bithelp.h Sun Jun 4 13:39:09 2006
+@@ -20,8 +20,6 @@
+ #ifndef G10_BITHELP_H
+ #define G10_BITHELP_H
+
+-#include <stdint.h>
+-
+ /****************
+ * Rotate the 32 bit unsigned integer X by N bits left/right
+ */
diff --git a/net-im/kmess/files/patch-kmess-crypt-globalstuff.h b/net-im/kmess/files/patch-kmess-crypt-globalstuff.h
new file mode 100644
index 000000000000..1d0262dde5da
--- /dev/null
+++ b/net-im/kmess/files/patch-kmess-crypt-globalstuff.h
@@ -0,0 +1,13 @@
+--- kmess/crypt/globalstuff.h.orig Fri May 21 04:00:44 2004
++++ kmess/crypt/globalstuff.h Sun Jun 4 13:48:21 2006
+@@ -16,9 +16,9 @@
+
+ #include "config.h"
+
++#include <sys/types.h>
+ #include <string>
+ #include <sstream>
+-#include <stdint.h>
+
+ /** convert something to string using ostringstream */
+ template <class T> inline
diff --git a/net-im/kmess/files/patch-kmess-kmessview.cpp b/net-im/kmess/files/patch-kmess-kmessview.cpp
new file mode 100644
index 000000000000..4693121cec3a
--- /dev/null
+++ b/net-im/kmess/files/patch-kmess-kmessview.cpp
@@ -0,0 +1,11 @@
+--- kmess/kmessview.cpp.orig Sun Jun 4 15:13:33 2006
++++ kmess/kmessview.cpp Sun Jun 4 15:14:27 2006
+@@ -1058,7 +1058,7 @@
+ {
+ Contact *contact = getContactByItem( contactListView_->currentItem() );
+ Group *oldGroup = getGroupByItem( contactListView_->currentItem() );
+- QString oldGroupId = (oldGroup != 0 ? oldGroup->getId() : "0");
++ QString oldGroupId = (oldGroup != 0 ? oldGroup->getId() : QString::fromLatin1("0"));
+
+ if(contact != 0)
+ {
diff --git a/net-im/kmess/files/patch-kmess-kmessview.h b/net-im/kmess/files/patch-kmess-kmessview.h
new file mode 100644
index 000000000000..7af92df09078
--- /dev/null
+++ b/net-im/kmess/files/patch-kmess-kmessview.h
@@ -0,0 +1,10 @@
+--- kmess/kmessview.h.orig Sun Jun 4 15:46:03 2006
++++ kmess/kmessview.h Sun Jun 4 15:59:14 2006
+@@ -187,6 +187,7 @@
+ private:
+ KMessView *kmessView_;
+ };
++ friend class ToolTip;
+
+ // Reference to the current tooltip
+ ToolTip *toolTip_;
diff --git a/net-im/kmess/files/patch-kmess-network-applications-p2papplication.cpp b/net-im/kmess/files/patch-kmess-network-applications-p2papplication.cpp
new file mode 100644
index 000000000000..d01924ba3a6a
--- /dev/null
+++ b/net-im/kmess/files/patch-kmess-network-applications-p2papplication.cpp
@@ -0,0 +1,11 @@
+--- kmess/network/applications/p2papplication.cpp.orig Sun Jun 4 15:00:05 2006
++++ kmess/network/applications/p2papplication.cpp Sun Jun 4 15:00:44 2006
+@@ -2056,7 +2056,7 @@
+ // Get message content and Content-Type
+ bool gotTransferInvitation = (invitationContentType_ == "application/x-msnmsgr-transreqbody");
+ QString content = message.getFields();
+- QString contentType = (gotTransferInvitation ? "application/x-msnmsgr-transrespbody" : invitationContentType_);
++ QString contentType = (gotTransferInvitation ? QString::fromLatin1("application/x-msnmsgr-transrespbody") : invitationContentType_);
+
+ QString myHandle = CurrentAccount::instance()->getHandle();
+