aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/komclean
diff options
context:
space:
mode:
authorjacula <jacula@FreeBSD.org>2010-06-26 00:46:20 +0800
committerjacula <jacula@FreeBSD.org>2010-06-26 00:46:20 +0800
commit9d1445a4a10a65f2e0da44195a4f52c4f36eff71 (patch)
treea77754e238a0cb3598451ee936e2e063c2d7b95c /net-im/komclean
parenta10f2c1b43ae8051500a915a3ebd12ddeb91fd9b (diff)
downloadfreebsd-ports-gnome-9d1445a4a10a65f2e0da44195a4f52c4f36eff71.tar.gz
freebsd-ports-gnome-9d1445a4a10a65f2e0da44195a4f52c4f36eff71.tar.zst
freebsd-ports-gnome-9d1445a4a10a65f2e0da44195a4f52c4f36eff71.zip
KOMclean as a LysKOM client gives you a tray icon which can be used
to open your browser to view the UI. The UI is HTML based. WWW: http://sharesource.org/project/komclean/ PR: ports/144979 Submitted by: Piotr Smyrak <smyru@heron.pl> Approved by: tabthorpe (mentor) Feature safe: yes
Diffstat (limited to 'net-im/komclean')
-rw-r--r--net-im/komclean/Makefile59
-rw-r--r--net-im/komclean/distinfo3
-rw-r--r--net-im/komclean/pkg-descr4
-rw-r--r--net-im/komclean/pkg-plist28
4 files changed, 94 insertions, 0 deletions
diff --git a/net-im/komclean/Makefile b/net-im/komclean/Makefile
new file mode 100644
index 000000000000..9494573e1c3b
--- /dev/null
+++ b/net-im/komclean/Makefile
@@ -0,0 +1,59 @@
+# Ports collection makefile for: komclean
+# Date created: 23 March 2010
+# Whom: smyru@heron.pl
+#
+# $FreeBSD$
+#
+
+PORTNAME= komclean
+PORTVERSION= 1.1.0
+CATEGORIES= net-im
+MASTER_SITES= http://dl.sharesource.org/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= smyru@heron.pl
+COMMENT= Web based LysKOM client
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/Copyright.txt
+
+USE_GMAKE= yes
+USE_XORG= x11 xext xextproto xpm
+INSTALLS_ICONS= yes
+MAN1= komclean
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV= CPPFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+
+DESKTOP_ENTRIES="KOMclean" \
+ "${COMMENT}" \
+ "komclean.xpm" \
+ "komclean" \
+ "" \
+ ${FALSE}
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+.ifndef(WITH_PORT)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Define WITH_PORT=[port number] to change default port 8080"
+ @${ECHO_MSG}
+.endif
+
+pre-build:
+.ifdef(WITH_PORT)
+ ${REINPLACE_CMD} 's,8080,'${WITH_PORT}',' ${WRKSRC}/src/webui/httpserver.cpp
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/komclean ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/html/img
+ @${INSTALL_DATA} ${WRKSRC}/html/img/*.* ${DATADIR}/html/img
+ @${INSTALL_DATA} ${WRKSRC}/html/*.* ${DATADIR}/html
+ @${INSTALL_DATA} ${WRKSRC}/icon/icon_normal.xpm ${PREFIX}/share/pixmaps/komclean.xpm
+ @${INSTALL_MAN} ${WRKSRC}/komclean.1 ${MANPREFIX}/man/man1/komclean
+
+.include <bsd.port.post.mk>
diff --git a/net-im/komclean/distinfo b/net-im/komclean/distinfo
new file mode 100644
index 000000000000..c6ccae404270
--- /dev/null
+++ b/net-im/komclean/distinfo
@@ -0,0 +1,3 @@
+MD5 (komclean-1.1.0-src.tar.gz) = e7df9cc61becaf425eb450456996ceb1
+SHA256 (komclean-1.1.0-src.tar.gz) = d5c1dca4c71f933bcddeea151d4da90d6022a4f2ee872f85c10385f968194c0d
+SIZE (komclean-1.1.0-src.tar.gz) = 169095
diff --git a/net-im/komclean/pkg-descr b/net-im/komclean/pkg-descr
new file mode 100644
index 000000000000..c350ade1567c
--- /dev/null
+++ b/net-im/komclean/pkg-descr
@@ -0,0 +1,4 @@
+ KOMclean as a LysKOM client gives you a tray icon which can be used
+ to open your browser to view the UI. The UI is HTML based.
+
+ WWW: http://sharesource.org/project/komclean/
diff --git a/net-im/komclean/pkg-plist b/net-im/komclean/pkg-plist
new file mode 100644
index 000000000000..3d6e4ad31fb3
--- /dev/null
+++ b/net-im/komclean/pkg-plist
@@ -0,0 +1,28 @@
+bin/komclean
+%%DATADIR%%/html/favicon.ico
+%%DATADIR%%/html/favicon_unread.ico
+%%DATADIR%%/html/favicon_unread_msg.ico
+%%DATADIR%%/html/help.html
+%%DATADIR%%/html/img/bg_content.png
+%%DATADIR%%/html/img/bg_content_bottom.png
+%%DATADIR%%/html/img/bg_topbar.png
+%%DATADIR%%/html/img/bg_toplist.png
+%%DATADIR%%/html/img/fake_indent.png
+%%DATADIR%%/html/img/icon_new.png
+%%DATADIR%%/html/img/icon_unread.png
+%%DATADIR%%/html/img/progress.png
+%%DATADIR%%/html/img/star_gold.png
+%%DATADIR%%/html/img/star_gray.png
+%%DATADIR%%/html/index.html
+%%DATADIR%%/html/kom.js
+%%DATADIR%%/html/komadmin.js
+%%DATADIR%%/html/komclean.css
+%%DATADIR%%/html/komcleanlogin.css
+%%DATADIR%%/html/komcsel.js
+%%DATADIR%%/html/komimsg.js
+%%DATADIR%%/html/kommsg.js
+%%DATADIR%%/html/login.html
+share/pixmaps/komclean.xpm
+@dirrm %%DATADIR%%/html/img
+@dirrm %%DATADIR%%/html
+@dirrm %%DATADIR%%