aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/libmsn
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2008-12-29 05:03:53 +0800
committermakc <makc@FreeBSD.org>2008-12-29 05:03:53 +0800
commit3b78d053f519b84d36de22b672e0dff0f54476de (patch)
treecfb959374770d07a9d186191276055b694bc670a /net-im/libmsn
parent0c92c83390168c345c877c0d609df5c753375598 (diff)
downloadfreebsd-ports-gnome-3b78d053f519b84d36de22b672e0dff0f54476de.tar.gz
freebsd-ports-gnome-3b78d053f519b84d36de22b672e0dff0f54476de.tar.zst
freebsd-ports-gnome-3b78d053f519b84d36de22b672e0dff0f54476de.zip
Update to 4.0-beta2
PR: based on ports/129993 Submitted by: Shane Bell <decept0 at gmail.com> Approved by: miwi (mentor)
Diffstat (limited to 'net-im/libmsn')
-rw-r--r--net-im/libmsn/Makefile14
-rw-r--r--net-im/libmsn/distinfo6
-rw-r--r--net-im/libmsn/files/patch-msn__CMakeLists.txt11
-rw-r--r--net-im/libmsn/files/patch-msntest__CMakeLists.txt11
-rw-r--r--net-im/libmsn/pkg-descr15
-rw-r--r--net-im/libmsn/pkg-plist13
6 files changed, 42 insertions, 28 deletions
diff --git a/net-im/libmsn/Makefile b/net-im/libmsn/Makefile
index d999a6e3b294..fc9994b905f4 100644
--- a/net-im/libmsn/Makefile
+++ b/net-im/libmsn/Makefile
@@ -7,18 +7,16 @@
#
PORTNAME= libmsn
-PORTVERSION= 3.2
-PORTREVISION= 2
+DISTVERSION= 4.0-beta2
CATEGORIES= net-im
MASTER_SITES= SF
MAINTAINER= decept0@gmail.com
COMMENT= A library for connecting to MSN Messenger service
-LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
-
-USE_AUTOTOOLS= libtool:15
-GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_OPENSSL= yes
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
@@ -27,4 +25,8 @@ USE_LDCONFIG= yes
BROKEN= Does not compile on alpha
.endif
+pre-configure:
+ ${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|g' \
+ ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.post.mk>
diff --git a/net-im/libmsn/distinfo b/net-im/libmsn/distinfo
index 76a692690482..68650a6480a4 100644
--- a/net-im/libmsn/distinfo
+++ b/net-im/libmsn/distinfo
@@ -1,3 +1,3 @@
-MD5 (libmsn-3.2.tar.gz) = 6f931cd98522cecae823072f0e346879
-SHA256 (libmsn-3.2.tar.gz) = fefeff6ca52f4fa7ab04e15848ea61dee9736241d80c247e3b6a1d1a3af4d471
-SIZE (libmsn-3.2.tar.gz) = 653862
+MD5 (libmsn-4.0-beta2.tar.bz2) = e2088e987a44cef0b243b4adcb8c3825
+SHA256 (libmsn-4.0-beta2.tar.bz2) = 67079d81ede4b65376b61dc10d34ecfe27d53c0db7fd725592c21650b4d3e819
+SIZE (libmsn-4.0-beta2.tar.bz2) = 155319
diff --git a/net-im/libmsn/files/patch-msn__CMakeLists.txt b/net-im/libmsn/files/patch-msn__CMakeLists.txt
new file mode 100644
index 000000000000..ec7f3719e6e1
--- /dev/null
+++ b/net-im/libmsn/files/patch-msn__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./msn/CMakeLists.txt.orig 2008-11-18 18:17:55.000000000 +0300
++++ ./msn/CMakeLists.txt 2008-12-28 22:24:22.000000000 +0300
+@@ -43,7 +43,7 @@
+
+ add_library(msn SHARED ${msn_STAT_SRCS})
+ set_target_properties(msn PROPERTIES VERSION 0.1.0
+- SOVERSION 0.1
++ SOVERSION 0
+ )
+
+ if(NOT WIN32)
diff --git a/net-im/libmsn/files/patch-msntest__CMakeLists.txt b/net-im/libmsn/files/patch-msntest__CMakeLists.txt
new file mode 100644
index 000000000000..7c9fe10d25fd
--- /dev/null
+++ b/net-im/libmsn/files/patch-msntest__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./msntest/CMakeLists.txt.orig 2008-11-13 03:41:03.000000000 +0300
++++ ./msntest/CMakeLists.txt 2008-12-28 22:10:09.000000000 +0300
+@@ -3,7 +3,7 @@
+ )
+
+ add_executable (msntest ${msntest_SRCS} )
+-target_link_libraries(msntest crypto msn ssl)
++target_link_libraries(msntest crypto msn ssl compat)
+
+ ########### install files ###############
+ install(TARGETS msntest DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
diff --git a/net-im/libmsn/pkg-descr b/net-im/libmsn/pkg-descr
index 351a810d2499..3c4c85f79abe 100644
--- a/net-im/libmsn/pkg-descr
+++ b/net-im/libmsn/pkg-descr
@@ -1,15 +1,4 @@
-libmsn is a C++ library for Microsoft's MSN Messenger service. It provides a
-high-level interface that allows an application to access instant messaging
-features with ease.
-
-libmsn currently supports version 8 of the MSN Messenger protocol. This means
-that it supports the following features:
- * Login and logout.
- * Buddy presence notifications.
- * Buddy list management.
- * Privacy settings.
- * Conversations.
- * Typing notifications.
- * File transfers.
+Libmsn is a reusable, open-source, fully documented library for connecting to
+Microsoft's MSN Messenger service.
WWW: http://sourceforge.net/projects/libmsn/
diff --git a/net-im/libmsn/pkg-plist b/net-im/libmsn/pkg-plist
index 43200dcdd7b9..3d416ef7b18c 100644
--- a/net-im/libmsn/pkg-plist
+++ b/net-im/libmsn/pkg-plist
@@ -4,18 +4,19 @@ include/msn/buddy.h
include/msn/connection.h
include/msn/errorcodes.h
include/msn/externals.h
-include/msn/filetransfer.h
-include/msn/invitation.h
-include/msn/md5.h
+include/msn/libmsn_export.h
include/msn/message.h
include/msn/msn.h
+include/msn/msnobject.h
include/msn/notificationserver.h
+include/msn/p2p.h
include/msn/passport.h
+include/msn/soap.h
include/msn/sstream_fix.h
include/msn/switchboardserver.h
include/msn/util.h
-@dirrm include/msn
-lib/libmsn.a
-lib/libmsn.la
lib/libmsn.so
lib/libmsn.so.0
+lib/libmsn.so.0.1.0
+libdata/pkgconfig/libmsn.pc
+@dirrm include/msn