aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/libpurple
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-08-19 07:18:24 +0800
committermarcus <marcus@FreeBSD.org>2009-08-19 07:18:24 +0800
commitc148147312e9a1e495739268f8e3943c3ecdd622 (patch)
tree31a7563bfa0f17dce0a085ed293fa3ede3feda51 /net-im/libpurple
parent3ed6cdab7fe6baa5fb629c076e2973e9cfde4af7 (diff)
downloadfreebsd-ports-gnome-c148147312e9a1e495739268f8e3943c3ecdd622.tar.gz
freebsd-ports-gnome-c148147312e9a1e495739268f8e3943c3ecdd622.tar.zst
freebsd-ports-gnome-c148147312e9a1e495739268f8e3943c3ecdd622.zip
Switch back to using NSS as the befault TLS provider as GnuTLS is known to
be buggy with pidgin.
Diffstat (limited to 'net-im/libpurple')
-rw-r--r--net-im/libpurple/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index ac807afb2b74..f84fcd85d9f5 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.5.8
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pidgin
@@ -49,8 +49,8 @@ PRPL_MODULES=
OPTIONS= BONJOUR "Enable mDNS support" on \
DBUS "Enable DBUS bindings" on \
- GNUTLS "GNUTLS encryption support" on \
- NSS "Mozilla NSS encryption support" off \
+ GNUTLS "GNUTLS encryption support" off \
+ NSS "Mozilla NSS encryption support" on \
SASL "Cyrus SASL support (for jabberd)" off \
PERL "Perl scripting" off \
TCLTK "Tcl/Tk scripting" off \
@@ -113,7 +113,7 @@ CONFIGURE_ARGS+=--disable-cap
PLIST_SUB+= CAP="@comment not installed: "
.endif
-.if !defined(WITHOUT_GNUTLS)
+.if defined(WITH_GNUTLS)
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --enable-gnutls=yes
PLIST_SUB+= GNUTLS=""
@@ -122,7 +122,7 @@ CONFIGURE_ARGS+= --enable-gnutls=no
PLIST_SUB+= GNUTLS="@comment "
.endif
-.if defined(WITH_NSS)
+.if !defined(WITHOUT_NSS)
LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
CONFIGURE_ARGS+= --enable-nss=yes \
--with-nspr-includes=${LOCALBASE}/include/nspr \