aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/licq
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2000-08-16 02:56:30 +0800
committerBrian Feldman <green@FreeBSD.org>2000-08-16 02:56:30 +0800
commit5fb1f723108ed69d3b4df5c2a2f6ffe760aea481 (patch)
treece798ebfae9ec719235617db0aca7f54cc727a5f /net-im/licq
parent0ecef4ad105b362f67668139ab155ea1a9d9064e (diff)
downloadfreebsd-ports-gnome-5fb1f723108ed69d3b4df5c2a2f6ffe760aea481.tar.gz
freebsd-ports-gnome-5fb1f723108ed69d3b4df5c2a2f6ffe760aea481.tar.zst
freebsd-ports-gnome-5fb1f723108ed69d3b4df5c2a2f6ffe760aea481.zip
Since it makes very... promiscuous modes in the installation, create
the ${PREFIX}/share/licq directory with no external permissions at all while doing the installation, then whack the permissions into shape later before handing it off to the world. There is no race condition, but this is under the assumption that the installation routine doesn't chmod ${PREFIX}/share/licq itself! God only knows, with this autoconfed, libtooled...
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 71a1439620ec..4a3fe53beecd 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -56,6 +56,10 @@ post-build:
${SETENV} ${MAKE_ENV} \
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+pre-install:
+ ${RM} -rf ${PREFIX}/share/licq
+ ${MKDIR} -m 700 ${PREFIX}/share/licq
+
post-install:
strip ${PREFIX}/bin/licq
cd ${WRKSRC}/plugins/qt-gui;\
@@ -72,5 +76,7 @@ post-install:
${MKDIR} ${PREFIX}/share/licq/qt-gui
cd ${DATADIR}/qt-gui && ${TAR} -chf - * | \
${TAR} -xf - -C ${PREFIX}/share/licq/qt-gui
+ ${CHMOD} -R a-w ${PREFIX}/share/licq
+ ${CHMOD} 555 ${PREFIX}/share/licq
.include <bsd.port.mk>