aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mikutter
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2015-05-17 14:30:28 +0800
committertota <tota@FreeBSD.org>2015-05-17 14:30:28 +0800
commit2a4e653e80594922e6a91477778e30105e48c0cd (patch)
tree8036f3851cbdca9f2de6ab123fd049f6e2287e04 /net-im/mikutter
parentd084a8d22f1e35fc389679f00d5220c56250fb41 (diff)
downloadfreebsd-ports-gnome-2a4e653e80594922e6a91477778e30105e48c0cd.tar.gz
freebsd-ports-gnome-2a4e653e80594922e6a91477778e30105e48c0cd.tar.zst
freebsd-ports-gnome-2a4e653e80594922e6a91477778e30105e48c0cd.zip
- Update to 3.2.3
- Regenerate patch file with 'make makepatch' - Use USES=shebangfix instead of RUBY_SHEBANG_FILES - Remove RUBY_REQUIRE
Diffstat (limited to 'net-im/mikutter')
-rw-r--r--net-im/mikutter/Makefile22
-rw-r--r--net-im/mikutter/distinfo4
-rw-r--r--net-im/mikutter/files/patch-mikutter.rb12
3 files changed, 17 insertions, 21 deletions
diff --git a/net-im/mikutter/Makefile b/net-im/mikutter/Makefile
index fdb1422f5ece..8a0e89bdd829 100644
--- a/net-im/mikutter/Makefile
+++ b/net-im/mikutter/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mikutter
-PORTVERSION= 3.2.2
+PORTVERSION= 3.2.3
CATEGORIES= net-im ruby
MASTER_SITES= http://mikutter.hachune.net/bin/ \
LOCAL/tota/${PORTNAME}
@@ -14,7 +14,7 @@ COMMENT= Simple, powerful, and moeful Twitter client
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= rubygem-gtk2>=2.2.0:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
+RUN_DEPENDS= rubygem-gtk2>=2.2.5:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
rubygem-cairo>=1.12.9:${PORTSDIR}/graphics/rubygem-cairo \
rubygem-addressable>=2.3.6:${PORTSDIR}/www/rubygem-addressable \
rubygem-hmac>=0.4.0:${PORTSDIR}/security/rubygem-hmac \
@@ -30,13 +30,13 @@ RUN_DEPENDS= rubygem-gtk2>=2.2.0:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_RUBY= yes
+USES= shebangfix
NO_BUILD= yes
-RUBY_REQUIRE= Ruby >= 200
-RUBY_SHEBANG_FILES= mikutter.rb \
- core/miku/miku.rb \
- core/lib/piapro.rb \
- devel/makechi.rb
+SHEBANG_FILES= mikutter.rb \
+ core/miku/miku.rb \
+ core/lib/piapro.rb \
+ devel/makechi.rb
PORTDOCS= README
SUB_FILES= mikutter.desktop
@@ -50,11 +50,7 @@ NOTIFY_DESC= notify-send support
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.include <bsd.port.pre.mk>
-
-.if !defined(RUBY_PROVIDED)
-IGNORE= requires Ruby 2.0.0 or later
-.endif
+.include <bsd.port.options.mk>
HTTPCLIENT_RUN_DEPENDS= rubygem-httpclient>=0:${PORTSDIR}/www/rubygem-httpclient
NOTIFY_RUN_DEPENDS= notify-send:${PORTSDIR}/devel/libnotify
@@ -78,4 +74,4 @@ x-generate-plist: stage
${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/mikutter -type f | ${SORT} | ${SED} -e 's,${STAGEDIR}${RUBY_SITELIBDIR},%%RUBY_SITELIBDIR%%,' >> pkg-plist.new
${ECHO} share/applications/mikutter.desktop >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/mikutter/distinfo b/net-im/mikutter/distinfo
index 96ca262d3ab0..8ac13c019712 100644
--- a/net-im/mikutter/distinfo
+++ b/net-im/mikutter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mikutter.3.2.2.tar.gz) = 4a8b24a357ccd3132688f7ee97efb909a03a9b78976b19f92e3f50f56dd887ad
-SIZE (mikutter.3.2.2.tar.gz) = 2575294
+SHA256 (mikutter.3.2.3.tar.gz) = 7e4337d38a4a778dc001c5d9a315ef3f9646eec3c386e9686abc7f58a9e5f8f5
+SIZE (mikutter.3.2.3.tar.gz) = 2575579
diff --git a/net-im/mikutter/files/patch-mikutter.rb b/net-im/mikutter/files/patch-mikutter.rb
index 73fa18eb9ed7..2f0ee4a46994 100644
--- a/net-im/mikutter/files/patch-mikutter.rb
+++ b/net-im/mikutter/files/patch-mikutter.rb
@@ -1,11 +1,11 @@
---- mikutter.rb.orig 2013-06-12 02:55:23.699616516 +0000
-+++ mikutter.rb 2013-06-12 02:58:14.554656063 +0000
-@@ -11,7 +11,7 @@
- You should have received a copy of the GNU General Public License along with this program. If not, see <http://www.gnu.org/licenses/>.
+--- mikutter.rb.orig 2015-05-14 01:40:33 UTC
++++ mikutter.rb
+@@ -9,7 +9,7 @@ This software is released under the MIT
+ http://opensource.org/licenses/mit-license.php
=end
-mikutter_directory = File.expand_path(File.dirname(__FILE__))
+mikutter_directory = '%%RUBY_SITELIBDIR%%/mikutter'
- begin
- ENV['BUNDLE_GEMFILE'] = File.expand_path(File.join(File.dirname($0), "Gemfile"))
+ unless ENV['DISABLE_BUNDLER_SETUP']
+ begin