aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pidgin-birthday-reminder/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-23 17:04:15 +0800
committermiwi <miwi@FreeBSD.org>2009-04-23 17:04:15 +0800
commite068f7d786762fd6b06959d94ed681f58c0d2088 (patch)
treef65912b7e2494444c1e413ac9c79ed154029fb97 /net-im/pidgin-birthday-reminder/Makefile
parentd487ea9ec794cf58642a3106be66f84cf33f1e84 (diff)
downloadfreebsd-ports-gnome-e068f7d786762fd6b06959d94ed681f58c0d2088.tar.gz
freebsd-ports-gnome-e068f7d786762fd6b06959d94ed681f58c0d2088.tar.zst
freebsd-ports-gnome-e068f7d786762fd6b06959d94ed681f58c0d2088.zip
Reminds you of your buddies birthday.
WWW: http://freakazoid.teamblind.de/2009/02/14/pidgin-birthday-reminder/ PR: ports/133651 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'net-im/pidgin-birthday-reminder/Makefile')
-rw-r--r--net-im/pidgin-birthday-reminder/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-im/pidgin-birthday-reminder/Makefile b/net-im/pidgin-birthday-reminder/Makefile
new file mode 100644
index 000000000000..5ef1aa4ead70
--- /dev/null
+++ b/net-im/pidgin-birthday-reminder/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pidgin-birthday_reminder
+# Date created: 11 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= birthday_reminder
+PORTVERSION= 1.0
+CATEGORIES= net-im
+MASTER_SITES= http://freakazoid.teamblind.de/wp-content/uploads/
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= ports@logvinov.com
+COMMENT= The birthday reminder for Pidgin
+
+LIB_DEPENDS= purple.5:${PORTSDIR}/net-im/libpurple
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAKE_JOBS_SAFE= yes
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= pkgconfig intltool
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>