aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/py-slixmpp
diff options
context:
space:
mode:
author0mp <0mp@FreeBSD.org>2018-12-28 23:04:28 +0800
committer0mp <0mp@FreeBSD.org>2018-12-28 23:04:28 +0800
commit4e7a43729e6cbb86b1102f92a151d923341e8a64 (patch)
tree9d041a0b52a95567f9b262c10c2be1c86dbd4efc /net-im/py-slixmpp
parentf8905336bf5240f816c0163f797d50b05d481c69 (diff)
downloadfreebsd-ports-gnome-4e7a43729e6cbb86b1102f92a151d923341e8a64.tar.gz
freebsd-ports-gnome-4e7a43729e6cbb86b1102f92a151d923341e8a64.tar.zst
freebsd-ports-gnome-4e7a43729e6cbb86b1102f92a151d923341e8a64.zip
New port: net-im/py-slimxmpp: Threadless Poezio-oriented fork of SleekXMPP using asyncio
Slixmpp is an MIT licensed XMPP library for Python 3.5+. It is a fork of SleekXMPP. Slixmpp's goals is to only rewrite the core of the library (the low level socket handling, the timers, the events dispatching) in order to remove all threads. WWW: https://git.poez.io/slixmpp/ Reviewed by: mat Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D18668
Diffstat (limited to 'net-im/py-slixmpp')
-rw-r--r--net-im/py-slixmpp/Makefile27
-rw-r--r--net-im/py-slixmpp/distinfo3
-rw-r--r--net-im/py-slixmpp/pkg-descr8
3 files changed, 38 insertions, 0 deletions
diff --git a/net-im/py-slixmpp/Makefile b/net-im/py-slixmpp/Makefile
new file mode 100644
index 000000000000..012435fb0da2
--- /dev/null
+++ b/net-im/py-slixmpp/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= slixmpp
+DISTVERSION= 1.4.1
+CATEGORIES= net-im python
+MASTER_SITES= https://git.poez.io/slixmpp/snapshot/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= slix-${DISTVERSION}
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Threadless Poezio-oriented fork of SleekXMPP using asyncio
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libidn.so:dns/libidn
+TEST_DEPENDS= gpg:security/gnupg
+
+USES= python:3.5+
+USE_PYTHON= distutils autoplist cython
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} run_tests.py
+
+.include <bsd.port.mk>
diff --git a/net-im/py-slixmpp/distinfo b/net-im/py-slixmpp/distinfo
new file mode 100644
index 000000000000..a8c5bbee0fd0
--- /dev/null
+++ b/net-im/py-slixmpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545919194
+SHA256 (slix-1.4.1.tar.gz) = 2ae5755c9d593d5e2e31985dffe4829670d947273f78a7a34ec263617eece0d6
+SIZE (slix-1.4.1.tar.gz) = 1009754
diff --git a/net-im/py-slixmpp/pkg-descr b/net-im/py-slixmpp/pkg-descr
new file mode 100644
index 000000000000..5a474ccac990
--- /dev/null
+++ b/net-im/py-slixmpp/pkg-descr
@@ -0,0 +1,8 @@
+Slixmpp is an MIT licensed XMPP library for Python 3.5+. It is a fork of
+SleekXMPP.
+
+Slixmpp's goals is to only rewrite the core of the library (the low level
+socket handling, the timers, the events dispatching) in order to remove all
+threads.
+
+WWW: https://git.poez.io/slixmpp/