aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/quaternion
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-02-21 21:44:45 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2019-02-21 21:44:45 +0800
commit352fcc4279c5a2a10a07ddbac0d5691733e3fe8c (patch)
tree66e2911bfa96664595d407786d1dce8bd58c76f7 /net-im/quaternion
parent5a70701df6d73e66347817d702233b0cfd15e3b9 (diff)
downloadfreebsd-ports-gnome-352fcc4279c5a2a10a07ddbac0d5691733e3fe8c.tar.gz
freebsd-ports-gnome-352fcc4279c5a2a10a07ddbac0d5691733e3fe8c.tar.zst
freebsd-ports-gnome-352fcc4279c5a2a10a07ddbac0d5691733e3fe8c.zip
New Matrix IM desktop client and support-library.
Quaternion is a Matrix IM desktop client; Matrix is a "modern" IM solution, based on federated messaging and optional end-to-end encryption. The protocol and most implementations are entirely Open Source. This commit introduces a support library, net-im/libqmatrixclient, and one user of that library, net-im/quaternion. The library itself is used by other Qt-based Matrix IM clients as well but I needed *one* client, not three of them. The pkg-descrs are awful short, but there's really not much more to say than "a desktop Matrix IM client", since that's what it is. Listing features seems like useless fluff, since those are inherent in Matrix protocol support (avatars, image previews, long messages, etc.).
Diffstat (limited to 'net-im/quaternion')
-rw-r--r--net-im/quaternion/Makefile23
-rw-r--r--net-im/quaternion/distinfo3
-rw-r--r--net-im/quaternion/pkg-descr3
-rw-r--r--net-im/quaternion/pkg-plist12
4 files changed, 41 insertions, 0 deletions
diff --git a/net-im/quaternion/Makefile b/net-im/quaternion/Makefile
new file mode 100644
index 000000000000..0c4abfe6d185
--- /dev/null
+++ b/net-im/quaternion/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= Quaternion
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.9.3
+CATEGORIES= net-im
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Matrix IM client based on Qt technologies
+
+LICENSE= GPLv3
+LICENSE_FILES= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= QMatrixClient
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libQMatrixClient.a:net-im/libqmatrixclient
+
+USES= cmake qt:5 tar:xz
+USE_QT= core declarative gui network widgets \
+ buildtools_build linguist_build qmake_build
+
+.include <bsd.port.mk>
diff --git a/net-im/quaternion/distinfo b/net-im/quaternion/distinfo
new file mode 100644
index 000000000000..343e53e81d6c
--- /dev/null
+++ b/net-im/quaternion/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550755841
+SHA256 (QMatrixClient-Quaternion-v0.0.9.3_GH0.tar.gz) = 7f92c3acc73bb7e44efe94bd1085ae9fd5b58efa51efc28a931cace131c22230
+SIZE (QMatrixClient-Quaternion-v0.0.9.3_GH0.tar.gz) = 350366
diff --git a/net-im/quaternion/pkg-descr b/net-im/quaternion/pkg-descr
new file mode 100644
index 000000000000..da00e88f1c1c
--- /dev/null
+++ b/net-im/quaternion/pkg-descr
@@ -0,0 +1,3 @@
+Quaternion is a cross-platform desktop IM client for the Matrix protocol.
+
+WWW: https://github.com/QMatrixClient/Quaternion
diff --git a/net-im/quaternion/pkg-plist b/net-im/quaternion/pkg-plist
new file mode 100644
index 000000000000..5714f683e4a1
--- /dev/null
+++ b/net-im/quaternion/pkg-plist
@@ -0,0 +1,12 @@
+bin/quaternion
+share/QMatrixClient/quaternion/translations/quaternion_de_DE.qm
+share/QMatrixClient/quaternion/translations/quaternion_en.qm
+share/applications/quaternion.desktop
+share/icons/hicolor/128x128/apps/quaternion.png
+share/icons/hicolor/16x16/apps/quaternion.png
+share/icons/hicolor/22x22/apps/quaternion.png
+share/icons/hicolor/32x32/apps/quaternion.png
+share/icons/hicolor/48x48/apps/quaternion.png
+share/icons/hicolor/64x64/apps/quaternion.png
+share/icons/hicolor/scalable/apps/quaternion.svgz
+share/metainfo/com.github.quaternion.appdata.xml