aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ricochet
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-01-10 21:20:59 +0800
committermiwi <miwi@FreeBSD.org>2016-01-10 21:20:59 +0800
commitb39a42b0244d5aa471cbeda2982f4456fb7b62b1 (patch)
tree095d416edba0674930c82350b495d63374a75d31 /net-im/ricochet
parent342bb5b6b99a999a9ac1d0f9bd41e9b71c80d7f3 (diff)
downloadfreebsd-ports-gnome-b39a42b0244d5aa471cbeda2982f4456fb7b62b1.tar.gz
freebsd-ports-gnome-b39a42b0244d5aa471cbeda2982f4456fb7b62b1.tar.zst
freebsd-ports-gnome-b39a42b0244d5aa471cbeda2982f4456fb7b62b1.zip
Anonymous peer-to-peer instant messenger working through the Tor network.
WWW: https://github.com/ricochet-im/ricochet PR: 200999 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Diffstat (limited to 'net-im/ricochet')
-rw-r--r--net-im/ricochet/Makefile33
-rw-r--r--net-im/ricochet/distinfo2
-rw-r--r--net-im/ricochet/files/patch-ricochet.pro26
-rw-r--r--net-im/ricochet/pkg-descr3
4 files changed, 64 insertions, 0 deletions
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
new file mode 100644
index 000000000000..41b2c11192db
--- /dev/null
+++ b/net-im/ricochet/Makefile
@@ -0,0 +1,33 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= ricochet
+PORTVERSION= 0.150620
+CATEGORIES= net-im net-p2p
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Anonymous peer-to-peer instant messenger
+
+LICENSE= RICOCHET
+LICENSE_NAME= Ricochet
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
+RUN_DEPENDS= tor:${PORTSDIR}/security/tor
+
+USE_GITHUB= yes
+GH_ACCOUNT= ricochet-im
+GH_TAGNAME= e31a0fb
+
+USES= compiler:c++11-lib gmake pkgconfig qmake
+USE_OPENSSL= yes
+USE_QT5= core gui network quick quickcontrols widgets multimedia buildtools_build linguisttools_build
+QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${LOCALBASE}
+
+PLIST_FILES= bin/ricochet \
+ share/applications/ricochet.desktop \
+ share/icons/hicolor/48x48/apps/ricochet.png \
+ share/icons/hicolor/scalable/apps/ricochet.svg
+
+.include <bsd.port.mk>
diff --git a/net-im/ricochet/distinfo b/net-im/ricochet/distinfo
new file mode 100644
index 000000000000..d27753d8ebd5
--- /dev/null
+++ b/net-im/ricochet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ricochet-im-ricochet-0.150620-e31a0fb_GH0.tar.gz) = 41d2f1265094b00085250c934ae065b87893baa79ec348b7d1c729e424a9fccc
+SIZE (ricochet-im-ricochet-0.150620-e31a0fb_GH0.tar.gz) = 1197163
diff --git a/net-im/ricochet/files/patch-ricochet.pro b/net-im/ricochet/files/patch-ricochet.pro
new file mode 100644
index 000000000000..dcd1476601a0
--- /dev/null
+++ b/net-im/ricochet/files/patch-ricochet.pro
@@ -0,0 +1,26 @@
+--- ricochet.pro.orig 2015-06-17 04:00:47 UTC
++++ ricochet.pro
+@@ -46,18 +46,18 @@ CONFIG(release,debug|release):DEFINES +=
+
+ contains(DEFINES, RICOCHET_NO_PORTABLE) {
+ unix:!macx {
+- target.path = /usr/bin
+- shortcut.path = /usr/share/applications
++ target.path = $$PREFIX/bin
++ shortcut.path = $$PREFIX/share/applications
+ shortcut.files = src/ricochet.desktop
+- icon.path = /usr/share/icons/hicolor/48x48/apps/
++ icon.path = $$PREFIX/share/icons/hicolor/48x48/apps/
+ icon.files = icons/ricochet.png
+- scalable_icon.path = /usr/share/icons/hicolor/scalable/apps/
++ scalable_icon.path = $$PREFIX/share/icons/hicolor/scalable/apps/
+ scalable_icon.files = icons/ricochet.svg
+ INSTALLS += target shortcut icon scalable_icon
+
+ exists(tor) {
+ message(Adding bundled Tor to installations)
+- bundletor.path = /usr/lib/ricochet/tor/
++ bundletor.path = $$PREFIX/lib/ricochet/tor/
+ bundletor.files = tor/*
+ INSTALLS += bundletor
+ DEFINES += BUNDLED_TOR_PATH=\\\"/usr/lib/ricochet/tor/\\\"
diff --git a/net-im/ricochet/pkg-descr b/net-im/ricochet/pkg-descr
new file mode 100644
index 000000000000..733b4f6b49f0
--- /dev/null
+++ b/net-im/ricochet/pkg-descr
@@ -0,0 +1,3 @@
+Anonymous peer-to-peer instant messenger working through the Tor network.
+
+WWW: https://github.com/ricochet-im/ricochet