aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/tkabber/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-11-14 23:10:05 +0800
committerosa <osa@FreeBSD.org>2003-11-14 23:10:05 +0800
commit43d1d3804682e1135d856bce7a461f672a50b866 (patch)
tree641840eec23196d7d35543007c81a64706703c4c /net-im/tkabber/Makefile
parent2ff4615f5cfeae584a61dfc0ee6871786976e9a3 (diff)
downloadfreebsd-ports-gnome-43d1d3804682e1135d856bce7a461f672a50b866.tar.gz
freebsd-ports-gnome-43d1d3804682e1135d856bce7a461f672a50b866.tar.zst
freebsd-ports-gnome-43d1d3804682e1135d856bce7a461f672a50b866.zip
Add a new port.
Tkabber is a free client for an instant messaging system called Jabber. It is written in Tcl/Tk and supports many features like support of unicode, ssl support, http proxy, file transfers and support of multi-user conference protocol. Submitted by: Alexander Timoshenko <gonzo@univ.kiev.ua> PR: 58389
Diffstat (limited to 'net-im/tkabber/Makefile')
-rw-r--r--net-im/tkabber/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-im/tkabber/Makefile b/net-im/tkabber/Makefile
new file mode 100644
index 000000000000..27d0e354c406
--- /dev/null
+++ b/net-im/tkabber/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: tkabber
+# Date created: 22 October 2003
+# Whom: Alexander Timoshenko <gonzo@univ.kiev.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkabber
+PORTVERSION= 0.9.5b
+CATEGORIES= net
+MASTER_SITES= http://www.jabberstudio.org/files/tkabber/
+DISTNAME= tkabber-0.9.5beta
+
+MAINTAINER= gonzo@univ.kiev.ua
+COMMENT= Tcl/Tk based jabber client
+
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
+ ${LOCALBASE}/lib/tcllib1.3/pkgIndex.tcl:${PORTSDIR}/devel/tcllib \
+ ${LOCALBASE}/lib/bwidget/pkgIndex.tcl:${PORTSDIR}/x11-toolkits/bwidget
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+NO_BUILD= yes
+
+SUBDIRS = emoticons-tkabber \
+ plugins \
+ jabberlib-tclxml \
+ pixmaps \
+ sounds \
+ textundo \
+ msgs \
+ mclistbox-1.02
+
+do-install:
+ ${ECHO} -e "#!/bin/sh\nexec wish8.4 ${DATADIR}/tkabber.tcl -name tkabber \"\$$@\"\n" > ${PREFIX}/bin/tkabber
+ ${CHMOD} +x ${PREFIX}/bin/tkabber
+ ${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/*.tcl ${WRKSRC}/*.xrdb ${DATADIR}
+.for i in ${SUBDIRS}
+ ${CP} -R ${WRKSRC}/${i} ${DATADIR}
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in tkabber.html tkabber.xml
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>