aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/uTox
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-17 00:01:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-17 00:01:29 +0800
commite95f5244bce3090bd42524910a2638c86456a0ae (patch)
tree40618223405b9e9683a1548055f5030e04245d13 /net-im/uTox
parent1d88ad59e4aee625c3edefb460e7681b2813a17c (diff)
downloadfreebsd-ports-gnome-e95f5244bce3090bd42524910a2638c86456a0ae.tar.gz
freebsd-ports-gnome-e95f5244bce3090bd42524910a2638c86456a0ae.tar.zst
freebsd-ports-gnome-e95f5244bce3090bd42524910a2638c86456a0ae.zip
- Update to 0.8.2.20160511
PR: 209424 Submitted by: fidaj@ukr.net (maintainer)
Diffstat (limited to 'net-im/uTox')
-rw-r--r--net-im/uTox/Makefile4
-rw-r--r--net-im/uTox/distinfo4
-rw-r--r--net-im/uTox/files/patch-Makefile5
-rw-r--r--net-im/uTox/files/patch-src_main.h11
-rw-r--r--net-im/uTox/files/patch-src_ui.c4
-rw-r--r--net-im/uTox/files/patch-src_xlib_main.c29
-rw-r--r--net-im/uTox/files/patch-src_xlib_video.c12
7 files changed, 60 insertions, 9 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index 9ad908654d16..60bc11bef973 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= uTox
-PORTVERSION= 0.7.0.20160321
+PORTVERSION= 0.8.2.20160511
CATEGORIES= net-im net-p2p
MAINTAINER= fidaj@ukr.net
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= GrayHatter
-GH_TAGNAME= 9524f98
+GH_TAGNAME= cc4388c
USES= compiler:c11 desktop-file-utils gmake openal:al pkgconfig
USE_XORG= x11 xext xrender
diff --git a/net-im/uTox/distinfo b/net-im/uTox/distinfo
index 64d055a6cf9b..63de3acfa206 100644
--- a/net-im/uTox/distinfo
+++ b/net-im/uTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GrayHatter-uTox-0.7.0.20160321-9524f98_GH0.tar.gz) = 5e6a6023e63ec77f5378541ed5f03981aa8b71b5586d8b02b24335dfcc88a636
-SIZE (GrayHatter-uTox-0.7.0.20160321-9524f98_GH0.tar.gz) = 1986717
+SHA256 (GrayHatter-uTox-0.8.2.20160511-cc4388c_GH0.tar.gz) = 7c436cec5bd524ffcce3e1824dbebb7a93a121d0bc5d6860f8dadd1494e67067
+SIZE (GrayHatter-uTox-0.8.2.20160511-cc4388c_GH0.tar.gz) = 2015584
diff --git a/net-im/uTox/files/patch-Makefile b/net-im/uTox/files/patch-Makefile
index d14d9738a252..b5fe71591864 100644
--- a/net-im/uTox/files/patch-Makefile
+++ b/net-im/uTox/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2016-03-21 02:14:57 UTC
+--- Makefile.orig 2016-05-10 07:09:15 UTC
+++ Makefile
@@ -2,9 +2,9 @@
# set to anything else to disable them
@@ -12,7 +12,7 @@
DEPS = libtoxav libtoxcore openal vpx libsodium
-@@ -53,6 +53,37 @@ ifeq ($(UNAME_S), Linux)
+@@ -54,6 +54,37 @@ ifeq ($(UNAME_S), Linux)
TRAY_OBJ = icons/utox-128x128.o
TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
@@ -49,4 +49,3 @@
+ TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
else ifeq ($(UNAME_O), Cygwin)
OUT_FILE = utox.exe
-
diff --git a/net-im/uTox/files/patch-src_main.h b/net-im/uTox/files/patch-src_main.h
new file mode 100644
index 000000000000..2576d875c3af
--- /dev/null
+++ b/net-im/uTox/files/patch-src_main.h
@@ -0,0 +1,11 @@
+--- src/main.h.orig 2016-05-13 18:05:27.586256000 +0300
++++ src/main.h 2016-05-13 18:06:21.738883000 +0300
+@@ -74,7 +74,7 @@
+ #define volatile(x) (*((volatile typeof(x)*)&x))
+ #endif */
+
+-#ifndef __OBJC__
++#if !defined(__OBJC__) && !defined(__NetBSD__) && !defined(__FreeBSD__)
+ #define volatile(x) (x)
+ #endif
+ /* UTOX_SCALE is used as the default so that we have a lot of options for scale size.
diff --git a/net-im/uTox/files/patch-src_ui.c b/net-im/uTox/files/patch-src_ui.c
index 0e496b11e771..c91c997e4c15 100644
--- a/net-im/uTox/files/patch-src_ui.c
+++ b/net-im/uTox/files/patch-src_ui.c
@@ -1,6 +1,6 @@
---- src/ui.c.orig 2016-03-21 02:14:57 UTC
+--- src/ui.c.orig 2016-05-10 07:09:15 UTC
+++ src/ui.c
-@@ -275,16 +275,9 @@ static void draw_settings_header(int UNU
+@@ -271,16 +271,9 @@ static void draw_settings_header(int UNU
setfont(FONT_SELF_NAME);
drawstr(MAIN_LEFT + SCALE(10), SCALE(10), UTOX_SETTINGS);
#ifdef GIT_VERSION
diff --git a/net-im/uTox/files/patch-src_xlib_main.c b/net-im/uTox/files/patch-src_xlib_main.c
new file mode 100644
index 000000000000..a8e6eb8c20c8
--- /dev/null
+++ b/net-im/uTox/files/patch-src_xlib_main.c
@@ -0,0 +1,29 @@
+--- src/xlib/main.c.orig 2016-05-13 17:52:03.371614000 +0300
++++ src/xlib/main.c 2016-05-13 17:53:38.294993000 +0300
+@@ -73,8 +73,9 @@
+ XFlush(display);
+ }
+
+-
++#ifdef __LINUX__
+ #include <linux/input.h>
++#endif
+ FILE *ptt_keyboard_handle;
+ Display *ptt_display;
+ void init_ptt(void){
+@@ -100,6 +101,7 @@
+ int ptt_key;
+
+ /* First, we try for direct access to the keyboard. */
++#ifdef __LINUX__
+ ptt_key = KEY_LEFTCTRL; // TODO allow user to change this...
+ if (ptt_keyboard_handle) {
+ /* Nice! we have direct access to the keyboard! */
+@@ -117,6 +119,7 @@
+ return 0;
+ }
+ }
++#endif
+ /* Okay nope, lets' fallback to xinput... *pouts*
+ * Fall back to Querying the X for the current keymap. */
+ ptt_key = XKeysymToKeycode(display, XK_Control_L);
diff --git a/net-im/uTox/files/patch-src_xlib_video.c b/net-im/uTox/files/patch-src_xlib_video.c
new file mode 100644
index 000000000000..416ef225cb7e
--- /dev/null
+++ b/net-im/uTox/files/patch-src_xlib_video.c
@@ -0,0 +1,12 @@
+--- src/xlib/video.c.orig 2016-05-13 18:12:01.175591000 +0300
++++ src/xlib/video.c 2016-05-13 18:12:27.944571000 +0300
+@@ -152,6 +152,9 @@
+ if(isdesktop(handle)) {
+ utox_v4l_fd = -1;
+
++#ifndef volatile
++#define volatile(x) (*((volatile typeof(x)*)&x))
++#endif
+ video_x = volatile(grabx);
+ video_y = volatile(graby);
+ video_width = volatile(grabpx);